mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik AVR-Doper + Win XP Problem


Autor: Paul Baumann (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe gerade einen sog. AVR-Doper:
http://www.obdev.at/products/avrusb/avrdoper.html

fertiggestellt und an meinen XP-Rechner gesteckt. Das Gerät wird erkannt
und steht im Gerätemanager unter "Eingabegeräte" als "HID-konformes 
Gerät"
und auch noch als "USB-HID (human Interface Device)".
Diese Treiber stammen aber beide von Micro-Soft, nicht von Obdev.

Nun stellt sich mir die Frage, wie ich das Gerät im AVR-Studio 
ansprechen soll. Meiner Ansicht nach müßte es doch einen Treiber für 
eine virtuelle COM-Schnittstelle geben, damit sich das Gerät "scheinbar" 
als STK500
zeigt.

Auf der Seite von "Obdev" finde ich keine Informationen dazu.

Hat schon mal jemand so einen AVR-Doper mit XP und AVR-Studio oder 
Bascom in Betrieb genommen?

MfG Paul

Autor: Paul Baumann (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hinweis für Leute, die das gleiche Problem haben könnten: Der 
"Ziehwiderstand" zwischen Anschluß 2 der USB-Buchse und +Ub muß von 2,2 
Kiloohm auf 1,5 Kiloohm verringert werden, dann wird der Avr-Doper als
"Communication Device" erkannt und der Treiber kann installiert werden.

Er erhält dadurch eine virtuelle serielle Schnittstelle und meldet sich 
im AVR-Studio als STK 500.

MfG Paul

Autor: Thomas Dehler (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Doku nicht gelesen?
Für die zwei möglichen Betriebsarten gibts den Jumper "USB HID".

Gesetzt: Avr-Doper meldet sich als HID-Device; läuft mit avrdude aber 
nicht mit AVR-Studio.

Nicht gesetzt: Avr-Doper meldet sich als zusätzlichen COM-Port an und 
läuft dann auch mit AVR-Studio.

Vor- und Nachteile beider Modi sind ebenfalls in der Doku aufgeführt.

Autor: Paul Baumann (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Doku nicht gelesen?

Doch, doch! Doku sogar mehrfach gelesen. ;-)

>Gesetzt: Avr-Doper meldet sich als HID-Device; läuft mit avrdude aber
>nicht mit AVR-Studio.

Das stimmt (habe ich oben auch so geschrieben)

>Nicht gesetzt: Avr-Doper meldet sich als zusätzlichen COM-Port an und
>läuft dann auch mit AVR-Studio.

...und genau das tat er nicht, da der Widerstand (siehe oben) zu groß 
dimensioniert war.

MfG Paul

Autor: Thomas Dehler (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Tja, muss wohl ein Problem mit deinem PC gewesen sein.
Ich benutze den Programmer schon lange zusammen mit AVR-Studio, was ja 
nur mit der COM-Port Anbindung funktioniert. Läuft mit den 
Standardbauteilwerten von Anfang an problemlos.

Autor: Mike J. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich nehme mal an 1.5K Ohm ist der Standardwert?

2.2k ist bei Bulktransfer

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.