mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik DCF77-Modul von Pollin


Autor: Sebastian B. (sebastian86)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
moin zusammen

Ich hab gestern nun endlich das Modul von Pollin bekommen und wollte das 
natürlich direkt testen aber wenn ich VDD auf +5 V und GND auf Masse 
lege dann geht mein Netzteil auf Kurzschluß

kann ich davon ausgehen das das dcf modul hinüber ist ?oder mache ich 
was falsch. +


data und Pon hab ich ma frei gelassen


kann mir da jemand helfen ?


Gruß

Sebastian

Autor: Jupp (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Nun, die Wahrscheinlichkeit ist extrem groß, dass das Teil kaputt ist; 
überrascht mich allerdings nicht wirklich...

Autor: Jupp (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Könnte allerdings auch sein, dass die Beschreibung im Datenblatt falsch 
ist.

Autor: Sebastian B. (sebastian86)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also ich hab es folgendermaßen angeschloßen

x sind die Anschlüße wenn man von oben auf die platine guckt

und o sind die anschlßte zur antenne

 --------
|      x | +5V
|      x | GND
|      x | Data    //Data sowie PON noch nicht angeschlossen
|      x | PON
|        |
|        |
| o o    |
----------


warum überascht es dich nciht wirklich ?

Autor: Andreas K. (a-k)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das beiliegende Datasheet von Pollin ist korrekt.

Autor: Sebastian B. (sebastian86)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Andreas Kaiser wrote:
> Das beiliegende Datasheet von Pollin ist korrekt.



jo danach hab ich es sngeschlossen und es geht auf kurzschluss wenn ich 
auf wiederstandmessung gehe meese ich 0,2 ohm oder so

auf der platine konnte ich bis zum schwarzen knubbel keinen kurzschluss 
erkennen :/

hört sich denke ich echt nach defekt an

Autor: Matthias Lenkeit (matten)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo

Ich habe auch Probleme mit dem DCF77modul von Pollin.
Hatte mir gleich 2 Stück bestellt, aber keines von beiden funktioniert.

Habe es an meiner funktionierenden Schaltung mit dem Conradmodul 
angeschlossen , PON wird direkt an einem Ausgang vom Atmega16 
gesteuert.Setze PON 5 sec auf High und dann auf Low aber es startet 
einfach nicht, es kommen jedenfalls keine Impulse.

Habe Standort schon etliche male verändert, mit den High->Low zeiten 
gespielt,
High->Low von hand ausprobiert, hab es die ganze Nacht durchlaufen 
lassen aber es kommt einfach nix.

Jemand eine Idee ?


Gruß matten

Autor: Andreas K. (a-k)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Antenne ausgerichtet?

Autor: Jupp (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Jemand eine Idee ?

Einpacken, zurückschicken, Geld verlangen.

Autor: Matthias Lenkeit (matten)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ja, ich habe auch die Antenne in vielen Richtungen Probiert.
Schliesse ich das Conradmodul an gehts sofort los.

Gruß matten

Autor: obake (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,

ähnliche Erfahrung: sehr grenzwertige Signalqualität des Pollin-Moduls, 
auch bei sorgfältiger Ausrichtung des Ferrit-Stabs unter Kontrolle des 
digitalen Ausgangs-Signals mit dem Oszi. Dann genügen schon  1-2° 
Änderung der Antennenposition, um das Signal wieder zum Verschwinden 
(tatsächlich: viele wilde Zacken...) zu bringen. Kontrollversuch mit dem 
Modul von C: Dabei keinerlei Probleme -- auch bei Drehung der Antenne um 
+/- 5° bleibt das Signal gut!

Autor: Haui (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hab mir demletzt auch DCF-77 von Pollin besorg.

Hatte anfangs auch Probleme .. hab den Original-Code (beispiel aus 
Bascom) verwendet und nichts hat geklappt.

Nach einigen vergeblichen versuchen hab ich das Modul an mein Oszi 
gehängt und siehe Da es Tacktet in Sekundenschriten.(wie es ja soll)

Hab mir nun ein eigenes Programm in Bascom geschrieben und siehe da es 
Klappt.

Hab auch ein älteres Modul von Big C . Das vom Empfang wesentlich 
schlechter ist.

Das Pollin-Teil funktioniert ohne Probleme noch in einer Metallbox :-)
Das Conradteil läuft nur direkt am Fenster.

Warum es mit dem Bascom-Beispielprogramm nicht funktioniert hab ist 
nicht kapiert . Das Signal von Beiden Modulen Sieht auf dem Oszi gleich 
aus ???

Nun gut .

PS Das Passt .. das Modul sendet aber nur nach einem High/Low wechsel an 
Pon.
    ||            (Achtung Pon nicht offen lassen sonst kommt mist an!
    ||             immer auf GND ziehen )
    \/

 --------
|      x | +5V
|      x | GND
|      x | Data
|      x | PON
|        |
|        |
| o o    |
----------

Autor: ajax (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>PS Das Passt .. das Modul sendet aber nur nach einem High/Low wechsel an
>Pon.

Dann dürfte das wohl das Problem der anderen sein.

ajax

Autor: Matthias (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Pollin: Das mit der H/L-Flanke ist detailiert in der beiliegenden 
Beschreibung erläutert und kein größeres Problem. Es reicht auch eine 
RC-Kombination mit großem C. Schlechter finde ich die Tatsache, dass das 
Modul nach dieser Flanke bis zu 20 Minuten braucht, um das Signal zu 
liefern. Das ist unzumutbar.

Conrad liefert bereits nach wenigen Sekunden die Impulse, Reichelt-Modul 
nach knapper Minute, gerade noch tollerierbar.

HKW-Module legen sofort los, haben aber enorme Problem mit Störungen auf 
GND/VCC und laufen bei mir, wenn ein Schaltregler oder Ladungspumpe im 
Spiel ist, überhaupt nicht. (Auch nicht mit der üblichen Filtermaßnahme 
RC vor dem VCC-Anschluß).

Autor: Aike T. (biertrinker)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

habe auch 2 Module von Pollin. Leider geben die ein sehr wechselhaftes 
Bild ab. Ein Modul liefert relativ brauchbare Signale, nur am Anfang und 
am Ende scheint es etwas zu "prellen". Das konnte ich mit einem 100nF 
Kondensator direkt auf die Lötpads für Data und GND gelötet beheben.
Das zweite Modul ist Quallitativ nicht so gut, habe immer wieder 
Störungen mitten im Signal, und teilweise sind die Signale auch zu lang. 
Mit dem Zweiten modul konnte ich noch nix Sauber dekodieren.

viele Grüße

Aike

Autor: Lothar Sammel (magic33)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
wie muss der ferit kern ausgerichtet werden Horizontal oder vertikal

Autor: Jadeclaw Dinosaur (jadeclaw)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Horizontal und die Breitseite Richtung Frankfurt. Das gilt übrigens für 
alle DCF77-Empfänger. In Betonbauten ans Fenster oder Außenwand gehen.

Gruß
Jadeclaw.

Autor: Ulli (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Beim Pollin-DCF die H/L-Flanke am PON nicht vergessen. Sonst erfolgt 
kein Empfang. Die Flanke sollte erst ca. 2s nach dem Einschalten 
erfolgen. Wenn die Flanke erkannt wurde, quittiert das Modul dies mit 
einem kurzen Impuls am DCF-Ausgang.

Autor: lorxor (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo!
Ich habe das selbe Modul und habe auch Probleme gehabt.
Bei mir lags aber schlicht daran das ich überlesen hab dass das Modul 
Sink/Source Ausgang hat, und man daher den internen Pull-Up des AVRs 
manell deaktivieren muss. (Die BASCOM Routine setzt ihn standardmäßig 
auf an.)
Mit dem folgenden Code läuft das Modul bei mir einwandfrei:
(Wichtig ist das PORTD.2=0)

Config Portd = Input

Config Dcf77 = Pind.2 , Timer = 1 ,
Config Date = Dmy , Separator = .



Enable Interrupts
Portd.2 = 0

Do


  Waitms 500

  Upperline
  Lcd "Intern: " ; Time$ ; " " ; Date$ ; " "
  Lowerline
  Lcd "DCF: " ; Time(dcf_sec) ; " " ; Date(dcf_day) ; " "

  Upperline

Loop

End

Autor: Thomas K. (tomk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,

was so ein Modul von Pollin betrifft, kann ich wenig drüber sagen. Ich 
weiß schlicht nicht mehr genau, wo mein Modul herkommt (möglicherweise 
Conrad, aber wie schon gesagt, SEHR alt, mind. 5 Jahre!)

Eine lange Zeit funktionierte es relativ (!) gut an einem seriellen Port 
mit lediglich einigen wenigen Schalttransistoren und einer LED als 
Versorgung für ca. 1,5V.

Nachdem mich der "Wahnsinn" gepackt hatte und ich im Rahmen eines 
Serverwechsels auch das Modul, resp. die Anschalt-Elektronik verbessern 
wollte (d.h. MAX232 für den ser. Port) ... ging es praktisch nicht mehr.

"Praktisch nicht mehr" heißt: vom Grundsatz her funktioniert das Modul, 
ist aber EXTREM kitzlig, was Spannungen, Störungen über die Zuleitungen 
etc. betrifft! Das ging so weit, das ich nur wenige Minuten und nur 
nachmittags eine Synchronisation hinbekam.

Fazit: mit meiner ersten Schaltung und dem Aufstellort hatte ich 
schlicht Glück! (wobei ich mich entsinne, das ich damals auch reichlich 
"gefummelt" habe!)

Diese sehr einfachen Schaltungen sind nichts für aufwendigere 
Anschaltelektronik, allenfalls für einfache Batterie-betriebene Uhren!

Schönen Tag noch,
Thomas

Autor: Max (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Nachdem mich der "Wahnsinn" gepackt hatte und ich im Rahmen eines
>Serverwechsels auch das Modul, resp. die Anschalt-Elektronik verbessern
>wollte (d.h. MAX232 für den ser. Port) ... ging es praktisch nicht mehr.

MAX232 ist oft die Ursache für Empfangsprobleme bei DCF. Der IC hat zur 
Erzeugung der höheren Spannungen (meist so +-9V) eine getaktete, interne 
Ladungspumpe, die zu Störungen führt. Bei ordnungsgemäßer 
Abblockung/Layout ist dies aber durchaus in den Griff zu bekommen.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.