mikrocontroller.net

Forum: Platinen Eagle bindet Fläche nicht an zugehörige Pins an


Autor: Michael H* (Gast)
Datum:
Angehängte Dateien:
  • preview image for 1.png
    1.png
    115 KB, 252 Downloads

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich habe einen recht winzigen und vielbeinigen IC in Eagle - TQFP128 mit 
0,18mm Pinabstand.
Um die ganze Platine liegt eine Massefläche, aber mehrere benachbarte 
Masse-Pins des ICs werden nicht angebunden, sondern nur miteinander 
verbunden und dann ein Airwire zur nächsten Masse geschlagen.
Einzelne Beinchen, deren Nachbar nicht Masse ist, werden problemlos 
angebunden.

Ich hab jetzt versucht, eine zweite Massefläche mit kleinerer Width um 
den IC zu legen, aber auch das klappt nicht. Bei nicht ganz so winzigen 
ICs hat das mit Eagle funktioniert.

Auf dem ersten Bild sieht man die Polygonzüge der zweiten, dünneren 
Massefläche, deren Rank natürlich angepasst wurde.
Auf dem zweiten Bild dann die gerenderte Fläche mit nicht angebundenen 
Beinen.

Hat da vielleicht jemand eine Idee, was ich da falsch eingestellt habe?

Danke schon mal,
Grüße, holli

Autor: Michael H* (Gast)
Datum:
Angehängte Dateien:
  • preview image for 2.png
    2.png
    56,8 KB, 255 Downloads

Bewertung
0 lesenswert
nicht lesenswert
Und hier noch das zweite Bild

Autor: Εrnst B✶ (ernst)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hast du Eagle auch gesagt, dass dein Polygon mit GND verbunden gehört?

Autor: ... (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
oder das raster passt nicht zum pinabstand.
raster feiner stellen.

Autor: Ralf (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Eher Breite der Polygon-Wires anpassen. Wenn man die Width des Polygons 
reduziert, erhöht man zwar das Datenvolumen, aber die Leitungen werden 
auch angebunden.

Ralf

Autor: Ralf (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ach so, nochwas: prüf doch mal im DRC deinen erlaubten Mindestabstand 
von Signalen unterschiedlichen Potentials, vielleicht liegts auch daran.

Ralf

Autor: holli_als_gast (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Autor:  Ernst Bachmann (ernst)
> Hast du Eagle auch gesagt, dass dein Polygon mit GND verbunden gehört?
ja. einzelne pins werden ja auch angebunden.

Autor: ... (Gast)
> oder das raster passt nicht zum pinabstand.
> raster feiner stellen.
was sollte das mit dem raster zu tun haben? das polygon richtet sich 
doch nicht danach.
habs trotzdem probiert, nützt nichts.

Autor: Ralf (Gast)
> Eher Breite der Polygon-Wires anpassen. Wenn man die Width des Polygons
> reduziert, erhöht man zwar das Datenvolumen, aber die Leitungen werden
> auch angebunden.
hab ich schon geschrieben, dass ich das gemacht hab. sogar mit width 
0.01mm wird nix angebunden.

Autor: Ralf (Gast)
> Ach so, nochwas: prüf doch mal im DRC deinen erlaubten Mindestabstand
> von Signalen unterschiedlichen Potentials, vielleicht liegts auch daran.
liegt darunter.

=(

Autor: Simon K. (simon) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
... wrote:
> oder das raster passt nicht zum pinabstand.
> raster feiner stellen.

Nein, das ist deifnitiv falsch! Man kann auch problemlos Leitungen 
verlegen, wenn das Raster != dem Pinabstand ist. Zumindest mit EAGLE 
geht das problemlos.

EDIT: Hast du mal versucht den Isolate Wert des (inneren) Polygons 
kleiner zu stellen?

Autor: holli_als_gast (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Autor: Simon K. (simon) Benutzerseite
> EDIT: Hast du mal versucht den Isolate Wert des (inneren) Polygons
> kleiner zu stellen?
auch mit isolate=0 geht nix.

Autor: Philipp Burch (philipp_burch)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Vielleicht irre ich mich, aber gehen die Airwires nicht zum Bauteil auf 
BOTTOM? Oder welche Leitungen machen denn Probleme? Sieht doch 
ordentlich aus.

Autor: Michael H* (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ja, das is n bisschen seltsam, aber da geht auch der durchsteiger links 
neben dem bauteil auf masse. also die zuordnung stimmt schon.
er zieht ja auch kleine kurze stücke zu leiterbahn von der fläche zu den 
ic-beinchen, traut sich aber doch ned ganz ran.

auch komisch: wenn ich die 100 gnd-airwires per hand (route) verdrahte - 
auch die direkt nebeneinanderliegenden -, meckert eagle beim DRC-check 
nicht.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.