mikrocontroller.net

Forum: PC Hard- und Software LAMP System - welcher Rechner?


Autor: Martin Kohler (mkohler)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,
Ich möchte mir eine LAMP Testsystem aufbauen, um eine PHP Applikation 
realitätsnah entwickeln und auch debuggen zu können.

Welche Systemanforderungen sind da in etwa zu erwarten, damit der Server 
und das Debuggen einigermassen flüssig laufen wird.

Reicht da ein Athlon Rechner mit 800MHz und 512MB RAM?

Nein, es soll keine "Rakete" sein, sondern nur ein Test- und 
Debugrechner.

Autor: Andreas K. (a-k)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ja, locker.

Autor: Martin Kohler (mkohler)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Danke für die Antwort!

Weiss zufällig auch noch einer, wie ich am schnellsten (ohne 
detaillierte Linux-Kenntnisse) zum LAMP System komme?
Ich meinte, dass es da eine Quelle mit vorbereiteten Install-Files gab, 
doch finde ich die nicht mehr.

Autor: Gerard Choinka (gerardchoinka)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Was soll die Applikation den machen? wie groß ist die Datenbank (wenn 
die Datenbank groß ist, wird RAM sehr viel wichtiger als CPU MHz)

Autor: Martin Kohler (mkohler)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die Test-DB wird relativ übersichtlich bleiben, einige hundert Einträge 
mit jeweils ca. 500 Byte pro Eintrag, insgesamt ca. 20 Tabellen.

Es geht um eine Online-Kalender Applikation, nichts Multimedia-lastiges.

Autor: Andreas K. (a-k)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Einen LAMP Server installiert dir so ziemlich jede Linux-Distro auf 
Anfrage ohne sonderlich viel eigenes Zutun.

Such die also eine Distro deiner Wahl und probier's aus. Ubuntu wär' 
schon mal nicht schlecht für den Anfang, aber ich will dich da nicht 
festlegen (ich verwende für sowas debian direkt, aber damit sollte man 
nicht unbedingt anfangen).

Und deine Datenbank-Anforderung dürfte auch einen Pentium 200 mit 128MB 
nicht allzu sehr ins Schwitzen bringen. Die heute fast unvermeidliche 
GUI, die allerdings schon. ;-)

Autor: Gerard Choinka (gerardchoinka)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
dürfte sich um ein schnellen weg handeln um an einen lamp zu kommen
http://www.apachefriends.org/de/xampp-linux.html

Autor: Martin Kohler (mkohler)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Meine Wahl würde auch auf Ubuntu fallen.

Autor: Andreas K. (a-k)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wenn er noch kein Linux drauf hat, wär's wohl einfacher, das im Rahmen 
einer Distroinstallation zu tun, als zu Fuss nach Installation vom Linux 
(was ihn sowieso fragen wird, ob er das drauf haben will).

Autor: Andreas Schwarz (andreas) (Admin) Benutzerseite Flattr this
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Kostenloses VMWare + Ubuntu-Image. Dafür einen eigenen Rechner laufen zu 
lassen ist überflüssig.

Autor: Martin Kohler (mkohler)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Tönt eigentlich ganz vernünftig mit der VM.

Dann muss ich in VMWare also eine neue Virtual Machine erstellen, in 
dieser das Ubuntu ISO Image laden und installieren?

Autor: Andreas K. (a-k)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Korrekt.

Autor: Andreas Schwarz (andreas) (Admin) Benutzerseite Flattr this
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Du musst Ubuntu nicht mal installieren, es gibt fertige VMWare-Images 
die man direkt starten kann, z.B. hier: 
http://jars.de/linux/ubuntu-804-vmware-image-download

Autor: Martin Kohler (mkohler)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Sodele, das Ubuntu ist in der VM installiert.

Wie komme ich nun aus der VM auf das Netz/Internet?
Im Moment ist in der VM "Host-only" eingestellt, das wird wohl falsch 
sein.

Welche Einstellung ist zu wählen?

Autor: Andreas K. (a-k)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die einfachste Variante ist üblicherweise "Bridged", dann steht der 
virtuelle Rechner da wie ein separater Rechner im Hausnetz und ist auch 
aus diesem Netz erreichbar. Mit DHCP und allem.

Bei "Host only" besteht ein eigenes virtuelles Netz innerhalb der 
VMware-Umgebung und ein Pseudo-Adapter auf dem PC steckt da ebenfalls 
mit drin. Dessen Adressraum und DHCP-Eigenschaften lassen sich mit 
VMware Tools konfigurieren.

Autor: Martin Kohler (mkohler)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
VMWare Tools sind bei dieser VM nicht installiert. Ist das eine 
zwingende Voraussetzung?

Autor: Andreas K. (a-k)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Sorry, zweideutige Begriffswahl. Ich meinte den auf dem Trägersystem 
(host) installieren Virtual Network Editor. Jedenfalls heisst er auch 
bei VMware Workstation/Player so, der kostenlose VMware Server ist mir 
weniger vertraut als WS und ESX.

Autor: Martin Kohler (mkohler)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Verbindung nach "aussen" klappt noch nicht.

Das Host-System (WinXP) liefert folgende IP-Konfiguration:
C:\Programme\Gemeinsame Dateien\SYSTEM\MSMAPI\1031>ipconfig

Windows-IP-Konfiguration


Ethernetadapter VMware Network Adapter VMnet8:

        Verbindungsspezifisches DNS-Suffix:
        IP-Adresse. . . . . . . . . . . . : 192.168.88.1
        Subnetzmaske. . . . . . . . . . . : 255.255.255.0
        Standardgateway . . . . . . . . . :

Ethernetadapter VMware Network Adapter VMnet1:

        Verbindungsspezifisches DNS-Suffix:
        IP-Adresse. . . . . . . . . . . . : 192.168.144.1
        Subnetzmaske. . . . . . . . . . . : 255.255.255.0
        Standardgateway . . . . . . . . . :

Ethernetadapter LAN-Verbindung:

        Verbindungsspezifisches DNS-Suffix: root.kernworld.com
        IP-Adresse. . . . . . . . . . . . : 172.16.100.176
        Subnetzmaske. . . . . . . . . . . : 255.255.248.0
        Standardgateway . . . . . . . . . : 172.16.96.1

C:\Programme\Gemeinsame Dateien\SYSTEM\MSMAPI\1031>ping 192.168.88.1

Ping wird ausgeführt für 192.168.88.1 mit 32 Bytes Daten:

Antwort von 192.168.88.1: Bytes=32 Zeit<1ms TTL=128
Antwort von 192.168.88.1: Bytes=32 Zeit<1ms TTL=128
Antwort von 192.168.88.1: Bytes=32 Zeit<1ms TTL=128
Antwort von 192.168.88.1: Bytes=32 Zeit<1ms TTL=128

Ping-Statistik für 192.168.88.1:
    Pakete: Gesendet = 4, Empfangen = 4, Verloren = 0 (0% Verlust),
Ca. Zeitangaben in Millisek.:
    Minimum = 0ms, Maximum = 0ms, Mittelwert = 0ms

C:\Programme\Gemeinsame Dateien\SYSTEM\MSMAPI\1031>

Der VM Adapter hat also noch keinen Standard-Gateway. Wie initialisiere 
ich diesen?

Autor: Andreas K. (a-k)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Im "Host only" mode ist Verbindung nach aussen, d.h. an Rechner 
ausserhalb der virtuellen Umgebung inklusive des Träger-PCs, nicht 
sinnvoll. Und ein Standardgateway ist nur erforderlich, wenn man Ziele 
ausserhalb des Netzes ansprechen will, wird in diesem Modus also meist 
nicht benötigt. Und wenn doch, muss man das XP als Router schalten und 
dem Rest der Welt dies auch mitteilen.

Wie schon geschrieben: lass den "Host only" Mode sausen und nimm den 
"Bridged" Mode.

Autor: Martin Kohler (mkohler)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Mit "Bridged" funktioniert es auch nicht.

In der VM liefert "ifconfig" folgende Angaben:
eth1: inet Adresse:172.16.101.94

Im Host-System liefert "ipconfig" folgende Angaben:
C:\Programme\Gemeinsame Dateien\SYSTEM\MSMAPI\1031>ipconfig

Windows-IP-Konfiguration


Ethernetadapter VMware Network Adapter VMnet8:

        Verbindungsspezifisches DNS-Suffix:
        IP-Adresse. . . . . . . . . . . . : 192.168.88.1
        Subnetzmaske. . . . . . . . . . . : 255.255.255.0
        Standardgateway . . . . . . . . . :

Ethernetadapter VMware Network Adapter VMnet1:

        Verbindungsspezifisches DNS-Suffix:
        IP-Adresse. . . . . . . . . . . . : 192.168.144.1
        Subnetzmaske. . . . . . . . . . . : 255.255.255.0
        Standardgateway . . . . . . . . . :

Ethernetadapter LAN-Verbindung:

        Verbindungsspezifisches DNS-Suffix: root.kernworld.com
        IP-Adresse. . . . . . . . . . . . : 172.16.100.176
        Subnetzmaske. . . . . . . . . . . : 255.255.248.0
        Standardgateway . . . . . . . . . : 172.16.96.1

C:\Programme\Gemeinsame Dateien\SYSTEM\MSMAPI\1031>

Ein Ping vom Host an 172.16.101.94 (die Adresse aus der VM) funktioniert 
bei laufender VM.
Aus der VM heraus kann auch auf 172.16.100.176 gepingt werden.

Aus der VM heraus komme ich aber trotzdem nicht aufs Netz (z.B. Browser 
aufs Internet).
Was muss noch eingestellt werden?

Autor: Andreas K. (a-k)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Mach mal ein
  ifconfig
innerhalb der VM.

Funktioniert innerhalb der VM die Namensauflösung? Also:
  host www.mikrocontroller.net

Autor: Martin Kohler (mkohler)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
VM ifconfig ist im angehängten Bild,
Host ipconfig im vorangegangenen Beitrag.

Autor: Andreas Schwarz (andreas) (Admin) Benutzerseite Flattr this
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Stell mal in der VM das selbe Gateway wie im Host ein, dann sollte es 
laufen.

Autor: Martin Kohler (mkohler)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Martin Kohler wrote:
> Der VM Adapter hat also noch keinen Standard-Gateway. Wie initialisiere
> ich diesen?
So weit war ich schon mal ;-)

Wie stelle ich diesen in der VM ein?
In den VM Settings finde ich keine entsprechende Einstellmöglichkeit.

Autor: Gast (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Unter Ubuntu in der Datei /etc/network/interfaces sollte für das 
Netzwerkinterface ein Eintrag gateway stehen, jedenfalls ist das in der 
Nicht-GUI-Server-Ubuntu-Version so. Post mal die Datei hier!

Autor: Martin Kohler (mkohler)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Die Datei enthält (siehe Bild).

Autor: Andreas K. (a-k)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
netstat -r

Autor: Martin Kohler (mkohler)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
netstat -r liefert (siehe Anhang)

Autor: Martin Kohler (mkohler)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Ich kann übrigens das File "/etc/network/interfaces" nicht editieren, da 
erscheint die Fehlermeldung (siehe Anhang).

Wie komme ich zu der Berechtigung? Müsste doch irgendwas mit sudo sein, 
bloss wie starte ich da den Editor...

Autor: Gast (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hmm, dann wird das in der Desktop-Version wohl wo anders eingestellt. 
Schreib mal versuchsweise zusätzlich
auto eth1
iface eth1 inet dhcp

rein und gib auf der konsole

sudo /etc/init.d/networking restart

ein, dann sollte er sich von deinem dhcp router eine IP geben lassen.

Autor: Martin Kohler (mkohler)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
aaahhh!!!

mit "sudo gedit /etc/network/config" hats geklappt.

Autor: Gast (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die Datei ist nur für den Systemuser (root) schreibbar. Es müsste 
irgendwo ne Möglichkeit geben, den Editor als root auszuführen. Oder du 
verwendest einen Editor auf der Kommandozeile.

Autor: Martin Kohler (mkohler)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Gast
hat nichts gebracht, er findet schon die Befehle nicht.

Ich habe nun den Eintrag "gateway 172.16.96.1" ins config-File 
geschrieben und "sudo /etc/init.d/networking restart" ausgeführt.

-> Browser kommt immer noch nicht aufs Internet
-> Host "ipconfig" zeigt immer noch keine Standard-Gateways für die 
VM-Einträge.

Autor: Martin Kohler (mkohler)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Resultat der Eingaben gemäss "Gast":

Autor: Andreas K. (a-k)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wenn man mit DHCP arbeitet, dann sollte in /etc/networking kein Gateway 
stehen, weil das per DHCP übermittelt wird. Und der Gateway steht im 
netstat ja auch klar drin. Das ist also schon einmal kein Problem.

Nächster Test wäre
   traceroute www.mikrocontroller.net
Wenn du damit nicht aus deinem Netz rauskommst, wär mal mehr Information 
zu diesem Netz hilfreich. Etwas wie Firewall oder eine "böswillige" 
IV-Truppe die auf allem den Daumen drauf hat.

Autor: Andreas K. (a-k)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Martin Kohler wrote:

> Ich habe nun den Eintrag "gateway 172.16.96.1" ins config-File
> geschrieben und "sudo /etc/init.d/networking restart" ausgeführt.

Da gehört normalerweise entweder eine feste statische Konfiguration rein 
(also kein DHCP) oder die bestehende ist korrekt weil alle notwendige 
Info aus DHCP kommt.

> -> Host "ipconfig" zeigt immer noch keine Standard-Gateways für die
> VM-Einträge.

"ipconfig" gibts nur in Windows, und was in Windows passiert, das 
interessiert die VM nicht. Ausser vielleicht du hast eine Firewall auf 
der Windows Kiste, die die VM Kommunikation behindert.

Autor: Martin Kohler (mkohler)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
traceroute ist im verwendeten VMWare Image offenbar nicht installiert.

Autor: Andreas K. (a-k)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
aptitude install traceroute

Autor: Martin Kohler (mkohler)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Firewall ist die Windows XP SP2 Firewall drauf.

Es ist mir schon klar, dass "ipconfig" nur auf Windows existiert, da 
ging es ja auch nur drum zu zeigen, was das Host System (eben WinXP) für 
Einstellungen zeigt.

Autor: Andreas K. (a-k)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Martin Kohler wrote:

> Firewall ist die Windows XP SP2 Firewall drauf.

Schalte die mal testhalber ab. Ich weiss nicht inwieweit die vielleicht 
mitmischt.

> Es ist mir schon klar, dass "ipconfig" nur auf Windows existiert, da
> ging es ja auch nur drum zu zeigen, was das Host System (eben WinXP) für
> Einstellungen zeigt.

Jo, und die wird sich durch Aktivitäten in der VM nicht ändern.

Autor: Martin Kohler (mkohler)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Andreas Kaiser wrote:
> Schalte die mal testhalber ab. Ich weiss nicht inwieweit die vielleicht
> mitmischt.
Dazu habe ich nicht die Berechtigung, damit wären wir dann beim Thema 
IT-Gurkentruppe :-(

Autor: Martin Kohler (mkohler)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Andreas Kaiser wrote:
> aptitude install traceroute

Klar doch, wir saugen schnell was vom Netz, um das Netz zum Laufen zu 
kriegen (?).

Autor: Andreas K. (a-k)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Martin Kohler wrote:

> Klar doch, wir saugen schnell was vom Netz, um das Netz zum Laufen zu
> kriegen (?).

Ist ein Diagnosetool. Aber je nun - wenn diese "Gurkentruppe"(*) mit 
einem sepaten Rechner glücklicher ist als mit einem virtuellen, dann 
kommt halt doch wieder der Athlon 800 zum tragen ;-). Jedenfalls ist das 
ein Stadium, in dem diese "Gurkentruppe" mit im Boot ist.

(*) - ist mein Brotberuf...

Autor: Martin Kohler (mkohler)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Andreas Kaiser
Ok, dann lassen wir das mit dem Zugriff nach aussen aus der VM wohl 
sein.
Ich frage mal noch bei unserem internen "Hacker" nach, ob er eine Lösung 
weiss.

Zur Gurkentruppe:
Ich habe grundsätzlich nichts gegen IT-Admins, bitte nicht falsch 
verstehen.
Hier bei uns ist das aber so eine Sache, naja, Gurken eben...

Autor: Andreas Schwarz (andreas) (Admin) Benutzerseite Flattr this
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Martin Kohler wrote:
> Martin Kohler wrote:
>> Der VM Adapter hat also noch keinen Standard-Gateway. Wie initialisiere
>> ich diesen?
> So weit war ich schon mal ;-)

Ups.

> Wie stelle ich diesen in der VM ein?
> In den VM Settings finde ich keine entsprechende Einstellmöglichkeit.

Den musst du in Ubuntu einstellen, aber dazu musst man nicht in 
irgendwelchen Konfigurationsdateien rumwühlen, das geht ganz bequem im 
Menü Einstellungen - Netzwerk (oder so ähnlich).

Autor: Martin Kohler (mkohler)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Jetzt kommen wir der Sache schon näher ;-)

Der Proxy war nicht eingestellt, ich habe jetzt dieselben Einstellungen 
in >System>Einstellungen>Netzwerk Proxy eingegeben wie sie im FF auf dem 
Host-System eingetragen sind.
Jetzt klappt der Web-Zugriff nach aussen problemlos.

Und jetzt versuchen wir auch gleich noch, das traceroute zu 
installieren...

Autor: Martin Kohler (mkohler)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die Installation des traceroute schlägt immer noch fehl.
Bei der Netzwerk-Konfiguration habe ich unter Details die Login-Daten 
für den Proxy eingetragen, das scheint diesen aber nicht zu 
interessieren.

Ist da noch ein Reboot erforderlich?

Beim Start von FF wird nämlich auch immer nach den Proxy Login-Daten 
gefragt, obwohl diese ja unter 
>System>Einstellungen>Netzwerk-Proxy>Details eingetragen sind.

Autor: Timmo H. (masterfx)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich frage mich gerade, warum du überhaupt eine VM laufen lässt. xampp 
gibts doch für Windows. Da brauchst du noch nichtmal was installieren 
sonder kannst den/die Server einfach nach bedarf starten. Vorraussetzung 
ist dass der xampp Order frei auf der Festplatte ist, z.B. D:\xammp

Autor: Martin Kohler (mkohler)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Timmo H. wrote:
> Ich frage mich gerade, warum du überhaupt eine VM laufen lässt.
Das Zielsystem ist später ein Linux-Server. Es könnte somit ein Vorteil 
sein, die Applikation auch auf einem Linux System zu 
entwickeln/debuggen.

Autor: Martin Kohler (mkohler)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
LAMPP ist jetzt auf der VM installiert und gestartet, es gab keine 
Fehlermeldungen.

Beim Zugriff in der VM auf localhost fühlt sich aber immer noch der 
Proxy zuständig, obwohl in den Netzwerk-Proxy Einstellungen die 
Ausnahmen für localhost eingetragen sind.

Wie kann ich den Zugriff über den Proxy verhindern und auf den Server 
zugreifen?

Autor: Andreas K. (a-k)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Steht in den Ausnahmen auch die IP 127.0.0.1 drin?

Autor: Martin Kohler (mkohler)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Jepp.

Autor: Andreas K. (a-k)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich hab nicht parat, was genau für ein Format drin stehen muss. Am Ende 
ist's sowas wie "http://...";.

Autor: Martin Kohler (mkohler)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die ersten drei Einträge standen schon drin, werden also syntaktisch 
korrekt sein. Den dritten habe ich später selbst eingefügt, dieser ist 
aber eigentlich in 127.0.0.0/8 ja schon enthalten.

Ich tendiere nun eher zum Einsatz von XAMPP direkt auf der Windows-Kiste 
oder dem separaten Linux-Rechner.

Autor: Martin Kohler (mkohler)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe mich nun entschieden, dass ich XAMPP bis auf weiteres direkt 
auf dem Windows Rechner einsetze.
Ich bedanke mich für die angeregte und hilfreiche Diskussion!

Im Bereich "PC-Programmierung" wird gleich die Anschlussfrage auftauchen 
zum Entwickeln/Debuggen von PHP-Code.

Autor: Stefan B. (stefan) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Martin Kohler wrote:
> Meine Wahl würde auch auf Ubuntu fallen.

Gerade bei Hack A Day...

LAMP on Ubuntu
http://www.hackaday.com/2008/06/13/lamp-on-ubuntu/

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.