mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik Gleichspannung erzeugen


Autor: Thomas Starke (skit)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hi @ all,

ich habe folgendes Problemchen:

Ich suche eine Lösung für die Erzeugung einer regelbaren Gleichspannung 
aus einem Schieberegister für eine Modelleisenbahn.
Derzeit wird aus dem Schieberegister eine PWM erzeugt (120HZ), welche 
speziell für Glockenanckermotoren schädlich ist.

Ich habe versucht die PWM mittels abgewandelten RC Pass zu glätten. Dies 
funktioniert auch gut, wenn der Ausgang durch die Lok belastet ist.
Jedoch fährt die Lok bei normaler Fahrt über meherere dieser Regler, so 
dass die Lok bei Erreichen eines unbelasteten Reglers ein kleinen Sprung 
macht, da der Kondensator des RC Passes geladen ist.
Ein weiteres Problem besteht darin, dass das Schieberegister mit 12V 
(CMOS) betrieben wird, die Fahrspannung für die Lok jedoch mit 16V 
betrieben wird.
Beide Spannungen müssen galvanisch getrennt bleiben (wegen möglichen 
Kurzschlüssen auf dem Gleis).

Eine weitere Idee war ein Widerstandsgrab zu verwenden, um die Aussgänge 
des Schieberegister je nach Wertigkeit in eine analoge Spannung 
umzuwandeln. Die galvanische Trennung geschieht durch je einen 
Optokoppler pro Ausgang des Schieberegisters.

Eine andere Einschränkung besteht darin, dass keine negative Spannung 
für eventuelle Operations Verstärker zur Verfügung steht.

Hat jemand eine Idee, wie man so etwas umsetzten könnte ?

mfg skit

Autor: Sven P. (haku) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Du könntest das mit der PWM im "Kleinen" machen, also quasi PWM mit 
künstlich ausreichend belastetem RC-Glied (sodass die Spannung stets 
sauber ist). Dahinter dann eine Endstufe (Leistungs-OPV oder 
Transistoren/FETs, Verstärker halt).

Statt der PWM könnte man dann natürlich auch einen fertigen DAC benutzen 
und den mit der o.g. Methode aufbohren, um gut Leistung rauszuholen.

Autor: Random ... (thorstendb) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
DAC0832CN + TL074 (2 OPs werden gebraucht) + BD139?
Der DAC hat nen Stromausgang, daher erst ne Wandlung -> U. Dann ne 
zweite OPV-Stufe mit Ausgang an Basis des (Darlington) BD139, 
rückkopplung an den OPV.

Oder brauchste die PWM, um Verlustarm zu schalten?

VG,
/r.


PS: Oh, da hat mich einer überholt während ich die Bezeichnung für den 
BD suchte :-)

Autor: Knut Ballhause (Firma: TravelRec.) (travelrec) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wir haben auf unsere Anlage direkt das PWM gegeben, allerdings mit einer 
Frequenz von 19kHz(!). Das macht bislang (seit 3 Jahren) jede Lok mit, 
auch alte und neue Dampflokmodelle. 120Hz sind wohl für jeden 
Gleichstrommotor zu wenig - das brummt nur. Nicht vergessen, eine 
Freilaufdiode über die Gleisanschlüsse (vor die Richtungsumkehr) zu 
schalten, sonst überlagert die Gegeninduktion des Motors das PWM, was zu 
einem miserablen Wirkungsgrad führt. Idealerweise nimmt man dafür eine 
schnelle Schottky-Diode (MBRS140).

Autor: Paul Baumann (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe mal meine Schaltung für eine ähnliche Aufgabe angehangen. Die 
PWM
kommt von einem Attiny2313 und steuert den ersten OPV an. Der nächste 
dient dazu, die Fahrtrichtung umzuschalten. Das bewirkt der Transistor, 
der den OPV als invertierend/ nichtinvertierend umschaltet. Die letzten 
beiden dienen zur Erzeugung des nötigen "Hubes". Das funktioniert prima.


MfG Paul

Autor: Thomas Starke (skit)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@ Travel Rec.
das mit der PWM leuchtet ein, leider kann die bisherige Schaltung keine 
ausreichend große Frequenz erzeugen.

Grundsätzlich aber mal eine Frage zur Nutzung der PWM:
Die Eisenbahnanlage ist in Blöcke unterteilt. Jeder BLock wird von einem 
Fahrregler gesteuert. Beim Übergang von einem Fahrregler zu einem 
zweiten Fahrregler macht eine schnelle Lok jedoch einen gewaltigen 
Sprung. Ursache könnte dafür sein, dass die PWM von den beiden 
Fahrreglern nicht synchronisiert sind und sich daher überlagern, sodass 
für die Lok ein breiterer Puls ansteht solange sie mit beiden 
Fahrreglern verbunden ist.

Besteht bei euerer Anlage ein ähnliches Problem, und wenn ja wie habt 
ihr dieses behoben?

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.