mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik Problem mit aktivem Hochpass


Autor: T. H. (pumpkin) Benutzerseite
Datum:
Angehängte Dateien:
  • preview image for op.PNG
    op.PNG
    19,3 KB, 380 Downloads

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich hatte heute eine Schaltung vor mir wie sie im Anhang dargestellt 
ist. Diese soll einfach die Phase schieben, was sie auch wie gewünscht 
tut. Allerdings ist am Ausgang des Filters ein seltsames Verhalten 
festzustellen, ich habe mal versucht es zu skizzieren. Die Frequenz des 
Sinussignals beträgt 50Hz. Schließt man den Kondensator kurz, dann 
erhält man einen reinen Sinus. Quelle ist ein Impedanzwandler, Senke ist 
ein weiterer invertierender Verstärker (jeweils gleicher OP-Typ). Ich 
habe eine Vermutung kann diese aber nicht testen weil die Hardware 
gerade nicht da ist - mich würde aber interessieren was hier die 
erfahrenen Analogiker dazu sagen.

Autor: T. H. (pumpkin) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Öhm, keine Ideen? Oder zu wenig Info's?

nachobenschieb

Autor: Martin Laabs (mla)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das ist die Push-Pull Stufe im OPAmp die im Nullpunkt wohl den linearen 
Betrieb verlässt. Das sieht man zwar eher bei z.B. Audio-Endstufen aber 
warum sollte es nicht auch im Operationsverstärker vorkommen ...
Versuche den Ausgang mal etwas zu belasten und schau ob es besser wird.

Viele Grüße,
 Martin L.

Autor: gast (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
wiso ist R7 so gross?

Autor: HildeK (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>wiso ist R7 so gross?
Der hat die ideale Größe: R7 = R8! Auch wenn das hier keine Rolle 
spielt.

Man soll die beiden Eingänge eines OPAs möglichst mit dem gleichen 
DC-Quellwiderstand beschalten, dadurch kompensieren sich die 
DC-Offsetströme.

Leider weiß ich auch keine Erklärung für das Problem von T.H.

Autor: Helmut Lenzen (helmi1)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das sieht nach Übernahmeverzerrungen der Gegentaktendstufe des OPs aus.
Ich hatte dieses Problem auch mal bei einem Integrator.
Versuch mal einen Widerstand vom Ausgang zur + (oder -) 
Versorgungsspannung zu legen. Grössenordnung ein paar KOhm.

Gruss Helmi

Autor: Axel R. (axelr) Flattr this
Datum:

Bewertung
0 lesenswert
nicht lesenswert
HildeK wrote:
>>wiso ist R7 so gross?
> Der hat die ideale Größe: R7 = R8! Auch wenn das hier keine Rolle
> spielt.
>
> Man soll die beiden Eingänge eines OPAs möglichst mit dem gleichen
> DC-Quellwiderstand beschalten, dadurch kompensieren sich die
> DC-Offsetströme.
>
> Leider weiß ich auch keine Erklärung für das Problem von T.H.

Hatte ich im letzten Bewerbungsgespräch auch gesagt: "R7==R8"

Mir wurde gesagt: "R7==R8||R6".
Habe ich allerdings jetzt nicht weiter untersucht.
Mal Tietze/Schenk bzw. Klaus Schlenzig und Dieter Jung befragen ;-)

Sind ja komische Übernahmeverzerrungen am Ausgang.

Würde auch als erstes einen 1K am Ausgang gegen Masse probieren.

Viel Erfolg.
Axelr.

Autor: T. H. (pumpkin) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Super Jungens, werd' es mal probieren. Die Vermutung hatte ich auch, 
wäre aber nicht mein Favorit gewesen - mal sehen.

Zu R7: Ist zwar nicht meine Schaltung, aber normalerweise macht man eine 
DC-Offset-Kompensation. In dieser Konstellation nur R8 weil C9 DC-mäßig 
ein Leerlauf ist. Ansonsten R8||R6.

Autor: T. H. (pumpkin) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Nachtrag für den interessierten Leser: Tietze/Schenk/Gamm, S.539 in der 
12. Auflage.

Autor: HildeK (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Hatte ich im letzten Bewerbungsgespräch auch gesagt: "R7==R8"
>Mir wurde gesagt: "R7==R8||R6".
Das gilt dann, wenn der C9 nicht drin ist!

Autor: Detlef _a (detlef_a)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>>Hatte ich im letzten Bewerbungsgespräch auch gesagt: "R7==R8"
>>Mir wurde gesagt: "R7==R8||R6".
>Das gilt dann, wenn der C9 nicht drin ist!

Input bias current ist Gleichstrom!
Wieder was dabeigelernt!

THX
Cheers
Detlef

BTW @T.H.: Was ist denn mit den 'Übernahmeverzerrungen' ? Neue 
Erkenntnisse?

Autor: Karl (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Bei einer Übernahmeverzerrung wie sie eine Klasse B Endstufe macht, 
müsste aber die Verzerrung flach sein und nicht senkrecht, oder?

Autor: T. H. (pumpkin) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Karl wrote:
> Bei einer Übernahmeverzerrung wie sie eine Klasse B Endstufe macht,
> müsste aber die Verzerrung flach sein und nicht senkrecht, oder?

Kommt drauf an in welche "Richtung" die "Fehlanpassung" vorliegt.


Detlef _a wrote:
> BTW @T.H.: Was ist denn mit den 'Übernahmeverzerrungen' ? Neue
> Erkenntnisse?

Nein, bisher noch nicht dazu gekommen.  ;^)   Meld' mich dann...

Autor: Mainzelmännchenbeisser (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

Tipp 1: aktive Hochpässe und ihre Tücken sind im "Aktiv-Filter-Kochbuch" 
sehr gut beschrieben

Tipp 2: R7 soll dem Widerstand der Parallelschaltung aus R8 und der 
Reihenschaltung aus R6 und dem kapazitiven Widerstand Zc des C9 
entsprechen. Zc= 1/(2*Pi*C)  Dies erklärt aber nicht die Verzerrung.

Tipp3: Nachfolgend sei eine invertierende OP-Schaltung angeschlossen. 
Hat sie vielleicht einen zu geringen Eingangswiderstand? > 1KOhm wäre 
wünschenswert.

Tipp4: dürfte die Entscheidende Sache sein: Die invertierende Schaltung 
hat keinen Gleichstrompfad zum Eingang, weil C9 nur den Wechselanteil 
durchläßt. Du müßtest parallel zu C9 noch einen Widerstand 10... 100 
Kohm schalten, um den Gleichstromweg zum Eingang sicher zu stellen. Am 
invertierenden Eingang des OPV befindet sich in dieser Schlung ein 
Stromknoten an dem die Summe aller Ströme Null sein muß.

Autor: Peter (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Mit einem richtigen OP07 und der angegebenn Schaltung kann dieses 
Verhalten nicht sein.

- Wie sieht die komplette Schaltung aus?
  Vermutlich unterschlägst Du den entscheidenten Teil.

- Verwendest Du tatsächlich einen OP und nicht etwa einen Komperator?
  (Wirklich ein OP07?)

- Welche Skala haben die XY-Achsen im Diagramm (Spannung, Zeit)

- Ist das Verhalten wirklich so gemessen oder bloss simmuliert?
  (Simulationstool? Modelle?)

Autor: Peter (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@ Mainzelmännchenbeisser

Quatsch mit Sauce! Mach erst mal ein anständige E-Ausbildung/Studium 
bevor Du anderen solchen Unsinn erzählst:

>Tipp 2: R7 soll dem Widerstand der Parallelschaltung aus R8 und der
>Reihenschaltung aus R6 und dem kapazitiven Widerstand Zc des C9
>entsprechen. Zc= 1/(2*Pi*C)  Dies erklärt aber nicht die Verzerrung.

Wie oben schon geschrieben, zählt für die Offsetkompensation bloss der 
DC-Widerstand, R6 fällt somit wegen dem C9 weg!

>Tipp4: dürfte die Entscheidende Sache sein: Die invertierende Schaltung
>hat keinen Gleichstrompfad zum Eingang, weil C9 nur den Wechselanteil
>durchläßt.

Auch der Invertierende Eingang hat einen DC-Pfad, nämmlich über R8 zum 
Ausgang!

Autor: Axel R. (axelr) Flattr this
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Reicht das Gain-Bandwith-Product (heisst doch so?) aus?
Aber bei der recht geringen Frequenz dürfte das keine Rolle spielen.

FilterPro von TI gibt bei ähnlichen Konstellationen 150Khz GBP an.
der OP07 
http://www.datasheetcatalog.net/de/datasheets_pdf/...
ist mit 400kHz spezifiziert. Sollte also eigentlich passen.
Evtl. ganz simpel: die Betriebsspannung zu gering.

Probier doch enfach mal einen anderen OPV zum Vergleich.
(Es wird schon einene Grund haben, warum du den OP07 verwendest...)

Der Typ ist doch eigentlich nur (nur iss gut) auf minimale Offsetdrift 
gezüchtet.
Die spielt doch bei Wechselspannungen eher keine große Rolle, dachte 
ich.

Ich tippe auf zu geringe Betriebsspannung, betreibst Du denn den OPV 
tatsächlich mit +-15V, oder nur mit +5V?

Gruß
Axelr.

Autor: Rudi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Axel

>Ich tippe auf zu geringe Betriebsspannung, betreibst Du denn den OPV
>tatsächlich mit +-15V, oder nur mit +5V?

mit nur '+5V' wird's nicht sein, da er ja laut Diagramm eine negative 
Ausgangsspannung erzeugt. Wo aber soll die bei unipolarer 
Spannungsversorgung herkommen?

Zu geringe Versorgungsspannung ist auch eher unwahrscheinlich, denn dann 
würden die Amplituden gekappt werden.

Wie bereits erwähnt, wäre von Vorteil zu wissen, ob das 
Ausganggsdiagramm simuliert ist oder tatsächlich gemessen wurde. Auch 
die Werte der Achsen wäre interessant.

Rudi

Autor: Axel R. (axelr) Flattr this
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Rudi
stimmt, haste Recht ;-)

Autor: T. H. (pumpkin) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Beruhigung bitte! ;^)

Ich habe nichts unterschlagen. Vorne Impedanzwandler, hinten 
invertierender Verstärker, Eingangswiderstand ~5kOhm. Versorgung stabile 
+/-15V. Der OP07 ist ein sehr ordentlicher Operationsverstärker, kein 
Komperator. Der OP07 wurde mit Bedacht gewählt, gerade wegen dem sehr 
guten Offsetverhalten.

  http://www.alldatasheet.com/

Das beschriebene Verhalten wurde gemessen, mangels Scopeplot aber 
nachträglich zur Veranschaulichung nachgezeichnet. Die Simulation in 
SWCad hatte dieses Verhalten (mit realen Bauelementen) nicht gezeigt.

Wie dem auch sein, ich hab heute Zeit gehabt zu messen - der Fehler 
tritt nicht mehr auf. Keine Ahnung warum. Trotdem vielen Dank für alle 
Tips!

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.