mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik LED mit variabler spannung betreiben


Autor: jacob (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hallo ihr Ingenieure,

ich habe da folgende Frage.
Ich bastle momentan an einem batteriebetriebenen Messgerät. An dieses 
Messgerät sollen 10 Sensoren angeschlossen werden. Diese Sensoren 
bestehen aus einem Kabel, dass am losen Ende in einer alkalische 
Flüssigkeit liegt. Die 10 Kabelenden sollen senkrecht übereinander 
angeordnet werden. Im Messgerät soll dann über 10 LED’s eine Art 
Füllstandsmessung möglich sein. Da nun ganz unterschiedlich 
Flüssigkeiten mit unterschiedlichen spez. Widerständen verwendet werden, 
sind nun Spannungen zwischen 3-12 V möglich.
Die LED darf jedoch mit max 3V angesteuert werden. Nun also meine Frage, 
wie kann ich mit einem 3-12V Steuersignal eine 3V LED antreiben.
Ich stoße da echt an meine Grenzen.
Vielen Dank für eure Zeit,

  Jacob

Autor: Helmut Lenzen (helmi1)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Diese Sensoren bestehen aus einem Kabel, dass am losen Ende in einer >alkalische 
Flüssigkeit liegt.

Du weisst das das dieses Kabelenden bei Gleichspannung einer sehr 
starken Korrision unterliegen ? Normalerweise nimmt man fuer sowas 
Wechselspannung. Eine angeschlossene Elektronik uebernimmt dann die 
Auswertung und steuert dann eine LED an. Somit liegen die LEDs alle an 
der gleichen Spannung.

Gruss Helmi

Autor: Frank L. (hermastersvoice)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Lies dir doch mal ein paar Grundlagen über LEDn durch. Kleiner Tipp: der 
Arbeitspunkt einer LED wird über den Strom eingestellt, nicht über die 
Spannung.

bye

Frank

Autor: jacob (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Helmi,

Gibt es da fertige Bausätze und wenn ja wie nennt man solche. Ich wollte 
Gleichstrom nehmen, damit ich eine einfache Batterie benutzen kann. Das 
Korrosionsproblem habe ich schon bemerkt ich kenne mich aber mit 
Wechselstrom noch weniger aus. Ich hatte vor die Messintervalle sehr 
groß zu wählen um so die Korrosion zu verlangsamen. Wenn es jedoch die 
Möglichkeit gibt das Messgerät mit Wechselstrom auszustatten wäre es 
natürlich erheblich besser.

Danke für diese schnellen Anregungen,

Gruß Jacob

Autor: Helmut Lenzen (helmi1)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe dir mal auf die schnelle was konstruiert. Du hast hier eine 
Wechselspannung (Rechteck) von ca. 10Khz an deinen Kabelenden liegen.
Wenn jetzt durch die Fluessigkeit das Kabelende kurzgeschlossen wird 
bekommt der Gleichrichter mit den beiden Dioden ein Signal. Wenn die 
Gleichspannung jetzt den Schwellwert des Transistors uebersteigt leitet 
dieser und die LED leuchtet. Du darfst allerdings keine Verbindung von 
GND der Schaltung zu der leitenden Fluessigkeit haben. Sollte das doch 
der Fall sein muessen wir die Schaltung modifizieren.

Gruss Helmi

Autor: jacob (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Hemi,

vielen vielen Dank für die Mühen die du dir machst. Der plan den du mir 
geschickt hast erschlägt mich leider ein Bisschen. Du überschätzt 
anscheinenden meine Fähig- und Möglichkeiten. Bei Conrad haben ich 
folgendes Teil gefunden Artikelnummer 210959 – 62 es scheint mir das 
ideale Teil zu sein.

Danke, Jacob

Autor: Helmut Lenzen (helmi1)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich glaube nicht das du mit dem Teil gluecklich wirst. Das Problem mit 
der Korrision bleibt weiterhin bestehen.

Gruss Helmi

Autor: jacob (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
da hast du natürlich Recht. Der Bausatz ist jedoch auch für Wechselstrom 
geeignet. Ich brauchte also nur noch eine Wechselstromquelle und hätte 
alles so wie von dir vorgeschlagen. Oder sehe ich das was falsch.

Autor: yalu (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Der Bausatz ist jedoch auch für Wechselstrom geeignet.

Ich würde nicht sagen, dass der Bausatz für Wechselstrom geeignet ist,
auch wenn dies auf der Web-Seite so geschrieben steht. Warum?

Werden die 12V verkehrt herum angelegt, bricht die LED mit einer
typischen Sperrspannung von etwa 5V durch, und es fließt ein hoher
Strom durch die Z-Diode, die Basis-Kollektor-Strecke des Transistors
und die LED. Mindestens eines der drei genannten Bauteile wird dadurch
das Zeitliche segnen.

Wenn du das Ganze mit Gleichstrom betreibst, entsteht nicht nur die
von Helmut bereits erwähnte Korrosion, sondern evtl. auch Knallgas,
falls es sich um eine wässrige Lösung handelt und der Behälter
geschlossen ist. Immerhin fließen bis zu 10 LED-Ströme durch die
Flüssigkeit.

Und willst du wirklich 34€ für 10 dieser Bausätze ausgeben, diese
zusammenlöten, auf eine Grundplatte montieren (damit sie nicht
umherfliegen) und mit den LEDs verkabeln? Die Bauteile für die
Schaltung von Helmut Lenzen kosten dich etwa so viel wie einer
dieser Conrad-Bausätze, und du kannst alle 10 Kanäle einschließlich
der LEDs ordentlich und kompakt auf einer einzelnen Lochrasterplatine
aufbauen.

Hast du mal gemessen, wie groß der Übergangswiderstand in einer der
weniger gut leitenden Flüssigkeiten ist? Da der gesamte LED-Strom
durch die Flüssigkeit fließen muss, darf der Übergangswiderstand nicht
sehr hoch sein, oder die LEDs glimmen nur noch düster vor sich hin.
Auch hier ist Helmuts Schaltung besser, da sie das Signal verstärkt.

Man könnte in dieser Schaltung evtl. die 10 Ausgangstransistoren
mitsamt Basiswiderständen durch CMOS-Schmitt-Trigger ersetzen. Damit
schalten die LEDs eindeutig ein oder aus, und es gibt keine halbhellen
Zwischenzustände. Die Empfindlichkeit kann dann durch Vergrößern von
R2 und R5 enorm gesteigert werden, so dass die Schaltung auch für sehr
schlecht leitende Flüssigkeiten anwendbar ist.

Solche CMOS-Schmitt-Trigger gibt es zu 6 Stück pro IC, so dass die
10 Transistoren und 10 Basiswiderstände durch 2 ICs ersetzt werden
können. Einer der beiden übrigen Schmitt-Trigger kann die Funktion des
NE555 als Oszillator übernehmen, so dass ein weiteres Bauteil
wegfällt. Damit ist der Zusammenbau der Schaltung wirklich nicht mehr
viel aufwendiger als bei der Variante mit den Conrad-Bausätzen.

Autor: Helmut Lenzen (helmi1)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hier noch mal die Schaltung in der Version mit den CMOS Schmitt-Trigger 
wie von yalu vorgeschlagen. Ich wollte zuerst keine ICs dafuer nehmen 
weil ich dachte das du mit normalen Transistoren und Widerstaenden 
besser zurecht kommst. Bei der Problematik mit dem Teil vom C. muss ich 
yalu voll zustimmen , das funktioniert so nicht.

Gruss Helmi

Autor: jacoblengers (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Ok, da ihr viel viel mehr Ahmung habt als ich werde ich das einfach mal 
so machen wie ihr mir dass empfehlt.
Der C Bausatz ist dann jetzt gestorben. Also diese Sensoren sollen in 
einem Rohr D1000 eingebaut werden, in welches Frischbeton eingefüllt 
wird. Explosionsgefahr besteht da wohl eher nicht.

Ziel des Versuches ist es eine Messmethode zu finden mit der sich 
Füllstände des Frischbetons feststellen lassen.
Will man z.B. einen Hohlraum vollständig mit Beton ausbetonieren, gilt 
es Sensoren an den oberen Teil der Decke zu installieren und dann 
mittels Schaltung nachzuweisen dass der Hohlraum bis an die decke 
gefüllt ist.

Der Übergangswiderstand lag in Vorversuchen zwischen 18 kOhm und 80 Ohm. 
Allerdings habe ich hier mir Gleichstrom gearbeitet und an den Messdraht 
war eine PVC Folie mit aufgeklebter Aluminiumfolie angebracht. Der 
Widerstand scheint sich nach 10 turbulenten Minuten bei ca 90 Ohm zu 
stabilisieren.

Ich bin kein Elektrotechniker und habe daher mit dem Bausatz 
geliebäugelt. Doch A habt ihr mich von Helmis Schaltung überzeugt und B 
bin ich jetzt tierisch gespannt ob ich eure Schaltung hinbekomme. Also 
löten kann ich ganz gut doch die wahre Funktionsweise eurer Schaltung 
kann ich nicht nachvollziehen.

Ist das zusammenlöten den mit dem von Helmit erstellten Plan möglich 
oder brauch ich da noch weiters Wissen.

Autor: Helmut Lenzen (helmi1)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Jacob,

Mein Plan zeigt allerdings nur 2 Sensoren wenn du mehr haben willst muss 
ich die Zeichnung ergaenzen oder du suchst dir die Pinummern der Gatter 
selber aus dem Datenblatt von dem IC. Ansonsten sollte die Schaltung 
schon funktionieren auch wenn ich sie am Samstag mal so eben 
hingezeichnet habe.

Als weiteres Wissen solltes du den Farbcode der Widerstaende, die 
Pinnummerierung des ICs und wo Kathode und Anode an der LED ist wissen.

Gruss Helmi

Autor: jacob (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ich hab da noch ein Paar fragen bevor ich die Teile bestelle:


muss ich IC2F, R1 und C1 anpassen wenn ich insgesamt 10 Sensoren 
verwenden will
macht es sinn anstelle R5 ein Potentiometer einzubauen um die 
Empfindlichkeit regeln zu könne
was für ein IC ist IC2P
und welches Bauteil oder Schaltkreis macht die Wechselspannung
kann ich nicht sofort 5v als Speisespannung nehmen
muss ich alle enden an denen GND steht miteinander verbinden(selbiges 
für +5V)
und wo schlisse ich die Batterie an
liegen an der Zelle nun 5 oder 12V an
was genau macht die separate Schaltung oben links

bei conrad finde nur folgenden IC

74HCT14 DIP
SN74HC14N DIP
SMD74HC14SO14

aber nicht das von Helmi vorgeschlagene 74HC15D
kann ich eines der anderen verwenden?

und auch LM7805 ist conrad leider unbekannt.

oder kennt jemand einen laden wo ich diese teile bekommen kann.

Den Rest habe ich schon zusammen, na ja sind ja auch Standartteile.
Und die Pin Belegung für IC 74HC15D hab ich auch gefunden.

Autor: Helmut Lenzen (helmi1)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Jacob

>muss ich IC2F, R1 und C1 anpassen wenn ich insgesamt 10 Sensoren
>verwenden will

Nein die Frequenz bleibt gleich.

>macht es sinn anstelle R5 ein Potentiometer einzubauen um die
>Empfindlichkeit regeln zu könne

Das könnte man machen.

>was für ein IC ist IC2P

Das ist die Spannungsversorgung von dem IC . Hier kommt +5V und GND 
dran.


>und welches Bauteil oder Schaltkreis macht die Wechselspannung

Das macht IC2F , R1 und C1.  Frequenz ca. 10KHz

>muss ich alle enden an denen GND steht miteinander verbinden(selbiges
für +5V)
Ja die must du alle verbinden.

>und wo schlisse ich die Batterie an
An +12V und GND . Die Batteriespannung kann zwischen 8 .. 15V betragen.

>was genau macht die separate Schaltung oben links

Das ist ein Spannungsregler. Der sorgt für eine stabile Betriebsspannung 
von 5V unabhaengig ob die Batterie 8 oder 15V liefert.


>74HCT14 DIP
>SN74HC14N DIP
>SMD74HC14SO14

>aber nicht das von Helmi vorgeschlagene 74HC15D
>kann ich eines der anderen verwenden?

SN74HC14N kannst du verwenden.


>und auch LM7805 ist conrad leider unbekannt.
doch such mal nach 5V Spannungsregler

>Den Rest habe ich schon zusammen, na ja sind ja auch Standartteile.
>Und die Pin Belegung für IC 74HC15D hab ich auch gefunden.

ähh ich habe dort ein 74HC14 eingesetzt nicht ein 74HC15 das hat eine 
andere Funktion.


>liegen an der Zelle nun 5 oder 12V an
An der Zelle liegt 5V Wechselspannung an.

>kann ich nicht sofort 5v als Speisespannung nehmen
Nein dann hast du das Problem mit der Korrision.

Ich hoffe deine Fragen beantwortet zu haben.

Gruss Helmi

Autor: HildeK (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>74HCT14 DIP
>SN74HC14N DIP
>SMD74HC14SO14
Der erste ist einer mit TTL-Schwellen und 5V,
der zweite mit CMOS-Schwellen in einem Dual-Inline-Package,
der dritte derselbe, jedoch in einem SMD-Package (SO14).
Die beiden letzten können ein einem weiteren Bereich versorgt werden.

Das 'D' steht vermutlich für DIP (einfacher zu handhaben) und deshalb 
solltest du den 74HC14 nehmen.

>und auch LM7805 ist conrad leider unbekannt
Fast unmöglich! Lass einfach mal die Buchstaben weg - die kennzeichnen 
häufig nur den Hersteller.

Einen 74HC15D hatte Helmi aber nicht in seinem Plan ...

>oder kennt jemand einen laden wo ich diese teile bekommen kann
http://www.mikrocontroller.net/articles/Elektronikversender

Reichelt würde ich als ersten fragen.

Autor: jacob (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>kann ich nicht sofort 5v als Speisespannung nehmen
Nein dann hast du das Problem mit der Korrision.

ja natürlich mit wechselstrom, davon habt ihr mich ja bereits überzeugt.
meien frage war ob ich den Spannungsregler nicht direkt mit 6V antreiben 
kann.

Danke euch

Autor: Helmut Lenzen (helmi1)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>meien frage war ob ich den Spannungsregler nicht direkt mit 6V antreiben
>kann.

6V Eingangsspannung ist für den 7805 zu wenig der will mindestens 8V.
Du kannst aber einen LM2931 dafuer nehmen der kommt mit den 6V klar.
Die Belegung ist gleich allerdings must du dann C7 von 100nF auf 100uF 
vergrösseren.

Gruss Helmi

Autor: jacob (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
sorry helmi hast die frage ja schon beantworte.

Also da wo GND und VCC (7 und 8) steht liegt die Versorgungsspannung für 
die beiden IC an, und diese sind dann parallel hier anzuschließen 
richtig?

Autor: Alexander Schmidt (esko) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
jacoblengers wrote:
> Also diese Sensoren sollen in einem Rohr D1000 eingebaut werden,
> in welches Frischbeton eingefüllt wird.
> Explosionsgefahr besteht da wohl eher nicht.
>
> Ziel des Versuches ist es eine Messmethode zu finden mit der sich
> Füllstände des Frischbetons feststellen lassen.
> Will man z.B. einen Hohlraum vollständig mit Beton ausbetonieren, gilt
> es Sensoren an den oberen Teil der Decke zu installieren und dann
> mittels Schaltung nachzuweisen dass der Hohlraum bis an die decke
> gefüllt ist.

Ich nehme mal an, dass die Sensoren, hier Kabelenden, mit einbetoniert 
werden.
Dann ist der Korrosionsschutz egal, denn nach ein paar Stunden dürfte 
der Beton gehärtet sein und sowieso keinen Strom mehr leiten.

Dann kannst du die Erzeugung der Wechselspannung und die Dioden aus der 
Schaltung weglassen.

Autor: Helmut Lenzen (helmi1)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Also da wo GND und VCC (7 und 8) steht liegt die Versorgungsspannung für
>die beiden IC an, und diese sind dann parallel hier anzuschließen
>richtig?

Fast richtig !

Pin 7 = GND
Pin 14 = VCC (+5V)

Gruss Helmi

Autor: jacob (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
die Sensoren sollen wenn möglich wieder verwendet werden. Sie werden 
dazu aus dem Frischbeton gezogen und anschließend gereinigt. Es sind 
auch nicht um einfachen Kabelenden.

Hallo Helmi,

yalu sprach davon die Widerstände R2 und R5 zu beeinflussen, soll ich an 
beiden Stellen Potentiometer(100kO bis 1MO) einsetzen oder reicht es nur 
R5 auszutauschen.

Autor: Helmut Lenzen (helmi1)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>yalu sprach davon die Widerstände R2 und R5 zu beeinflussen, soll ich an
>beiden Stellen Potentiometer(100kO bis 1MO) einsetzen oder reicht es nur
>R5 auszutauschen.

R2 und R5 haben die gleiche Funktion. Wenn du jetzt 10 Kanaele haben 
willst dann must du die Schaltung 10 mal aufbauen. Also den rechten Teil 
der Schaltung mit den beiden Dioden dem Widerstand den beiden 
Kondensatoren und dem Inverter.

Gruss Helmi

Autor: jacob (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
oh gott ich esel. das sehe ich jetzt auch. danke

Autor: jacob (Gast)
Datum:
Angehängte Dateien:
  • P1.sch (107 KB, 203 Downloads)

Bewertung
0 lesenswert
nicht lesenswert
da das ganze ordentlich werden soll, will ich nun eine Platine 
anfertigen lassen. Ich habe das Layout mit eagel gemacht. kann mir 
jemand sagen ob das Layout so brauchbar ist. (Abstände zu klein oder 
sonstige Fehler)

Autor: jacob (Gast)
Datum:
Angehängte Dateien:
  • P1.brd (32,4 KB, 178 Downloads)

Bewertung
0 lesenswert
nicht lesenswert
und das noch

Autor: Helmut Lenzen (helmi1)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Jacob,

Bildformate

Wuerdest du bitte die Eagledateien im PNG Format wiederholen.
Ich und andere koennen sie sonst nicht lesen.

Gruss Helmi

Autor: jacob (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
ja sicher, ich dachte ihr hättet alle dieses Programm

Autor: jacob (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
und noch der Schaltplan

Autor: Helmut Lenzen (helmi1)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich sehe schon du hast das mit dem Autorouter gemacht.
Naja schoen ist anderes.

Was mir auf die schnelle auffaellt:

1. Die Leiterbahnen zwischen den IC Beinchen sind nicht mittig.
2. Den GND (Masse) solltest du dicker und besser verlegen (nicht so wie 
der Autorouter um 25 Ecken)

3. 5V an den beiden IC fehlt
4. in der naehe der beiden IC solltest du einen 100nF Kondensator 
zwischen GND u. 5V schalten
5. Dein 5V Spannungsregler hat einen Kurzschluss zwischen Ein u. Ausgang
6. Waeren schoenheitssachen (Kuerzer Verbindungen alles nicht um 25 
Ecken verlegen u.s.w) das ist auch mit ein Grund warum ich keinen 
Autorouter benutze.

>ja sicher, ich dachte ihr hättet alle dieses Programm
Programm ja aber nicht laufend andere Versionen davon. 4.60 kann ich 
nicht einlesen.

Gruss Helmi

Autor: jacob (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
sind die Massen so dick genug
den Kondensator regle ich über den IC Sockel
den Kurzschluss sehe ich irgendwie nicht
wie kann ich die IC’s denn im Schaltplan anschließen ich habe da ja 
immer nur die einzelnen Gatterda gestellt.
wie wichtig ist es denn das ich die Leiter ordentlich verlege, das 
dauert nämlich auch so schon alles immer ziemlich lange, weil ich das 
Programm vorher noch nie benutzt habe.

Autor: Helmut Lenzen (helmi1)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Jakob ,

Ich habe es dir mal eben neu geroutet.

Gruss Helmi

Autor: Helmut Lenzen (helmi1)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hier noch der Schaltplan dazu.

Ich hoffe du kannst meine Eagledateien einlesen

Autor: Stephan (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die Widerstände kommen mir sehr groß (Baugröße) vor. Sind das 1 
Watt-Typen?
Hier sollten auch 1/4W-Standardwiderstände reichen.

Autor: jacob (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Da bin ich aber platt, wie hast du das denn so schnell gemacht. Ich bin 
total begeistert. Tausend Dank.
das sind 1/2 Watt Widerstände.
super super super

Autor: Helmut Lenzen (helmi1)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Naja Jacob,

Ich habe da auch so um die 30 Jahre erfahrung drin in Schaltungsdesign 
und Layout. Ganz frueher noch mit Klebebaender und Tusche gemacht.

Ich habe ueberigens 1/4W Widerstaende mit RM 10 verwendet.

Gruss Helmi

Autor: Marian (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Dürften andere das neu geroutete Layout auch mal sehen, also das von dir 
Helmi (PNG wäre super)? Bin sehr interessiert und neugierig, so als 
mitleser :).

Autor: Helmut Lenzen (helmi1)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Aber klar doch duerfen andere das auch sehen.

Gruss Helmi

Autor: jacob (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hilfe Hilfe,

ich habe heute weitere Test mit der Schaltung gemacht und einen 
komischen/störenden Effekt bemerkt. Ich habe ein ca 10[m] langes 
Muticore Kabel (24 Adrig) angeschlossen. Wenn ich nun am offenen Ende 
die Kabelender verbinde leuchtet die LED so wie sie soll. Wenn ich den 
Kontakt nun wieder löse. so bleibt die LED leuchten.
Hann mir jemand diesen Effekt erklähren bzw hat jemand eine Idee wie man 
ihn untebinden kann ???

Ich brauche dringend eine Lösung, weil ich die Schaltung so nicht 
benutzen kann.

Grüße Jacob

Autor: Alexander Schmidt (esko) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
jacob wrote:
> Wenn ich nun am offenen Ende die Kabelender verbinde
> leuchtet die LED so wie sie soll. Wenn ich den Kontakt nun wieder löse.
> so bleibt die LED leuchten.

Die Leds gehen also gar nicht mehr aus, wenn das Kabel angeschlossen 
ist.
Wenn das Kabel abgeklemmt ist, gehen sie aber aus? -> Nachprüfen

Wenn sie nur ohne Kabel ausgehen, dann liegt irgendwo ein eine 
Verbindung im Kabel vor. -> Durchklingeln

Falls das auch nicht der Fall ist, fängst du dir irgendwelche Störungen 
über das lange Kabel ein.

Poste mal den Schaltplan, oder den Link zu dem Beitrag, so wie du es 
schlussendlich aufgebaut hast.

Autor: Helmut Lenzen (helmi1)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Jacob

Den Effekt den du beschreibst haengt mit dem kapazitiven Ubersprechen 
zwischen den Adern zusammen. Je laenger die Leitungen werden um so 
groesser wird die Kapazitaet zwischen den Adern. Um das hinzubekommen 
gibt es jetzt 2 Moeglichkeiten.

1.  Die Frequenz kleiner machen. Dazu must du den Kondensator C1 von 
10nF mal auf 47nF oder 100 nF vergroesseren.

2. Den Einganswiderstand der Schaltung kleiner machen. Dazu must du die 
100Kohm Widerstaende mal auf 47K , 22K oder 10Kohm aendern.

Ich wuerde als erstes mal mit 1 anfangen. Da brauchst du nur 1 Koni zu 
aendern. Durch verkleineren der Frequenz hast du ein kleiners 
uebersprechen zwischen den Adern.

Gruss Helmi

Autor: jacob (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe die Platine genau so aufgebaut und bestückt wie von helmi 
vorgeschlagen.

Die LED bleibt auch nach lösen des Kabels an.

Also, wenn ich alles nur anschließe (kein Kontakt am Kabelende) ist die 
LED nicht an. Sobald ich dann das Kabelende kurz schließe geht die LED 
an und bleib auch an wenn ich den Kontakt wieder unterbreche.

7 der 10 Kanäle Verhalte so. Die anderen Mal so mal so.

Wenn ich die Stromzufuhr unterbreche und anschließen wieder anschließe 
sind alle LED's aus bis ich den Kontakt wieder schließe.

Bei den eingebauten Kondensatoren habe ich nur auf den jeweiligen Wert 
geachtet und nicht auf die Bauform.


Ich mache morgen mal ein Foto

Autor: Helmut Lenzen (helmi1)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Jacob

Mach mal bitte die 100KOhm  Widerstaende kleiner.
So um den Daumen gepeilt 10 .. 22 Kohm.

Gruss Helmi

Autor: Helmut Lenzen (helmi1)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe das gerade mal ausprobiert.

Ich habe zwar kein Multicore Kabel da und kann deshalb nicht sagen 
wieviel pf / m das hat. Ich habe statt dessen ca. 5m normales 2 Aderiges 
0.34mm2 Kabel genommen und das mal durchgemessen. Da bin ich auf 270pF 
gekommen.
Geschaltet hat die LED dabei noch nicht. Allerdings war die 
umschaltschwelle fast erreicht dabei. Dann habe ich den 100Kohm mal auf 
10Kohm erniederigt. Die Spannung am Schmitt-Trigger war dabei weit weg 
von der Umschaltschwelle.

Also Jacob aendere mal den 100K auf 10 .. 22KOhm und teste die Sache 
nochmal.

Gruss Helmi

Autor: jacob (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe zufällig die Kapazität gemessen. (hatte da so einen Verdacht)
der Wert lag zwischen 0,9 bis 1,3 müF.

Autor: Helmut Lenzen (helmi1)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Du meinst 0.9 .. 1.3 nF ?

Ich hatte gerade mal einen Koni von 3.3nF zum testen dran. Das gab am 
Schmitt-Trigger cas. 1.5V . Also noch unterhalb der Triggerschwelle.

Bei 1.3nF bist du dann noch weiter auf der sichern Seite. Eventuell 
kannst du Frequenz trotzdem noch etwas erniederigen. Tausch den 10nF mal 
gegen sowas im Bereich von 33nF .. 100nF aus. Mit den Werten must du mal 
ein klein bisschen experimentieren. Wie gesagt ich habe dein Kabel ja 
nicht da.

Berichte mal obs jetzt klappt.

Gruss Helmi

Autor: jacob (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
soweit ich mich erinnere waren dass müF und nicht pF

Autor: Helmut Lenzen (helmi1)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Sag mal sind im diesem Multicore Kabel die Draehte paarweise verdrillt ?

Vielleicht wenn gar nicht anders klappt ein kapazitaetsaermeres Kabel 
nehmen.

Autor: jacob (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
nein die sind nicht verdrillt

Autor: jacob (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hier habe ich ein ähnliches Kabel gefunden
http://www.sommercable.com/1__produkte/1__1_f_mw.html
da spricht man von 120 pF/m bei 19 m müsste dass doch 1,2 müF ergeben 
oder.

Autor: Helmut Lenzen (helmi1)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
120 pf/m * 19m = 2280pF

Mach als erstes mal den 10nF grosser . Scheint bei mir erstmal die 
einfachtes Loesung zu sein.

Autor: jacob (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ups das sollte 10m heißen. OK werde ich morgen sofort machen.
Habe die Sachen leider nicht zu hause. mist.

Bin gespannt.

Danke!!!

Autor: Helmut Lenzen (helmi1)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Jo dann bis morgen.

Hast ja erstmal genug Tipps was du aendern kannst.

Gruss Helmi

Autor: jacob (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
So, es hat geklappt. 33nF scheint das Maß der Dinge zu sein.

Autor: Helmut Lenzen (helmi1)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Jacob

Platine sieht ja gut aus. Schön das es geklappt hat. Kannst du noch mal 
die Spannung über den 100K Widerständen messen. Dann könnte man sehen 
wieviel noch fehlt bis zum Umschaltpunkt.

Und hast du das heute auch mit Beton schon ausprobiert.

Gruss Helmi

Autor: jacob (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

Ja, funktioniert auch in Beton.
Bei welcher Spannung der IC denn umschalten ?

Autor: Helmut Lenzen (helmi1)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich meinte die Spannung über  dem 100KOhm Widerstand wenn das Kabel 
angeschlossen ist aber noch nicht im Beton steckt.

Autor: jacob (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Helmi,

könntest du mir einen weiteren großen gefallen tun ? Die Hauselektriker 
wollen unbedingt eine Sicherung und die Platine soll fest eingeschraubt 
werden. Dazu muss das board ein wenig geändert werden. Den Umriss habe 
ich schon eingefügt. Könntest du mir den Spannungswächter integrieren 
und dann einen 4 Poligen Stecker vorsehen über den ich die LED noch 
antreiben kann ??? Ich kann leider nicht mehr zwischen board und 
schaltplan wechseln (inkonsitent) und das Programm sagt an anderer 
Stelle dass ich hier mit der Freeware nicht weiter arbeiten kann.

Gruß Jacob

Autor: Helmut Lenzen (helmi1)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Jacob

Sicher kann ich das.
Melde dich mal per Email.

Uberigens kann ich dein Board nicht lesen.
Habe nur Eagle 4.09 und 4.16

Gruss Helmi

Autor: Alex Bürgel (Firma: Ucore Fotografie www.ucore.de) (alex22) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Helmis Board sieht ca. 100x so gut aus wie der alte Entwurf! :-)
Möchtest du für mich nicht auch mal eine Platine routen? Hat nur so ca. 
1000 Bauteile (SMD und die meisten mit mehr als 2 Pins...).

Autor: jacob (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ja ja,

der Helmi weiß wie es geht und ich halt nicht.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.