mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik Probleme mit aktivem Bandpass-Filter


Autor: reflection (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Salu zusammen

Ich habe ein Problem :o)

Folgendes: Ich habe eine IR LED welche mit einer Frequenz (Rechteck) von 
5kHz sendet. Habe ich mit dem KO gemessen und funktioniert.
Im Anhang seht ihr die Auswertungssschaltung, also die IR-Diode. Wenn 
ich nach dem 1. OP messe, sehe ich das Signal und es stimmt auch. 
Amplitude ca. 4V. So, messe ich nun nach dem 33k Widerstand, sehe ich 
nichts mehr. Fehler beim Schaltungsaufbau kann ich ausschliessen, habe 
es zig mal kontrolliert. Denke es liegt an der Dimensionierung von R4, 
welcher ja lediglich 180R ist. Das wäre ja dann ein Spannungsteiler von 
33k zu 180R.

Wie macht man das nun. Ich habe die Werte der Widerstände und C's mit 
einem Filtereditor berechnet udn solange probiert bis ich mit E24 Werten 
möglichst nahe dran war. Die Schaltung soll mit so wenig Bauteilen wie 
möglich auskommen

Eckdaten: fc = 5kHz, Bandbreite ca. 500Hz

Wie erreiche ich das ohne alles über den Haufen zu werfen. Geht das 
überhaupt so? Wie kann ich sicherstellen, das der "nur" Filtert und 
nicht auch noch an der Amplitude rumbastelt. Das Tool gab mir aus, das 
der Gain = 1 ist. Das wäre ja weder eine Verstärkung noch eine Dämpfung, 
aber trotzdem kommt halt nichts mehr hinten raus.

Wäre echt toll wenn ihr mir bei der Berechnung des Filters helfen 
könntet.

Gruss reflection

Autor: Hubert G. (hubertg)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die Werte sollte schon stimmen, wie sieht es mit der Stromversorgung 
aus?

Autor: Helmut Lenzen (helmi1)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich sehe da gerade das du einen LM324 nimmst . Folgendes entweder hast 
du eine +- Versorgung fuer die OPS oder du legst den + Eingang ueber 
einen Spannungsteiler auf UB/2  also quasi eine Symetrische Versorgung.

Das mit dem Spannungsteiler 33K zu 180 Ohm ist korrekt. Das Verhaeltnis 
muss so sein damit die Guete und Resonanzfrequenz des Filters stimmt. 
Was du allerdings bedenken must dabei ist das die Leerlaufverstaerkung 
des OPs bei der Resonanzfrequenz groesser ist als 2*Q^2.

Also deine Filterguete ist ja  fr/B = 5000 / 500 = 10

Daraus folgt das die Verstaerkung des OPs bei 5KHz noch mindestens

2 *10 *10 = 200 Betragen muss. Besser ist es das er dort noch mehr 
Reserve hat.

Laut Datenblatt hat der LM324 bei 5KHz rund 40 dB (100 fach) 
Verstaerkung. Das ist zu wenig fuer deinen Zweck. Besser du nimmst fuer 
sowas einen TL084
OP der hat bei der Frequenz rund 50dB (316 fach) Verstaerkung.

Gruss Helmi

Autor: Uwe Nagel (ulegan)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Schaltung sollte eigentlich gehen. Hinter dem 33k Widerstand wird nicht 
viel zu erkennen sein, der Filterausgang ist ja schliesslich hinter dem 
OP. Allerdings ist der LM324 in dieser Anwendung ziemlich am Ende. Die 
Leerlaufverstärkung muss in dieser Schaltung grösser als 2*Q² bei der 
Mittenfrequenz des Filters sein. Die Güte Q=F0/B=5000Hz/500Hz=10 . Also 
Verstärkung grösser 200 bei 5kHz macht ein 
Verstärkungs-Bandbreite-Produkt von grösser 1MHz.
Benutzt du eine doppelte Versorgungsspannung?

Autor: T. H. (pumpkin) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Mmmh, fix nachgrechnet:
Scheint soweit zu passen.

Autor: reflection (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo zusammen

ich speise den LM324 mit +5V einseitig. am OP Ausgang tut sich dann eben 
auch rein gar nichts (0V gerausche) Aber selbst wenn der OP nicht die 
benötigte Verstärkung aufweist müsste doch irgendwas da hinten 
rauskommen, oder sehe ich das jetzt völlig falsch?

Gruss reflection

Autor: Helmut Lenzen (helmi1)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich kann dich nur auf meinem ersten Post verweisen


>Ich sehe da gerade das du einen LM324 nimmst . Folgendes entweder hast
>du eine +- Versorgung fuer die OPS oder du legst den + Eingang ueber
>einen Spannungsteiler auf UB/2  also quasi eine Symetrische Versorgung.

Gruss Helmi

Autor: reflection (Gast)
Datum:
Angehängte Dateien:
  • preview image for 1.gif
    1.gif
    11,3 KB, 387 Downloads

Bewertung
0 lesenswert
nicht lesenswert
Hallo zusammen

Nun habe ich besagten Spannungsteiler am OP+ Eingang gemacht (2x10k).
Schema habe ich angehängt.

So, nun tut sich doch schonmal was, auch wenn ich daraus absolut nicht 
schlau werde :o) Vielleicht liegt das aber nun an der, wie ihr ja gesagt 
habt, fehlenden Verstärkung. Wollte aber trotzdem nochmal nachfragen.

Also wenn ich nun hinter dem 2.OP messe sehe ich so etwas ähnliches wie 
einen Sinus mit DC-Offset. Am Ausgang habe ich dann ca. 2.5V und wenn 
ich nun IR Licht auf meine Diode gebe, ändert sich der Pegel am Ausgang 
um ca. 0.6V Sprunghaft. Also so auf vielleicht 3.1V. Kommt mir doch 
alles ein wenig komisch vor :o) Weiss nun nicht genau wie ich vorgehen 
soll. Meint ihr das liegt nur an der Verstärkung oder ist da noch was 
anderes im Argen?

Gruss und merci für die bereits gegebenen Tipps

reflection

Autor: Helmut Lenzen (helmi1)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
+ von deinem ersten OP und Anode von der Diode muessen auch auf UB/2
R8 am besten mit 1uF ueberbruecken.

Gruss Helmi

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.