mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik mit Oszi falsch gemessen?


Autor: Aufnehmer (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hi, ich realisiere gerade das Abspielen von Audio mit einem CS4272 
Audio-Codec. momentan sende ich erstmal einen Sektor Testdaten - eine 
Sinuswelle, Nullwerte und 2 Rechteckflanken. Den Oszi-Tastkopf habe ich 
direkt an die Ausgänge gehangen (also GND an AOUT- und den Signaleingang 
an AOUT+) 7 Gerät läuft mit Batterie. Wenn ich jetzt messe, sieht das 
Signal total verrauscht aus, ich dachte schon, mit meiner 
Datenübertragung stimmt was nicht.

Dann habe ich zufällig gesehen, daß beim an- und abklemmen manchmal 
alles super aussieht, und ich konnte das reproduzieren, indem ich 
100kOhm in Reihe zum Tastkopf geschaltet habe. Daß die Kurve nicht exakt 
rechteckig ist, schiebe ich mal auf meine Freiluftverdrahtung (ca. 10cm 
Leitungsweg hinter den Ausgängen vom Chip).

Habe ich jetzt falsch gemessen und mein Signal ist super, oder hat der 
100kOhm-Widerstand einfach alles weggeglättet (siehe nächstes Bild) und 
mein Signal ist verrauscht?

Autor: Aufnehmer (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
"sauberes" Signal

Autor: Aufnehmer (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ach so, die Polarität beim 2. Bild ist umgeschaltet, nicht wundern.. :-)

Autor: Jörg Wunsch (dl8dtl) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Aufnehmer wrote:

> Habe ich jetzt falsch gemessen und mein Signal ist super, oder hat der
> 100kOhm-Widerstand einfach alles weggeglättet (siehe nächstes Bild) und
> mein Signal ist verrauscht?

Der 100-kΩ-Widerstand bildet zusammen mit der Eingangskapazität deines
Tastkopfes einen prima Tiefpass.  Lass uns überschlagen, du hast 100 kΩ
und 15 pF, das ist eine Zeitkonstante von 1,5 µs oder eine Grenzfrequenz
des Tiefpasses im Bereich von 100 kHz.

Autor: lkmiller (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
>eine Grenzfrequenz des Tiefpasses im Bereich von 100 kHz
und trotzdem sieht man im zweiten Bild noch Reste von irgendwelchen 
hochfrequenten Komponenten.
Muß da an den Ausgängen noch was getan werden (Bild)?

Autor: Aufnehmer (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Wahrscheinlich ist es normal, daß das Signal direkt an den Ausgängen so 
aussieht. Ich verstehe auch den 2. Absatz (siehe Bild) nicht so richtig. 
Auf jeden Fall sind da auch Filter eingebaut.

Autor: Benedikt K. (benedikt) (Moderator)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das dürfte ein Delta-Sigma DAC sein. Der rauscht immer stark bei ein 
paar MHz, da er meist nur wenige Bit Auflösung hat, und die hohe 
Auflösung durch Fehlerverteilung erzeugt. Daher steht auch immer 
irgendwo im Datenblatt, man soll einen Tiefpass nachschalten.

Autor: Aufnehmer (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ach ja und die "Reste" liegen bestimmt an meinem 
Freiluft-Test-Boardlayout. Ein Sektor (512 Bytes, 16Bit pro Sample), den 
man im Bild sieht, dauert nur ca. 5ms. Also alles was da "rauscht" ist 
offenbar >> 100MHz.

Autor: Aufnehmer (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Na dann bin ich ja beruhigt (Beitrag von Benedikt, zeitl. mit meinem 
überschnitten)

Ich werde also diese Ausgangsstufe mal aufbauen. Was sind das eigentlich 
für Kondensatoren mit "C0G"? Wenn ich z.B. bei Reichelt danach suche, 
finde ich nix..

Autor: Andreas K. (a-k)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Unter NP0 suchen.

Autor: Magnus Müller (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Aufnehmer wrote:
> Sinuswelle, Nullwerte und 2 Rechteckflanken. Den Oszi-Tastkopf habe ich
> direkt an die Ausgänge gehangen (also GND an AOUT- und den Signaleingang
> an AOUT+) 7 Gerät läuft mit Batterie. Wenn ich jetzt messe, sieht das

Schon mal mit dem Gedanken gespielt, GND vom Oszi auch mit (A)GND deiner 
Schaltung zu verbinden?

Nee...nee...nee...

Autor: Falk Brunner (falk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@ Aufnehmer (Gast)

>Dateianhang: DSC00492.JPG (845,3 KB, 67 Downloads)

Für so einen verwaschenen Dreck 850KB?
Informiere dich bitte über Bildformate

>direkt an die Ausgänge gehangen (also GND an AOUT- und den Signaleingang
>an AOUT+) 7 Gerät läuft mit Batterie. Wenn ich jetzt messe, sieht das

Das macht man nicht. Differentielle Ausgänge kann man ur richtig mit 
einem differentiellen Taskopf messen.

>Signal total verrauscht aus, ich dachte schon, mit meiner
>Datenübertragung stimmt was nicht.

Sind wahrschlich digitales Störungen, die dir durch deine Messanordnung 
in die Masse einkoppeln. Miss mal die Signale einzeln gegen GND. UNd 
ausserdem ist das Signal dort noch nicht so relevant, schliesslich kommt 
ja noch der Ausgangsfilter. DORT muss es sauer sein.

>rechteckig ist, schiebe ich mal auf meine Freiluftverdrahtung (ca. 10cm
>Leitungsweg hinter den Ausgängen vom Chip).

Kann sein.

>Habe ich jetzt falsch gemessen und mein Signal ist super, oder hat der

Wahrscheinlich.

>100kOhm-Widerstand einfach alles weggeglättet (siehe nächstes Bild) und

Kann sein.

MFG
Falk

Autor: Jörg Wunsch (dl8dtl) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Falk Brunner wrote:

>>Dateianhang: DSC00492.JPG (845,3 KB, 67 Downloads)
>
> Für so einen verwaschenen Dreck 850KB?

Kannste auch ein wenig freundlicher schreiben.

> Das macht man nicht. Differentielle Ausgänge kann man ur richtig mit
> einem differentiellen Taskopf messen.

Naja, das nur da drin ist nicht notwendiger Weise die einzig
mögliche Methode (allerdings vermutlich die einzig mögliche für den
hier benutzten Oszi): wenn es der Oszi unterstützt, kann man die
differenziellen Signale auch in zwei Kanälen erfassen und das
Differenzsignal vom Oszi bilden lassen.

> DORT muss es sauer sein.

Du klingst mir gerade ein wenig sauer. :-)

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.