mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik Analogwert bricht zusammen


Autor: Mario (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Zusammen,

ich habe ein Netzteil bei dem ich über ein Analoginterface die Spannung 
messe.

Den Spannungswert lese ich mit einer LOGO! ein.
Allerdings bricht mir die SPannung leicht ein.

Was kann ich nun machen, dass die Spannung nicht einbricht??

Autor: Igor Metwet (bastel-wastel)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ein gescheites Netzteil einsetzen.

Möglich, dass das jetzige NT eine Mindestlast braucht oder einfach nicht 
sauber arbeitet.
Möglicherweise auch ein Messfehler.

Autor: Mario (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also die Logo hat ja ne relativ hohe Eingangsimpendanz von 76kOhm.
Das Netzteil is von GossenMetrawatt und war sau teuer.

Wenn ich die Logo absteck ist die Spannung am Analoginterface i.O..

Wenn ich nen 30kOhm Widerstand reinhäng is sie zu niedrig, bei 68kOhm 
auch. erst bei 330kOhm + ist der Wert ok.

Autor: Igor Metwet (bastel-wastel)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
30k ist doch keine Last - da darf die Spannung nicht so einbrechen. Um 
welche Werte reden wir hier? Wie weit bricht die Spannung ein?

Autor: Jochen Müller (taschenbuch)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Mario,

Lass Dir BITTE nicht JEDES WORT aus der Nase ziehen.

-wann bricht da was ein?
-wie hoch ist die Last?
-was für Art von Last?
-wieviel bricht da ein?
...
...
...
-ist das Messgerät WIRKLICH OK? (Woanders getestet?)

Das diese Infos wichtig sind, könntest Du Dir doch wohl auch SELBST 
denken!!


Jochen Müller

Autor: Mario (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
-wann bricht da was ein?

Steht doch drin. Wenn ich den Analogwert mit der LOGO messe. Sollte der 
Analogwert ca. 1,97 V ist aber bloß 1,77V.

-wie hoch ist die Last?

Steht doch drin. Die Eingangsimpendanz der LOGO ist 76kOhm = Last ist 
76kOhm

--was für Art von Last?

EIne Logo!! Also: Wie sind eine Logo im Innenleben aus??


-wieviel bricht da ein?

s.o.

Autor: Mario (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Netzteil ist Gossenmetrawatt SYSKON P1500

Autor: Jochen Müller (taschenbuch)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>>Steht doch drin. Wenn ich den Analogwert mit der LOGO messe. Sollte der
>>Analogwert ca. 1,97 V ist aber bloß 1,77V.
NEIN! Stand bisher nicht drin...

Aber langsam:

1)
Was meinst du mit *sollte 1,97*? Wer sagt das? Misst Du noch mit einem 
anderen Messgerät und das zeigt einen andere Wert an, oder wie kommst Du 
auf diese 1,97?

2)
Was sagt der Oszi, schwingt da was? Restwelligkeit?

Jochen Müller

Autor: Mario (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
sry stimmt stand nicht srin ;-))
aber egal.

Der Wert am Analog Interface sollte 6 mal weniger sein als an den 
Anschlussklemmen, weil: 0-60V entsprechen 0-10V

Der Innenwiderstand vom Netzteil is 8k!

Autor: Gast (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Dein Analoginterface kann eventuell nicht genug Strom treiben, deshalb 
hat Deine Messung nicht gepasst. Du musst hochohmiger messen, also 
eventuell einen OPV als Puffer zwischenschalten.

Autor: Mario (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
gute idee mit dem OPV. Allerdings is des ganze schon in nem 19" Rack 
verbaut, deswegen fast zu aufwendig. Gibts noch ne andere möglichkeit??

Autor: Wolf (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> aber egal.
Egal ist ein Handkäse.
Der Ri vom Netzteil ist 8k?
Steht das in den Technischen Daten?

Autor: Mario (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
richtig. steht in im datenblatt bzw in der bedienungsanleitung

Autor: Wolf (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Dann hab ich in der Schule nicht aufgepasst.
Ein Netzteil mit solch einem hohen Ri darf dann nicht belastet werden, 
der geringste Entnahmestrom lässt die Spannung an den Klemmen sinken.

Autor: Mario (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
das musste3 ich nun auch festellen. Die LOGO! is dann natürlich zu 
Niederohmig. Aber was tun??

Autor: Martin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Nimm nen extra Netzteil daß einen Spannungsfolger speist (mit 
Operationsverstärker).
Diesen fütterst du mit dem zu messenden Signal. Der Spannungsfolger 
macht das ganze dann Belastbar und du hast Ruhe. :)

Autor: Simon K. (simon) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Netzteil mit 8k Innenwiderstand? Was soll denn das sein?

Autor: Wolf (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das gibts nicht. Das Gossen-Teil muß doch stromen können. 10tausend Volt 
und 0,001mA laß ich mir gefallen, aber schon bei 1,97V...
Gossen gut und Meter Watt schlecht.

Autor: Mario (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@ Simon. nicht die Lastspannung vom Netzteil hat 8k sondern das analog 
Interface!

Autor: Mario (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
http://www.gossenmetrawatt.com/deutsch/seiten/sysk...

hier ist es.

der strom is schon echt blamabel!! ;:-)

Autor: Jochen Müller (taschenbuch)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>>Der Innenwiderstand vom Netzteil is 8k!
>>@ Simon. nicht die Lastspannung vom Netzteil hat 8k sondern das analog
>>Interface!

Mario!!

Bitte fang jetzt ENDLICH AN Dich absolut zusammen zu reissen!
Alle möglichen Leute, die Dir helfen wollen (ich eingeschlossen) 
müssen...
-rätseln
-mehrmals rückfragen
-jede menge tippen

nur weil DU es NICHT SCHAFFST, klar, präzise und FEHLERFREI mal Deine 
Fakten zu nennen. WAS SOLL DAS, WAS IST LOS MIT DIR??????????????

Jochen Müller

Autor: Mario (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
steht in meinen ersten Beitrag. Analog Interface; auch im Zwieten 
Beitrag erwähne ich analog Interface.

Außerdem erkläre ich das am ANALOGINTERFACE die SPannung 6 mal so klein 
ist wie an den ANSCHLUSSKLEMMEN.

Kann es sein das du nicht weißt was ein ANALOGINTERFACE ist???
ODer liest du nur nicht richtig?

Autor: Mario (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Von der Last die an der LastSpannungsversorgung hängt war doch nie die 
Rede. Ich rede doch schon die ganze zeit vom Analoginterface

Autor: Stefan (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Jochen, locker bleiben auf die Schulter klopf...

Mario:
Du schreibst dauernd von "Analoginterface". Was genau soll denn das sein 
?
Deinen Ausführungen nach bricht der Ausgang diese Dingens zusammen, was 
interessiert uns dann das Netzteil ?

>Der Wert am Analog Interface sollte 6 mal weniger sein als an den
>Anschlussklemmen, weil: 0-60V entsprechen 0-10V
>Der Innenwiderstand vom Netzteil is 8k!
Mit solchen Infos blickt natürlich keine Sau mehr durch.
>Lastspannung vom Netzteil hat 8k
...und mit solchen noch weniger...

Also, vor dem nächsten Beitrag bitte erst nochmal in Ruhe durchlesen und 
uns dann erklären was genau in deinem Fall ein "Analoginterface" sein 
soll.

Autor: Stefan (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ach, da kam was inzwischen;

>Kann es sein das du nicht weißt was ein ANALOGINTERFACE ist???
Wie soll er das auch wissen ? "Analoginterface" sagt an sich erstmal 
genau so viel aus wie "Dingsbumms"...

Autor: Dieter Werner (dds5)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Außerdem erkläre ich das am ANALOGINTERFACE die SPannung 6 mal so
> klein ist wie an den ANSCHLUSSKLEMMEN.

> Der Innenwiderstand vom Netzteil is 8k!


Das interpretier ich mal als Spannungsteiler 6:1 und der hat offenbar 
8kOhm Innenwiderstand.
Da lässt sich wohl nix machen ausser hochohmiger zu messen.

Autor: Mario (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ja da wissen wir doch nun. aber an der logo kann ich nichts ändern. ein 
OPV in ein fast fertigens Rack einzubauen ist viel zu aufwändig.

Analog = Analog
Interface Schnittstelle
Analogschnittstelle

Eine schnittstelle, an der analoge Signale ausgeben werden.

In dem Fall 1:6 vom Sollwert der Lastspannung

Autor: Wolf (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Sträub.

Autor: Dieter Werner (dds5)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Dann schick eine mail an die PTB und beantrage eine Änderung des 
Ohm'schen Gesetzes, vielleicht hilft das weiter.

Autor: Stefan (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Analog = Analog
>Interface Schnittstelle
>Analogschnittstelle

Sag mal, für wie dumm hälst du uns ?
Ich geb's auf. Wenn du nicht verstehen willst welche Infos für Hilfe 
nötig sind dann, ...ja dann halt nicht...

Leb' wohl

Autor: Simon K. (simon) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Mario wrote:
> Der Innenwiderstand vom Netzteil is 8k!

Steht da Netzteil oder (ich will es gar nicht aussprechen) 
Analoginterface ?

Hehe, Leute gibts.

Autor: Jochen Müller (taschenbuch)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Simon K.
Ja, aber er pampt nur herum wenn man berechtigterweise rückfragt.
Ich habs aufgegeben. Für einen OP hat er angeblich keinen Platz und die 
Änderung des Ohmschen Gesetzes muss er erst beantragen.

@OP
http://de.wikipedia.org/wiki/Merkbefreiung

Jochen Müller

Autor: Wolf (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die neue Einheit von Ohm heißt dann Mho.

Autor: Stefan Helmert (Firma: dm2sh) (stefan_helmert)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

na wenn du genau weißt, dass das Analoginterface des Netzteils 8k Ohm 
hat und die Logo 76k Ohm, dann kannst du doch berechnen, wie hoch die 
eigentliche Spannung sein müsste - Spannungsteilerformel - und diesen 
Faktor in der Logo einprogrammieren? Sind die 8k Ohm genau? sind die 76k 
Ohm genau? Dann ist das doch kein Problem!?

Autor: Magnus Müller (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich versuche mal für Euch zu übersetzen:

Das SYSCON P1500 kann Ausgangsseitig 0..60V bei 0..60A. Bei dem von 
Mario erwähnten "Analoginterface" handelt es sich um separate 
Steuereingänge und Monitorausgänge an der Rückseite des Netzteils.

Die Monitorausgänge haben eine Ausgangsimpedanz von 8k. Die Spannung am 
(unbelasteten) U-Monitor beträgt 1/6 der realen Ausgangsspannung (also 
0..10V). Die Spannung am I-Monitor beträgt auch 0..10V für einen 
Ausgangsstrom von 0..60A.

@Mario:
Es ist überhaupt kein Problem, die Impedanz der Monitorausgänge 
nachträglich mit Opamps herabzusetzen. Das "Analoginterface" stellt dir 
sogar noch eine Hilfsspannung von 15V (bei 60mA Last) bis maximal 18,5V 
(unbelastet) zur Verfügung. Mit dieser kannst du deine Opamps versorgen.

Ausserdem muss ich sagen, dass du dir wirklich ALLES aus der Nase 
ziehen lässt!

Gruß,
Magnetus

Autor: Wolf (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wer weiß, daß er eine Nase hat?

Autor: Johannes (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Mario,

die meisten Leute hier haben schon ein gewisses Maß an Erfahrung und 
Kenntnissen. Wenn es Rückfragen gibt, liegt das in den meisten Fällen 
daran, dass die Beschreibung nicht eindeutig war. Vielleicht ist nicht 
jedem klar gewesen, dass Du eine Spannungsquelle mit speziellem 0-10V 
Ausgang hast - kein Grund, ungeduldig zu werden.

Dein Netzteil hat also einen analogen 0-10V Ausgang mit einer Impedanz 
von 8 k. Die Logo hat einen analogen Eingang mit 73k Eingangsimpedanz.

Mal kurz die Spannugsteilerregel angewendet und nach dem Innenwiderstand 
des Netzteil-Ausgangs aufgelöst, Deine Messwerte eingesetzt, passt: 
8,249 k. Also gibt es keine weiteren Störeffekte.

Folglich kannst Du in der Logo den tatsächlichen Spannungswert 
zurückrechnen:

U0=Umess*(8,249k+76k)/76k = Umess*1,1085

Kurzer Test: Umess = 1,77V -> U0 = 1,77V * 1,10805 = 1,96V

Klappt also.

Wenn Dir das so nicht gefällt, wirst Du tatsächlich einen 
Pufferverstärker einsetzen oder die Spannung mit einem niederohmigeren 
Spannungsteiler vom (Leistungs-)Ausgang des Netzteils abgreifen müssen.
Oder gleich die Rücklesung über GPIB verwenden...

Johannes

Autor: Magnus Müller (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Falls noch Jemand die Nerven hat Mario weiter zu helfen, ist hier der 
Link auf die Bedienungsanleitung (1220kB). Das "Analoginterface" ist ab 
Seite 22 beschrieben.

http://www.gossenmetrawatt.com/resources/la/psp/ba_d.pdf

Gruß,
Magnetus

Autor: Jochen Müller (taschenbuch)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Magnetus,

Danke, ich glaube nun ist es klar.
Übrigens wundert es mich ÜBERHAUPT NICHT, dass der OP Probleme mit 
seiner Schaltung hat. Das ist mir sonnenklar.

Wenn er die Schaltung genau so entwickelt hat, wie er hier auftritt...
- planlos durcheinander
- nicht mehr wissen, was er vor 3 Minuten gesagt hat
- nicht wissen was er eigentlich sagen will
- erst hüh, dann hott, dann wieder anders herum
- nicht präzise fragen können
- kurz: unkonzentriert und völlig konzeptlos

Mit so einer Denk- und Arbeitsweise kann man kein Projekt sinnvoll 
erledigen.
Nicht ein Einziges.

Jochen Müller

Autor: Wolf (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ein Glück hat er UNS.

Autor: Magnus Müller (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Oder anders ausgedrückt:

Zu unserem Unglück hat er uns... =)

Autor: Wolf (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Jetzt reichts.
Wenn wieder, dann heißt er sowieso anders.

Autor: Thomas O. (kosmos)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
probier mal nach dem Widerstand einen 100nF Kerko parallel, wenn die 
Messfrequenz nicht zu hoch ist sollte der Kerko den Spannungsabfall 
verhindern können. Also zw. Kerko und Messystem keinen Widerstand 
reinmachen.

Autor: Magnus Müller (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das ist Quatsch. Der Kerko kann den Spannungsabfall nicht verhindern.

Autor: Thomas O. (kosmos)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das Teil spuckt doch 0-10V aus nur halt nicht so belastbar, wenn die 
Messfrequenz aber nicht so hoch ist hat man doch ausreichend Zeit einen 
Kerko oder meinetwegen auch einen größeren Elko zu laden, wärend der 
Messung wird dann der niederohmige Elko belastet und nicht der Ausgang 
selbst.

Autor: Magnus Müller (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Du meinst quasi, dass der Analogeingang der LOGO nur für den Kurzen 
Moment der Messung mit dem Monitorausgang verbunden sein soll. Dies 
würde aber trotzdem zu einer (wenn auch geringeren) Verfälschung des 
Messergebnisses führen, da der Kondensator während der Messung durch die 
Last teilweise entladen wird und danach über den Ri des Monitorausgangs 
wieder nachgeladen werden muss.

Die vorher genannten Lösungen wären die beste Wahl:

Herabsetzen der Ausgangsimpedanz mittels OpAmps:

 + Keine Signalverfälschung bei Spannungsänderungen
 + Unabhängigkeit der Messspannung von der Lastimpedanz
 + Messspannung weitgehend immun gegen Störeinstrahlungen
 + wenn erforderlich, könnten weitere Messgeräte angeschlossen
   werden, ohne die Messungen der anderen Messgeräte zu beeinflussen
 - erhöhter (wenn auch sehr geringer) Hardwareaufwand

Korrektur des gemessenen Wertes via Software:

 + Keine zusätzliche Hardware notwendig

Gruß,
Magnetus

Autor: Thomas O. (kosmos)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Der Messeingang der Logo belastet das Analogsignal ja nur für den Moment 
der Messung also wenn diese Sample&Hold Stufe der Logo aufgeladen wird. 
Angenommen man misst jede Sekunde einmal und die Messung benötigt 1mSek 
dann hat man 999mSek Zeit damit der Kondensator wieder geladen wird.

Autor: Magnus Müller (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Auf jeden Fall bin ich der Meinung, dass die Hardwarevariante mit dem 
Impedanzwandler dann doch einfacher als deine Lösung ist.

Nix für ungut =)

Magnetus

Autor: Thomas O. (kosmos)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
einen Elko auf der Logoplatine ist doch leichter nachzurüsten als eine 
OPAMP-Lösung die auch noch etwas Hühnerfutter benötigen wird. Zum 
Ausprobieren kann er den Kondensator auch einfach mal hinhalten.

Autor: Magnus Müller (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wenn du denkst dass du nur den C parallel zur LOGO schalten musst, 
liegst du wieder falsch. Die Messspannung würde nach wie vor permanent 
durch den Eingangswiderstand der LOGO belastet werden, was wiederum zur 
Verfälschung des Messergebnisses führt. Der Eingang der LOGO müsste also 
zwischen den Messungen elektrisch vom Monitorausgang getrennt werden. 
Dies wiederum bedeutet einen größeren Hardwareaufwand, als dies beim 
Impedanzwandler nötig wäre.

Gruß,
Magnetus

Autor: Thomas O. (kosmos)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
wie hoch ist den der Eingangswiderstand im Tristate Modus?

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.