mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Merkwürdige Probleme mit ATmega8 & MCP2515


Autor: Areopag (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo!

Ich habe auf einem Steckbrett 2 CAN-Knoten mit je einem ATmega8 
(getaktet mit 9,216 MHz Quarz) und einem MCP2515 (getaktet mit 8 MHz 
Quarz) aufgebaut. Die Kommunktion zwischen den beiden läuft soweit auch 
ganz gut.
Nun hab ich die exakt gleiche Schaltung wie auf dem Steckbrett auf einer 
selbstgeätzten Platine nachgebaut.
Doch leider funktioniert hier weder die Übertragung zu anderen 
Busteilnehmern, noch die Kommunktion im Loopback-Modus des MCP2515.
Ich habe nun schon alle möglichen Komponenten wie MCP2515, ATmega, 
Quarze getauscht, doch leider ohne Erfolg.
Ein Phänomen das wahrscheinlich von Bedeutung ist:
Am CS- und SO-Pin liegt nach dem ersten Senden von Daten (nach der 
initalisierung des MCP) eine Spannung von ca. 0,7V an (mit dem Oszi 
gemessen), dieser Pegel ändert sich dann auch nicht (was sich aber 
sollte)...

Woran könnte das Problem liegen? Eventuell durch die Leitungsführung auf 
der Platine?

MfG,
Areopag

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.