mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik Spannungsversorgung


Autor: Dirk (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo

Ich möchte eine Schaltung aufbauen, hab aber ein kleines Problem mit
den unterschiedlichen Versorgungsspannungen der einzelnen Bauteile.

Ich möchte mit einem 90s8535 (2,7-5,5 Volt Version) einen Drucksensor
(MS5535 von Intersema) auslesen. Der Drucksensor wird mit 2,7 - 3,3
Volt betrieben. Das Ergebnis soll auf einem LCD Display (16x2 DIP
VErsion von Reichelt) ausgegeben werden. Das ganze wird von einem
Lithium Akku (3,7 Volt von einem Nikia 3310) angetrieben.

Problem. Prozessor und Drucksensor könnte ich über 3 - 3,3 Volt
antreiben, aber wie bekomme ich die 5 Volt oder +- 3,3 Volt für das
Display hin, wenn ich mit dem Akku (3,7 Volt) weiterarbeiten will???

Noch eine Frage zum Akku. Am Akku selbst ist eine kleine Platine (Ic
mit 8 Füßen, 4 Kondensatoren und 5 Widerständen)
Wofür ist die gut (Vieleicht Ladecontroller??????)??


Danke  Dirk

Autor: Holger (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Bei dem Akku handelt es sich warscheinlich um einen sogenannten
"intelligenten Akku" d.h. der IC auf der Platine überwacht den Strom
zu und aus dem Akku und errechnet den Ladezustand. Der Hostcontroller
kann dann mit dem eingesetzten Akku kommunizieren und das mehr- oder
weniger volle Akkusymbol erscheint auf Deinem Handydisplay oder in der
oberen Ecke des Camcorder Suchers o.ä......

Zu Deinem Problem mit der Spannung: schon schwieriger!
5V aus 3,3 zu machen ist mit einem Aufwärtswandler kein Problem. Aber
dann ist der Pegelunterschied zwischen Display und Prozessor da. Wenn
möglich würde ich versuchen 5V zu erzeugen und Display und Prozessor
damit zu betreiben und dann nur den Sensor mit geringerer Spannung zu
versorgen. Hängt von ab, wie die Datenübertragung zum uC stattfindet.

gruss Holger

Autor: Peter Kasi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also Displays laufen meist mit deutlich weniger Spannung als 5V, evtl.
mußt du etwas am Timing feilen, da es nicht mehr so schnell arbeitet.
Das größte Problem dürfte der Kontrast sein, aber dafür kannst du dir
recht einfach mit einem ICL7660 o.ä. eine negative Spannung erzeugen
und an den "Kontrast-Pin" hängen, damit du wieder etwas siehst....

Gruß
Peter

Autor: Dirk (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo

Sorry, daß ich jetzt erst antworte, war ein paar Tage offline.
Hab´s jetzt mit dem ICL7660 ausprobiert. Funktioniert gut, sogar die
LED BEleuchtung funktioniert.

Danke für die Tips.

Mit der Stromversorgung werde ich wieder auf NIMh Akkus umsteigen. Ich
glaube die machen weniger Streß, bleibe aber mit den LI-Akkus am BAll.

Dirk

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.