mikrocontroller.net

Forum: Offtopic zum Abschied rauch ich eine


Autor: Santiago m. H. (mausschubser)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
... sagte die Tina (ATtiny2313) und machte sich von dannen.

Hallo,

jetzt bin ich (etwas) verunsichert.

Könntet Ihr bitte mal über Plan und Board schauen, ob ich nen Bock beim 
Planen geschossen habe, oder ob ich nen Fehler beim Bestücken gemacht 
habe?

Falls Plan OK ist, wie könnte ich denn den Fehler aufspüren. ATtiny 
ist/war gesockelt, der Rest ist fest eingelötet. Ich habe nur kleine 
Multimeter (2) zum Messen.

Gruß Santi

Autor: Günny (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich sehe keinen Spannungsregler auf der Platine...
Sicher, dass Dein Netzteil geregelt ist und keinen Wechselstrom 
ausgibt? ;-)
Bei ungeregelten 5V Netzteilen misst man schonmal 10 V am Ausgang...

Autor: egberto (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die Beschaltung der Relais ist doch sehr zweifelhaft.....
Die Schutzdioden gehen ja von GND nach VCC - wenn du die 
Betriebsspannung verpolst arbeiten die zwar als Leuchtdioden, die 
Transistoren an den Relais schützen sie aber nicht(außerdem sollten die 
Relais in den Kollektorzweig).

Autor: Frank W. (frankw) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Verrätst Du uns was U+ ist ? Geregelte 5 Volt - oder mehr ?

Die Freilaufdioden der Relais sollten direkt am Relais sein.
Jetzt sind sie ja über den Transistor und den Vorwiderstand.
Ich denke nicht das sie so ihre Arbeit verrichten können.

Autor: Santiago m. H. (mausschubser)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

vielen Dank für Eure Aufmerksamkeit.

Beim Abrauchen der Tina hatte ich die 5V von einem PC-Netzteil 
verwendet, im Endzustand sollte der 5V-Zweig von diesem 
(http://www.pollin.de/shop/detail.php?pg=NQ==&a=NDA...) NT 
verwendet werden.

Ok, also die Relais habe ich falsch angeschlossen. Kann das schon zum 
Ableben der Tina geführt haben?

Autor: egberto (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
so auf den ersten Blick eigentlich nicht....

Ist der Tiny wirklich sichtbar "abgeraucht" ?

So lange das mit den Relais nicht ok ist, löte erst mal die 2 
Basiswiderstände von den Ralaistransistoren einseitig ab, damit ist 
dieser Schaltungsteil vom uC getrennt.

Dann legst du Betriebsspannung an ohne(!!) uC im Sockel und mißt dort am 
leeren Sockel Betribsspannung und ev. vorhandene Pegel an den anderen 
Anschlüssen.

Wenn das alles ok ist, solltest du den uC (Spannung nat. abschalten) 
einsetzen und prinzipell testen können.

Viel Erfolg!

Autor: Santiago m. H. (mausschubser)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

> Ist der Tiny wirklich sichtbar "abgeraucht" ?

Also es stieg weißer Rauch auf. Daraufhin habe ich natürlich gleich das 
NT ausgeschaltet und der Tiny war so heiß, dass ich mir fast die Finger 
verbrannt hätte.

> So lange das mit den Relais nicht ok ist, löte erst mal die 2
> Basiswiderstände von den Ralaistransistoren einseitig ab, ...

da ich keine SMD-Widerstände auslöten kann, habe ich die Leiterbahn 
durchschnitten.

> Dann legst du Betriebsspannung an ohne(!!) uC im Sockel und mißt dort

5,2V - Mit dem PC-Netzteil habe ich bislang alle Schaltungen betrieben 
und bislang keine Probleme gehabt.

Ich habe den Tiny inzwischen in ein Testboard umgesteckt und ich konnte 
die Fuses noch auslesen. Vielleicht ist sie ja doch noch nicht 
gestorben...

Gruß Santi

P.S. ist die Relaisansteuerung so besser?

Autor: Santiago m. H. (mausschubser)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich habe den Tiny wieder eingesteckt und versucht in der Timer-Platine 
die Fuses auszulesen, aber das hat nicht geklappt.
Fehlermeldung: device not responding

Kann die Verbindung von MOSI zum Schieberegister dafür verantwortlich 
sein?
Habe alle Pins des ISP-Steckers durchgemessen - die passen soweit.
Ich meine, bei meinen ersten LCD-Tests hätte ich auch mal derartige 
Probleme gehabt, meine aber, ich hätte dann doch flashen können, ohne 
die Verbindung zum Schieberegister zu trennen ...

Autor: Simon K. (simon) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Tja, hättest du ein vernünftiges Netzteil benutzt, wäre er unter 
Umständen nicht abgeraucht.

"Je mehr Power, desto besser" gilt nicht immer.

Autor: Falk Brunner (falk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Santiago m. H. (mausschubser)

>Beim Abrauchen der Tina hatte ich die 5V von einem PC-Netzteil
>verwendet, im Endzustand sollte der 5V-Zweig von diesem

AUA!

PC Netzteile sind gefählich weil die

a) eine Grundlast brauchen um saubere Spannung auszuspucken (10W++)
b) im Fehlerfall VERDAMMT vie Strom bringen.

Lesson learned. Hände weg von PC-Netzteilen wenn man nicht GENAU weiss 
was amn tut.

>Ok, also die Relais habe ich falsch angeschlossen. Kann das schon zum
>Ableben der Tina geführt haben?

Nein, soweit bist du gar nicht gekommen.

MFG
Falk

Autor: Falk Brunner (falk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Santiago m. H. (mausschubser)

>NT ausgeschaltet und der Tiny war so heiß, dass ich mir fast die Finger
>verbrannt hätte.

Der ist zu 99% ins Nirvana übergesiedelt.

>P.S. ist die Relaisansteuerung so besser?

Ja. Aber wozu die 47 Ohm?

MFG
Falk

Autor: Santiago m. H. (mausschubser)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

> Tja, hättest du ein vernünftiges Netzteil benutzt

Ist ein NT vernünftig, wenn ich einen 3-4 stelligen Betrag bezahlt habe?
Ich habe das PC-NT nicht wegen der Power genommen, sondern weil es 
einmal (mich) nix gekostet hat, eine gute Regelung hat und leise ist 
(Seasonic).

> Ja. Aber wozu die 47 Ohm?

Es ist ein FBR211NED001U, welches mit einer 12 Ohm Spule an 1,5V 
betrieben werden soll und max. 125mA Strom bekommen darf. Vielleicht 
läßt sich das ja noch eleganter regeln ... ?

> Der ist zu 99% ins Nirvana übergesiedelt.

Bin schon dabei eine neue Platine zu machen. Habe sicher einen Fehler 
beim Bestücken gemacht.

Autor: Simon K. (simon) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Santiago m. H. wrote:
> Hallo,
>
>> Tja, hättest du ein vernünftiges Netzteil benutzt
>
> Ist ein NT vernünftig, wenn ich einen 3-4 stelligen Betrag bezahlt habe?

Nein, ein NT ist in der Hinsicht vernünftig, wenn es nicht über (in 
diesem Falle) 100mA geliefert hätte.

Dafür gibt es Labornetzteile, aber du hättest auch eine einfache kleine 
Wandwarze (mit Trafo drin) benutzen können.

Autor: Santiago m. H. (mausschubser)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Simon,

danke für die Aufklärung!

Gruß Santi

Autor: Thilo M. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Dem Piezosummer würde ich vorsichtshalber auch eine Freilaufdiode 
spendieren, falls keine Interne verbaut ist. Die hauen manchmal 
ordentliche Spitzen 'raus.

Autor: Atmega8 Atmega8 (atmega8) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Autor:  Santiago m. H. (mausschubser)
Datum: 22.08.2008 15:14

also bei T1 und T6 fließen jeweils 16mA in die Basis ( 32mA recht viel 
Strom für I/O-Pins! )

Der BD139 hat doch eine gute Verstärkung, ersetze die 270 Ohm 
Widerstände durch 2k bis 5k Widerstände.
(ich hoffe mal auf den SMD-Widerständen stand nicht "270" rauf, das sind 
dann 27 Ohm und es fließen 320mA von den I/O-Pins in die Basis der 
Transistoren)

Zu den 5V von PC-Netzteil:
- Ich nutze diese 5V auch manchmal, aber da dort recht viel HF-Spitzen 
vom SNT mit übertragen werden sollte man sich eine kleine Platine mit 
einem Festspannungsregler (2.5V bis 4.5V einstellbar) bauen und einen 
kleinen LC-Filter sollte man dem Eingang vorschalten.

Wenn du sicher gehen willst solltest du immer einen Vorwiderstand vor 
deine Schaltung setzen, die Spannung langsam erhöhen und den 
Spannungsabfall über diesen Vorwiderstand messen. Dann kannst du 
abschätzen ob deine Schaltung in Ordnung ist und ob du ihr volle 5V 
geben kannst.

Autor: Falk Brunner (falk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@ Atmega8 Atmega8 (atmega8) Benutzerseite

>Wenn du sicher gehen willst solltest du immer einen Vorwiderstand vor
>deine Schaltung setzen, die Spannung langsam erhöhen und den
>Spannungsabfall über diesen Vorwiderstand messen. Dann kannst du
>abschätzen ob deine Schaltung in Ordnung ist und ob du ihr volle 5V
>geben kannst.

Diesen Schwachsinn kann man sich schenken, wenn man mal 10 Euro in einen 
strombegrenzten Spannungsregler investiert, L200 ist dein Freund. Oder 
sich gleich für 30 Euro irgendwo ein einfaches Labornetzteil besorgt. 
Aber warum einfach und sicher, wenns auch anders geht. . .

Ebay-Artikel Nr. 250285471966

Autor: Santiago m. H. (mausschubser)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Atmega Atmega (atmega8)
> und einen kleinen LC-Filter sollte man dem Eingang vorschalten.

entspricht L2 mit C10 und C11 nicht dem LC-Filter?
Den Spannungseingang habe ich entsprechend den Appnotes von Atmel 
gemacht.

> Wenn du sicher gehen willst solltest du immer einen Vorwiderstand vor
> deine Schaltung setzen, die Spannung langsam erhöhen und den

Naja, ich habe auch schon einiges an Hühnerfutter verfeuert, konnte 
derlei Fehler bislang aber immer meiner eigenen 
Dummheit/Fehlerhaftigkeit zuordnen. Auf die Idee, mit einem anderen NT 
bin ich erst mit diesem Fred gebracht worden. Habe mir bislang keine 
Gedanken um das NT gemacht.

@Falk Brunner
> Diesen Schwachsinn kann man sich schenken, wenn man mal 10 Euro in einen
> strombegrenzten Spannungsregler investiert, L200 ist dein Freund.

Danke für den Tip mit L200 - habe mir gleich das Datenblatt gezogen.
Der Bau eines Labor-NTs steht bei mir auch auf der Wunschliste. Bislang 
habe ich mich eher an den L47xx Schaltreglern orientiert.
Kann man den L200 (mehr oder weniger) mit der 78er Reihe vergleichen, 
d.h. die Differenz der Spannung wird in Wärme umgesetzt?

Bei den L47xx wollte ich eine Stromregelung selbst dazu bauen (mit mega 
+ ADC).

Ist nicht so, dass ich keine kleineren Netzteile hätte - ich hatte mir 
bislang keine Gedanken darüber gemacht.

> Aber warum einfach und sicher, wenns auch anders geht. . .
Falk, ich würde Unwissenheit nicht mit Unwilligkeit gleichsetzen. Das 
Thema der HW-Bastelei ist viel zu komplex, um gleich alles richtig zu 
machen oder gleich alle Eventualitäten beim Einstieg bedenken zu können.
Vielleicht schaltet sich Dein Sarkasmus etwas zu früh ein?!?

Da ich durch die Diskussion einiges gelernt habe, tut mir weder die 
Platine, noch die zu ersetzende Tina leid. Ich sehe das eher als "gut 
investiertes Leergeld" :D

Gruß Santi

Autor: Falk Brunner (falk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@ Santiago m. H. (mausschubser)

>Kann man den L200 (mehr oder weniger) mit der 78er Reihe vergleichen,
>d.h. die Differenz der Spannung wird in Wärme umgesetzt?

Ja, es ist ein klassischer Linearregler.

>Bei den L47xx wollte ich eine Stromregelung selbst dazu bauen (mit mega
>+ ADC).

Besorg dir erstmal ne solide Grundausrüstung.

MfG
Falk

Autor: cdg (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Nimm als +5 Volt die Standby-Spannung (ATX-Netzteil).
Da raucht nichts ab, die Spannung ist auch sauber.

cdg

Autor: Santiago m. H. (mausschubser)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo und danke für die Hinweise/Antworten.

> Nimm als +5 Volt die Standby-Spannung (ATX-Netzteil).
> Da raucht nichts ab, die Spannung ist auch sauber.

Habe zwar nur von Enermax ein Handbuch, aber dort liefert die 
Standby-Leitung durch die Bank bei allen Modellen locker 2A.
Schätze ich werde (zumindest für die ersten Tests) ein kleines 
Steckernetzteil nehmen (< 1A).

Gruß Santi

Autor: Atmega8 Atmega8 (atmega8) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> entspricht L2 mit C10 und C11 nicht dem LC-Filter?
> Den Spannungseingang habe ich entsprechend den Appnotes von Atmel
> gemacht.
Ja, passt schon.

> wenn man mal 10 Euro in einen strombegrenzten Spannungsregler investiert
Stimmt schon, eine ordentliche Ausrüstung erspart viel Fehlersuche und 
gibt einem eine gewisse Sicherheit.

@ Santiago m. H.
Ich habe hier einen LM317 der regelt/begrenzt mir den Strom auf 50mA und 
davor einen anderen am 12V Netzteil der die Spannung begrenzt.
Das reicht auch aus.

Bitte melde dich an um einen Beitrag zu schreiben. Anmeldung ist kostenlos und dauert nur eine Minute.
Bestehender Account
Schon ein Account bei Google/GoogleMail, Yahoo oder Facebook? Keine Anmeldung erforderlich!
Mit Google-Account einloggen | Mit Facebook-Account einloggen
Noch kein Account? Hier anmelden.