mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik Probleme mit Analogschaltung (Transimp. + OV)


Autor: Martin L. (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

Ich habe ein Problem mit folgender Schaltung:
Transimpedance Verstärker + Verstärkerschaltung

Beides für sich funktioniert einwandfrei, soll der OV jedoch das Signal 
aus der Transimpedancestufe verstärkern passiert nichts (als ob der 
Eingang dann auf Masse liegt)
Kann mir jemand erklären woran es liegt?

Vielen Dank

Martin

Autor: Nides (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die 2te Stufe ist ein invertierender Verstärker.
Wenn der OP keine negative Versorgung hat, dann kann er auch kein 
negatives Signal ausgeben!

Nides

Autor: Lothar Miller (lkmiller) (Moderator) Benutzerseite
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
>Beides für sich funktioniert einwandfrei
Wie das?
>als ob der Eingang dann auf Masse liegt
Eher, also ob der Ausgang auf Masse liegt.

Da muss ein nichtinv. Verstärker als 2. Stufe rein.
Also: den 10k Widerstand an Masse, und das Signal an den +Eingang vom 
OP2.

Autor: Martin L. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Vielen dank, es funktioniert.

Ich habe aber noch ein anderes Problem bei dem ihr mir evtl weiterhelfen 
koennt. Auf dem Ausgang des Transimpedanceverst. liegt ein Ozilieren von 
50Hz (kommt nicht durch Leuchtstoffroehren). Nur mit einem sehr grossem 
C parallel zu R, kann ich es unterdruecken. Dadurch geht aber die 
Dynamik verloren, welche Moeglichkeiten gibt es noch?

Danke Martin

Autor: Stefan (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>liegt ein Ozilieren von 50Hz
Bei der großen Impedanz und Verstärkung von 10Meg wundert Dich das?

Schirmung, Schirmung, Schirmung!
Schau Dir mal die AppNotes diverser OP-Hersteller dazu an. Stichwort 
"Guard-Ring" usw...

Autor: Falk Brunner (falk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@ Martin L. (Gast)

>koennt. Auf dem Ausgang des Transimpedanceverst. liegt ein Ozilieren von
>50Hz (kommt nicht durch Leuchtstoffroehren). Nur mit einem sehr grossem

Aber vielleicht vom Netz. Tastkopf falsch angeschlossen? Schlechte 
Masseverbindung?

>C parallel zu R, kann ich es unterdruecken.

Das C ist sogar ZWINGEND notwendig.

Lichtsensor / Helligkeitssensor

> Dadurch geht aber die Dynamik verloren,

Nöö, nur Bandbreite. Dynamik ist was anderes.

MFG
Falk

Autor: Martin L. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Koennt ihr mir ein paar Tips geben, wie ich das Ganze am Besten 
abschirmen kann?

Autor: Michael Lenz (hochbett)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

es ist denkbar, daß die 50 Hz über die Versorgungsspannung kommen.
Um das herauszufinden, kannst Du die OPV testweise mit einer Batterie 
betreiben.

Wenn das hilft, kannst Du Dir folgende Maßnahmen überlegen:
- Verwendung eines Linearreglers für die Eingangsspannung 
(beispielsweise
  LM317; wenn der OPV auch 5V verträgt, dann 7805).
- Einbau eines Parallelschwingkreises mit fg=50 Hz in die
  Versorgungsleitung auf dem Board (wahrscheinlich sind die Bauteile 
dazu
  recht groß).

Um auszuschließen, daß die 50 Hz von den Lampen kommen, hast Du die 
Photodiode sicher verdunkelt. Das Ergebnis wundert mich nicht, da eine 
Lampe i. a. mit 100 Hz flackert. (Strom von rechts nach links --> hell; 
Strom von links nach rechts --> wieder hell).


Gruß,
  Michael

Autor: Michael Lenz (hochbett)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Falk,

>>C parallel zu R, kann ich es unterdruecken.
>
> Das C ist sogar ZWINGEND notwendig.
Ich glaube, ihr redet von verschiedenen C.

Du sprichst von größenordnungsmäßig 10pF, um ein Schwingen des OPV zu 
verhindern. Das führt zu einer Zeitkonstante von tau=1MEG*10pF = 10E-9s.

Er spricht von einem Kondensator, der die Grenzfrequenz auf <50 Hz 
bringen soll.


Gruß,
 Michael

Autor: Michael Lenz (hochbett)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Stefan,

kennst Du Dich mit den Guard-Ringen aus? Ich habe im Datenblatt des 
OPA2380 gelesen, daß sie auf demselben Potential liegen sollen wie die 
Leitungen, damit Leckströme verhindert werden sollen.

- Weißt Du, ob es dabei in der Praxis um Leckströme geht, oder eher um
  kapazitive Kopplungen zu irgendwelchen Nachbarleitungen? Bei HF-Sachen
  könnte ich mir vorstellen, daß Kapazitäten auch schon was ausmachen.

Ich habe mit dem OPA2380 eine Schaltung wie Martin aufgebaut.
- Siehst Du das auch so, daß der Guard-Trace die Massefläche ist.

Ich vermute ja, daß das so ist, weil beide Eingänge des OPV auf 
Massepotential sind; ich kenne aber niemanden, der mir das definitiv 
beantworten kann.

Bei Avalanche-Photodioden wäre mir alles klar. Dort treibst Du die Diode 
ja mit typischerweise 100V; da kann ich mir einen Leckstrom schon 
vorstellen.



Gruß,
  Michael



>>liegt ein Ozilieren von 50Hz
> Bei der großen Impedanz und Verstärkung von 10Meg wundert Dich das?
>
> Schirmung, Schirmung, Schirmung!
> Schau Dir mal die AppNotes diverser OP-Hersteller dazu an. Stichwort
> "Guard-Ring" usw...

Autor: Martin L. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Michael,

hast du mal versucht die Photodiode gehen + zu legen?  Ich werde morgen 
mal weiter testen.. Hast du auch das 50Hz Problem?

Autor: kurt (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo!

Das Problem ist unter anderem, dass bei solchen HF-Aufbauten mit
alternativen Verstärkerkonzepten das Layout extrem kritisch sein kann.
Deswegen ist in den Datenblättern der Hersteller sehr oft eine
Empfehlung für das Layout abgebildet.

> Bei HF-Sachen
> könnte ich mir vorstellen, daß Kapazitäten auch schon was ausmachen.

Es können schon mal ohne weiteres parasitäre Kapazitäten von einigen
pF vorkommen. In Verbindung mit den sehr hochohmigen Widerständen, die
ich in deiner Schaltung sehe kann das natürlich bei höheren Frequenzen
zu Problemen führen.

> kennst Du Dich mit den Guard-Ringen aus? Ich habe im Datenblatt des
> OPA2380 gelesen, daß sie auf demselben Potential liegen sollen wie die
> Leitungen, damit Leckströme verhindert werden sollen.

Guard Ringe sollen definitiv auf dem selben Potential liegen, wie deine
Signalleitung(en).
Wenn nämlich Signalleitung und Guard-Ring auf dem selben Potential 
liegen,
verhinderst du Leckströme von der Signalleitung zum Guard-Ring.
Eventuelle Leckströme fließen dann vom Guard-Ring zur Masse (oder sonst
wohin). Das beinflusst die Signalleitung dann allerdings kaum.

> - Weißt Du, ob es dabei in der Praxis um Leckströme geht, oder eher um
>  kapazitive Kopplungen zu irgendwelchen Nachbarleitungen? Bei HF-Sachen
>  könnte ich mir vorstellen, daß Kapazitäten auch schon was ausmachen.

Hier verhält es sich ähnlich wie oben:
Es besteht eine (parasitäre) Koppelkapazität zwischen Guard Ring und
Signalleitung - diese wirkt sich allerdings auf Grund der im Idealfall
bestehenden 0 V Potentialdiffernz kaum auf das Signal aus.

Gruß

Kurt

Autor: Martin L. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich bekomme die 50Hz einfach nicht weg, selbst im Batteriebetrieb nicht. 
Ich habe es jetzt mit dem OPA354 und OPA380 probiert bei beiden sind 
50Hz Schwingungen zu beobachten. Durch das C (parallel zu R) kann ich 
lediglich die Amplitude verringern (min 5mV). Fremdlicht ist 
auzuschliessen, da ich die Photodiode komplett verdunkelt habe.
 Woran kann es liegen, hat jemand ein paar Tipps für mich?

Autor: HildeK (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ganz normal Einstreuung von
- Labornetzteil
- Lötkolben
- Monitor
- ....

Autor: B e r n d W. (smiley46)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hast Du eine Keksdose aus Blech oder eine Konservendose? Dann steck die 
Schaltung da rein und verbinde Deine Masse mit der Keksdose. Es wird 
dunkel und abgeschirmt --> der Brumm sollte mindestens Faktor 10 weniger 
werden.

Guard-Ring um die hochohmige Schaltung des positiven Eingangs eines OPs.
Dabei geht es um Kriechströme, nicht um Brumm. Je nach Anwendung kann 
GND, der negative Eingang oder der Ausgang des OPs (Gegenkopplung) auf 
den Ring gelegt werden. Die Kriechströme liegen normalerweise im pA oder 
nA Bereich.

Gruß, Bernd

Autor: Michael (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

von der Batterie kommen die 50 Hz sicher nicht und vom 
Operationsverstärker auch nicht. Wenn Operationsverstärker schwingen, 
dann eher mit MHz.

Schalte in der Nähe alle unnötigen Geräte ab, die als Störquelle infrage 
kommen: Monitor wurde schon genannt, Lampe in der Lupe, alle Geräte mit 
Trafos.

Als Lampe zum Test kannst Du eine Taschenlampe nehmen.

Beachte beim Oszilloskop, daß beide Anschlüsse des Tastkopfes 
angeschlossen werden müssen:
- Messspitze an den Ausgang des Oszilloskops
- Klemme an die Schaltungsmasse

Die Oszilloskopklemme ist mit der Geräteschirmung verbunden.



Gruß,
  Michael

Autor: Martin Laabs (mla)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Manchmal kann auch ein 50Hz Notchfilter helfen wenn man mit der 
entsprechenden Frequenzantwort leben kann.

Autor: Mores (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo alle,
Ich habe auch genau das gleiche Problem mit der 50Hz, hat einer von euch 
eine Idee wie man das abschaffen kann ohne das die Schaltung zu langsam 
wird?Ich meine ohne das man noch großere kapazität zu filtern 
anwende.Eine Bemerkung bei mir habe ich bemerke das wenn ich mit dem 
Oscilloscope in irgendeinem Punkt der Platine  der keine Verbindung mit 
meiner schaltung hat, messe statt null volt kriege ich eine 
Wechselspannung im bereich von Millivolt das auch  50Hz.Das bedeutet 
ganz klar das meine Schaltung kein Problem hat aber woraus kann diese 
Error stammen.
Gruß Mores,

Autor: Kai Klaas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Ich habe auch genau das gleiche Problem mit der 50Hz, hat einer von euch
>eine Idee wie man das abschaffen kann ohne das die Schaltung zu langsam
>wird?

Ist es wirklich 50Hz, oder eher 100Hz? Auch Glühlampen haben einen 
erheblichen 100Hz AC-Anteil im Licht. Das wird oft unterschätzt.

Kai Klaas

Autor: Mores (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ja diese 50Hz haben nichts mit der Beleuchtung zu tun, ich arbeite 
einfach nur mit dem Tageslicht außerdem,mein Oscilloscope ergibt mir 
auch 50hz auch wenn die Anschlüße einfach im  Luft stehen.Ich kriege in 
dem Fall eine Wechselspannung mit 50Hz im bereich von mV.Ich hatte erst 
gedacht das das ganze mit einem kriechstrom zu tun hätte aber der 
Kriechstrom erscheint erst im Bereich von nV also meine Oscilloscope 
konnte mir kein Ergebnis im mV ergeben.Von meiner Batterie kommt das 
auch nicht ich habe überprüft.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.