mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik Op Amp verstärkt schlecht


Autor: Manuel (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

http://www.reichelt.de/?;ACTION=7;LA=6;OPEN=1;INDE...
Das ist das Datenblatt meines Operationsverstärkers. Auf Seite 6 ist ein 
Input Offset Voltage Null Circuit. Was soll das sein? Und was bedeuten 
die Dreiecke in dem Diagramm? Was anderes hab ich nicht gefunden, wie 
ich die beiden Offsets verbinden muss. Hab das einfach mal so verbunden 
und die Dreiecke ignoriert, aber die Verstärkung beträgt 410 statt 450. 
Was könnte ich sonst falsch gemacht haben?

Autor: Helmut -dc3yc (dc3yc)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Welche beiden Dreiecke? Das eine ist ein OpAmp, das andere der Schleifer 
eines Potis. Und die Schaltung ist, wie der Name schon sagt, zu 
Offsetabgleich des Verstärkers. Und welche Pins hast du verbunden? Die 
Offsetabgleichpins? Wenn du die nicht benutzt, dann lass die offen!

Servus,
Helmut.

Autor: Jens G. (jensig)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
klingt ja trollig ...

Autor: Manuel (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ahso, das soll ein Poti darstellen. Naja ich möchte die nicht benutzen, 
da ich gar nicht weiss was der Offset-Abgleich ist und sie sind nun 
offen gelassen. Trotzdem wird so schlecht verstärkt. 225mV sollen auf 
450mV verstärkt werden, angezeigt werden 410mV. Sind so grobe Fehler 
normal bei Op-Amps oder was könnte ich falsch gemacht haben?
Ist denke ich alles nach dem Tutorial hier verbunden, eine Verstärkung 
ist ja auhc sichtbar. Verwendet werden 2 1kOhm widerstände.

Autor: yalu (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> 225mV sollen auf 450mV verstärkt werden, angezeigt werden 410mV. Sind
> so grobe Fehler normal bei Op-Amps ...

Nein.

> oder was könnte ich falsch gemacht haben?

Einiges.

Sind die Widerstände halbwegs genau? Sie müssen nicht absolut genau
sein, sondern nur gleich. Das kannst du leicht (auch mit einem
schlechten) Multimeter nachprüfen.

Hast du alle Vorgaben in der Tabelle "recommended operating conditions"
im Datenblatt erfüllt? Wie hoch sind die positive und die negative
Versorgungsspannung?

Ist die Signalquelle am Eingang extrem hochohmig? Wie sieht die
Signalquelle aus?

Zieht die Last am Ausgang zuviel Strom? Wie sieht die Last aus?

Autor: Manuel (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
danke für die antwort erstmal

>Einiges.

Da hab ich befürchtet g

>Sind die Widerstände halbwegs genau? Sie müssen nicht absolut genau
>sein, sondern nur gleich. Das kannst du leicht (auch mit einem
>schlechten) Multimeter nachprüfen.

Hmm, sie sind 0,983 und 0,987kOhm.

>Hast du alle Vorgaben in der Tabelle "recommended operating conditions"
>im Datenblatt erfüllt? Wie hoch sind die positive und die negative
>Versorgungsspannung?

Ich denke ja. Vcc+ beträgt 5V. Vcc- hängt an GND, dachte das geht, wenn 
man nur positiven Input hat. Oder hab ich mich getäuscht?

>Ist die Signalquelle am Eingang extrem hochohmig? Wie sieht die
>Signalquelle aus?

Hmmmm, also die Signalquelle ist ein Poti zw. meiner Versirgungsspannung 
(5V) mit dem Schleifer an IN+. Sollte also nicht extrem hochohmig sein

>Zieht die Last am Ausgang zuviel Strom? Wie sieht die Last aus?

Ich weiß nicht wie viel, denke aber nicht sehr viel. Der Ausgang hängt 
an einem ATmega8, der die Daten weiterverarbetet

Autor: yalu (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Hmm, sie sind 0,983 und 0,987kOhm.

Also ziemlich gleich, das ist in Ordnung.

> Ich denke ja. Vcc+ beträgt 5V. Vcc- hängt an GND, dachte das geht,
> wenn man nur positiven Input hat. Oder hab ich mich getäuscht?

Im Datenblatt steht aber min. ±3V. Du kannst zwar den Nullpunkt woanders
hinlegen (mit Einschränkungen beim Eingangsspannungsbereich, s.u.),
trotzdem muss VCC+ - VCC- >= 6V sein. Bei dir sind es nur 5V.

Die Common-Mode-Input-Voltage, also der zulässige Eingangsspannungs-
bereich ist für VCC± = ±15V mit ±13V angegeben. Wie dieser Bereich bei
+5V und 0V aussieht, kann man leider nur schätzen, bspw. so: Die
Eingangsspannung muss in etwa zwischen VCC- + 2V und VCC+ - 2V liegen,
in deinem Fall also zwischen +2V und +3V. Die 225mV liegen eindeutig
außerhalb dieses Bereichs.

Die Ausgangsspannung reicht laut Datenblatt bei VCC± = ±15V von -13V bis
+13V. Bei 5V dürfte dieser Bereich nicht viel weiter als von +2V bis +3V
reichen. Da jedoch der Ausgang durch den ADC praktisch überhaupt nicht
und durch die Gegenkopplungswiderstände nur gegen GND belastet wird,
wird er in deiner Schaltung wahrscheinlich den Bereich von 0V bis 3V
abdecken, was dann wieder ok sein dürfte.

Auf jeden Fall scheint der OP07 nicht der richtige Verstärker für deinen
Versorgungs- und Eingangsspannungsbereich zu sein. Sehr viel besser
würde der LM358 oder ein beliebiger anderer Single-Supply-OPV passen.
Der LM358 funktioniert schon ab 3V Versorgungsspannung, und der
Eingangsspannungsbereich beginnt schon bei 0V. Gedanken um den
Offsetabgleich musst du dir auch nicht machen, da bei diesem Bauteil gar
nichts abgeglichen werden kann ;-) Dafür stecken in einem Gehäuse gleich
zwei Verstärker, vielleicht brauchst du ja an anderer Stelle noch einen.

Autor: Timbo (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Tata. Erstes Problem. Das ist kein Rail to Rail Verstärker. Nimm einen 
TLC271, setz den in den Bias mode den Du brauchst und lass den 
Offsetabgleich offen. Dann geht es.

Autor: Michael (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Problem ist die Eingangsspannung. Wie ja schon richtig erwähnt wurde ist 
der OP07 kein Rail-to-Rail-OP, also kein OP der von der oberen 
Betriebsspannung bis zur unteren Betriebsspannung schalten kann. 
Vielleicht kannst du, außer einen Rail-to-Rail-OP zu verwenden auch eine 
um 0V symetrische Spannung anlegen. Nimmst du nun einen Rai-to-Rail und 
bleibst bei der Versorgungsspannung würde ich auf alle Fälle einen 
Offset-Spannungsabgleich machen. Immerhin erwartest du am Ausgang nicht 
mal 10 % der Betriebsspannung. Und so viel falsch gemacht hast du auch 
nicht, du bist nur in die üblich Falle beim Einstieg in die Arbeit mit 
OPs getappst ;)

Autor: Manuel (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo!

nur um sicher zu gehen, dass ichs richtig verstanden habe, ein Rail to 
Rail Op Amp ermöglicht also in meinem Fall eine Verstärkung jeder 
beliebigen Spannung von 0 bis 5V?

Das würde passen, im mittleren Bereich verstärkt er relativ genau.. aber 
irgendwann macht er einfach schluss und auf meinem LCD gehts (schon 
verstärkt) z.B. nur bis 4300mV...

Naja, dann werd ich mir mal ein paar neue bestellen. Wie genau 
funktioniert der Offset-Abgleich?

Autor: Michael (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Hallo!
>
>nur um sicher zu gehen, dass ichs richtig verstanden habe, ein Rail to
>Rail Op Amp ermöglicht also in meinem Fall eine Verstärkung jeder
>beliebigen Spannung von 0 bis 5V?

Oh nein, Rail-to-Rail bedeutet nur, dass der OP an seinem Ausgang bis 
zur Betriebsspannung des OPs ausgesteuert werden kann, d.h. der Ausgang 
kann Spannungen im Bereich von -Vcc bis +Vcc annehmen. Das muss nicht 
zwangsläufig heißen, dass er diese Spannungen auch am Eingang haben 
darf. Welche Spannungen er am Eingang haben darf ist von OP zu OP 
verschieden, das Datenblatt weiß Rat dazu.

Autor: Manuel (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
achso, naja dann muss ich mal was geeignetes suchen.

>Nimm einen
>TLC271, setz den in den Bias mode den Du brauchst
Ich weiss gar nicht, was der Bias mode ist gg. Ich glaub, dann probier 
ichs erstmal mit einem einfacheren, wo man das nicht braucht, aber danke 
für den Rat.

Was haltet ihr vom LM358? Der wird im Tutorial empfohlen

Autor: Michael (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Da du ja nur eine Spannung von 225 mV verstärkenb willst und der Input 
Common Rangen bei einer Single Supply Versorgung von 0 bis Ub-1.5 V geht 
dürfte das bei deiner 5 Volt Versorgung keine Probleme bereiten.

Autor: yalu (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Was haltet ihr vom LM358? Der wird im Tutorial empfohlen

Der LM358 geht eingangs- und ausgangsseitig bis auf 0V hinunter,
deswegen habe ich in in meinem letzten Post vorgeschlagen. Allerdings
reicht der Ausgang bei 5V Versorgungsspannung nur bis etwa 3,5V. Damit
kannst du nicht den vollen Dynamikbereich des ADC nutzen, sofern dieser
mit einer Referenzspannnung von 5V betrieben wird. Man kann aber die
Referenzspannung auf 3,5V herabsetzen, dann passt es wieder.

Einen OPV mit Rail-to-Rail-Ausgang brauchst du eigentlich nur dann, wenn
du, aus welchen Gründen auch immer, unbedingt 5V als Referenzspannung
nehmen möchtest. Und kostenmäßig kann dem LM358 (7 Cent) keiner das
Wasser reichen :)

Mal eine ganz andere Frage: Wenn die Signalquelle einfach nur ein Poti
von VCC nach GND ist, warum brauchst du dann überhaupt einen OPV?
Schließe doch einfach den Abgriff des Potis direkt an den ADC-Eingang
an.

Autor: Ralph Referenz (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
OK, der LM358 passt dann denk ich gut. Wollte die Referenzspannung 
sowieso noch auf 2V senken.

Zu deiner Frage: Ich brauch später OPVs, daher hatte ich mir nun schon 
mal einen mitbestellt, um die einfach mal zu testen. Wollte die Spannung 
mal verdoppeln, einfach um sicher zu gehen, dass später alles 
funktioniert. Also reiner Testaufbau :-)

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.