mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Impedanzwandler mit AD817


Autor: Björn (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Leute,

ich möchte einen AD817 als Impedanzwandler verwenden, da ich den Rest 
meiner Schaltung (Besseltiefpassfilter 8ter Ordnung) mit den gleichen 
OPs realisiere.

Aber wenn ich den pos. Eingang des Impedanzwandlers auf Masse lege, dann 
bricht die negative Versorgunsspannung zusammen (es wird über 100mA 
benötigt), egal ob dabei der Ausgang beschaltet ist oder nicht! Woran 
kann das liegen?
Im Datenblatt steht, dass er Verstärkungen von +1 realisieren kann. Oder 
gibt es noch ein anderes Kriterium, welches es verbietet, den AD817 als 
Impedanzwandler einzusetzen?

Viele Grüße,
Björn

Autor: Raimund Rabe (corvuscorax)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
a) Die ganze Sache schwingt (passiert bei diesen 'High Speed' OpAmps 
recht schnell - bedingt durch schlechten Aufbau, Masseführung, ...) - 
ein Oszi wär hier ganz hilfreich.
b) Das Netzteil ist an seiner Grenze, bzgl. Stromlieferfähigkeit, 
angelangt - OpAmp raus und mal einen ohmschen Belastungswiderstand 
reinsetzen.
c) Dieser OpAmp ist generell defekt - mal mit einem Anderen aus dem 
Besselfilter tauschen.
d) ...

Weiteres, wenn man mehr über die Schaltung, Aufbau, usw. erfahren kann 
und die Antworten zu a)...c) vorliegen.

Autor: Björn (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ich habe den op als impedanzwandler mittlerweile getrennt aufgebaut, 
ganz simpel, alle fehlerquellen wie übersprechen, massefehler, emv sind 
ausgeschlossen!

zu c) ich habe den op mit 5 anderen frisch gekauften ausgetauscht, er 
ist auf jeden fall nicht defekt
zu d) das netzteil kann bis zu 1 A liefern, daran liegt es nicht

zu a) das teilt schwingt tatsächlich mit etwa 10 Mhz! Aber das darf 
eigentlich gar nicht sein. Laut Datenblatt muss der OP ein Gain von 1 
schaffen!! Warum schwingt das Teil trotzdem? Was kann ich dagegen 
machen?

Autor: Björn (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ok ich habe mal zwei dicke kondensatoren an die die Spannungsquelle 
geklemmt und siehe da: das Schwingen am Ausgang des AD817 ist fast weg!

Aber das darf bei so hochwertigen OPs doch eigentlich nicht passieren??

Wenn ich z.B. ein OP213 als Impedanzwandler verwende, mit der gleichen 
Spannungsquelle ohne Kondensatoren, dann schwingt die Schaltung nicht! 
Aber ein OP213 kann ich leider nicht verwenden, weil ich eine hohe 
Bandbreite (mind. 50 MHz) für meine Schaltung brauche.

Autor: Raimund Rabe (corvuscorax)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Björn wrote:
> ich habe den op als impedanzwandler mittlerweile getrennt aufgebaut,
> ganz simpel, alle fehlerquellen wie übersprechen, massefehler, emv sind
> ausgeschlossen!

Tja, ganz 'simple' führt manchmal zu Problemen! Und Massefehler und 
schlechte Abblockung der Versorgungsspannung ist der funktionierenden 
Schaltung Todfeind. ABer dazu komme ich noch weiter unten.

>
> zu c) ich habe den op mit 5 anderen frisch gekauften ausgetauscht, er
> ist auf jeden fall nicht defekt

OK.

> zu d) das netzteil kann bis zu 1 A liefern, daran liegt es nicht

Als eigentliche Quelle des Übels wird das Netzteil vmtl. nicht direkt zu 
identifizieren sein. Ich denke hier kommt ein 78xx zum Einsatz, oder? 
Abblockkondensatoren wie im Datenblatt 'recommended' sollte man jedoch 
nie vergessen einzulöten.

>
> zu a) das teilt schwingt tatsächlich mit etwa 10 Mhz! Aber das darf
> eigentlich gar nicht sein. Laut Datenblatt muss der OP ein Gain von 1
> schaffen!! Warum schwingt das Teil trotzdem? Was kann ich dagegen
> machen?

Als ob ich's nicht geahnt hätte!
Alles aufzuzählen, was man falsch machen kann, würde hier zu weit 
führen. Es gibt da gute Literatur von den großen Herstellern wie eben 
Analog Devices (AN), Texas Instruments (TI), usw.
Such ggf. mal in den Application Notes (AN) nach 'Grounding' und/oder 
'Layout Considerations' in Verbindung mit 'High-Speed Devices'. Leider 
hab ich die AN-Nummern von AD oder TI nicht parat - aber wer suchet, der 
findet auch.

Übrigens sind alle sogenannten 'High Speed' OpAmps sehr sensibel was 
Schwingneigungen angeht, wenn das Platinenlayout nicht optimal ist - da 
ist es völlig egal ob im Datenblatt drinsteht, das er 'unity-gain 
stable' ist oder nicht!
Versorgungsspannungen immer gut (und richtig) abblocken. Masse-Führung 
bloss richtig machen, d.h. in den meisten Fällen flächig und mit 
niedriger Impedanz, usw.
Diese OpAmps z.B. mal eben auf einer Lochrasterplatine aufzubauen, um zu 
sehen ob die Schaltung richtig ausgelegt ist, wäre fatal und außerdem 
reiner Zufall wenn es auf anhieb funktionieren würde.

Wenn alles nicht fruchtet würde ich auf langsamere OpAmps umsteigen, 
sofern die Applikationsanforderungen (aka Pflichtenheft) dies erlauben. 
Zur maximal zu verarbeitenden Frequenz hattest du aber (noch) nichts 
geschrieben.
Korrektur meinerseits: Jetzt hast du, während ich nich schrieb, doch was 
zur max. Frequenz geschrieben. Und - man höre und staune - weitere 
Abblockkondensatoren am Netzteil am die Schwingneigung verringert aber 
(noch) nicht beseitigt. Das Abblocken am AD817 selbst scheint also 
weiterhin 'suboptimal' zu sein.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.