mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik LVDS Display anschließen


Autor: Benjamin K. (benni222)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hey! Ich habe ein Problem. Und zwar habe ich ein 3,5" Board und möchte 
nun über LVDS ein Display anschließen. Das Board hat ein 20 poligen 
Hirose Stecker (sieht so aus: 
http://www.hirose.co.uk/productreleases/df20.htm)
Das Display stammt aus einem EEE 900 und hat ein I-Pex stecker (den hier 
mit 40 pins: 
http://www.i-pex.com/en/component/option,com_produ...)
Ich habe bereits ein Kabel vom Display, das jedoch auf der einen Seite 
den oben genannten IPex stecker hat und auf der anderen Seite diesen 
Stecker (20polig): 
http://www.i-pex.com/en/component/option,com_produ...

Wenn ich alles nun richtig verstanden habe, brauche ich also einen Kabel 
mit Hirose Plug an der einen Seite und auf der anderen Seite entweder 
die 20 polige Buchse oder den 40 poligen Stecker. Stimmt das? Und wenn 
ja, wo gibt es diese Bauteile und gibt es eine Pinnbelegung der IPex 
stecker?

Vielen Dank für eure Hilfe

Autor: Michael Wulz (mwulz)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich würde mir die Pinbelegung von beiden Steckern googlen und 
anschließend ein Kabel löten?

gruss
M

Autor: Stefan Wimmer (wswbln)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
...und bei der Kabelanfertigung nicht vergessen: LVDS sind 
differenzielle Signale, die auf verdrillten Paaren zu führen sind.

Autor: Benjamin K. (benni222)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hey! Danke für die Antworten. Das Problem ist, dass ich den i-pex 
stecker bzw buchse nirgends zum kaufen finden kann. Kennt von euch 
jemand eine Seite wos den gibt? Den Hirose Stecker hab ich schon wo 
gefunden. Das 2. Problem ist, dass ich auch schon noch der 
steckerbelegung vom i-pex stecker gesucht habe, aber auch dort nichts 
gefunden habe, beim Hirose stecker aber schon... Kennt auch da jemand 
eine Seite wo des steht???

Vielen Dank für eure Hilfe!!

Autor: Benjamin K. (benni222)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hey! Ich hab endlich die Pinbelegung vom 20 pol stecker gefunden: 
http://www.eeefan.com/archiver/?tid-250.html
Teilweiße kann ich diese auch zu meinem Mainboard stecker zuordnen, 
jedoch leider nicht alle. Ich hab maln Bild davon hochgeladen. Kann mir 
jemand von euch bei der Zuordnung helfen?

Bisher bin ich soweit:
Handbuch=EEE Pinbelegung

1=7
2=12
3=9
4=8
5=11
6=10
7=14
8=13
9=16
10=15
11=?
12=?
13=5?
14=?
15=?
16=?
17=?
18=?
19=?
20=?

Was bedeutet NC?
Und sind die LCD_VCC des back light zeug oder ist des die spannungen die 
da liegen?


Edit: aufm bild rechts unten ist die Pinbelegung

Autor: JojoS (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
NC steht üblicherweise für 'not connected', also nix angeschlossen.

Autor: Benjamin K. (benni222)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hm sind dann 1-6 die VCCs oder 17-20?

Wenn ich des Kabel mach, welche Paare sind dann immer verdrillt? Immer 
die die zusammenpassen? Also Clk- und Clk+ oder D0- und D0+?

Autor: Christian R. (supachris)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Benjamin K. wrote:
> hm sind dann 1-6 die VCCs oder 17-20?
>
> Wenn ich des Kabel mach, welche Paare sind dann immer verdrillt? Immer
> die die zusammenpassen? Also Clk- und Clk+ oder D0- und D0+?

Jeweils gleiche Signale +/- sollten verdrillt werden. Also D0+ mit D0-, 
CLK+ mit CLK- usw.

Autor: Benjamin K. (benni222)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
So, ich habe inzwischen das Kabel so umgeändert wie ich es wollte. Ich 
habe anstatt dem IPex Stecker mein benötigten Hirose Stecker dran 
gemacht.
Jetzt versuche sich die Display Hintergrundbeleuchtung zum Leuchten zu 
bringen. Und zwar gibts da ja die Background VCC und das Background 
Ground(vgl. Link oben) an die hatte ich, als der alte Stecker noch 
funktioniert hatte ca. 3 Volt angelegt und es hat geleuchtet.


Wenn ich das jetzt mit meinem neuen Stecker versuche, geht es nicht. Ich 
hab es immer mal wieder geschafft es kurz zum Leuchten zu bringen, aber 
ich konnte nicht nachvollziehen, was ich anders gemacht habe. Zu Beginn 
dachte ich, ich muss das Background On Off mit dem Ground verbinden. Das 
funktioniert jedoch nicht... Ich habe mal folgendes gemessen:

Die Background VCC ist 3,3 Volt
Dadurch ist auf dem Background On Off Kabel auch 3,3 Volt und auf dem 
Background Adjust auch.

Hat von euch jemand eine Idee was ich mit was verbinden muss, damit das 
Display leuchtet?

Geht das Display auch ohne Beleuchtung? Also dass es was anzeigt nur 
halt sehr dunkel und schwach?

Grüße Benni


Edit: Was auch sehr komisch ist, dass an dem Display Metallrand auch 3,3 
Volt anliegen... Eigentlich sollten dort doch 0 Volt sein, oder?

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.