mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Pegelwandler


Autor: Anfänger (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo ich habe einen MAX 232 Pegelwandler wenn ich -5V auf Pin13 gebe 
bekomme ich 1,6V und wenn ich 5V auf Pin13 geben bekomme ich 3,5V 
eingentlich sollten doch 0V und 5V heraus kommen.
Was kann ich machen denn der mc kann bei solch kleinen Pegeln keine 
Daten einlesen.

Autor: Magnus Müller (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Schaltplan...?

Autor: Anfänger (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
der MAX 232 wurde wie im Datenblatt andeschlossen pc an Pin 13 mc an Pin 
12

Autor: Magnus Müller (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich LIEBE diese Aussagen...!

Hättest du alles richtig angeschlossen, hättest du jetzt kein Problem!

Autor: Anfänger (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
dann sag mir doch mal was ich noch anders machen kann + und - 5V auf Pin 
13 und an Pin 12 messen und den rest so wie im Datenblatt.

Autor: Magnus Müller (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Mach doch mal ein (scharfes) Bild von deinem Aufbau. Bitte Bestückungs- 
und Lötseite.

Gruß,
Magnetus

Autor: Magnus Müller (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Anfänger wrote:
> Hallo ich habe einen MAX 232 Pegelwandler wenn ich -5V auf Pin13 gebe
> bekomme ich 1,6V und wenn ich 5V auf Pin13 geben bekomme ich 3,5V
> eingentlich sollten doch 0V und 5V heraus kommen.

Ausserdem sollte bei einer Eingangsspannung überhalb der Schwellspannung 
0V und bei einer Eingangsspannung unterhalb der Schwellspannung 5V 
herauskommen.

Autor: Anfänger (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe es noch einmal gemessen wenn ich -5V auf pin13 gebe bekomme ich 
2,9V
bei 5V bekomme ich 1V am Ausgang.

Autor: Alexey (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Anfänger,

gibst du eine negative und eine positive spannung auf den max232?
Das brauchst du nicht der macht sich seine negative spannung ja selber 
der will nur GND (also Masse) und 5V positive versorgungsspannung haben.

Hast du alle Kondensatoren dran? Auch den zwischen Masse und 
Versorgungsspannung? Welchen Wert haben die? 100nF, 1uF oder 10uF?

Poste mal mehr infos dann kann man dir besser helfen. :)

Alexey :)

Autor: Magnus Müller (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Magnus Müller wrote:
> Mach doch mal ein (scharfes) Bild von deinem Aufbau. Bitte Bestückungs-
> und Lötseite.
>
> Gruß,
> Magnetus

PUSH

Autor: Anfänger (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Aber an den Pin 13 wird doch der RS232 Schnittstelle angescholssen und 
an der RS232 ist eine "1" -15 bis -3V und eine "0" ist 15V bis 3V. Meine 
4 Kon. haben 1uf und sind auch richtig angeschlossen.

Autor: Magnus Müller (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
BILD (nicht die Zeitung!)

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.