mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik LM358-komisches Verhalten


Autor: Maddin Sche (schrank)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo!


Betreibe einen LM358-OpAmp als Komparator. Der Komparator schaltet eine 
LED ein, wenn seine Differenz am Eingang positiv ist.
Diese Schaltung funktioniert eigentlich recht gut, nur hin und wieder 
verhält sich der Opamp eigenartig:
Manchmal schaltet der Opamp nicht direkt auf Vcc wenn er sollte sondern 
erreicht irgendeinen Zwischenwert (ca. 1/3 Vcc). Berühr ich eines der 
Bauteile (z.B. das Poti mit dem ich die Referenzspannung einstelle) 
klappts wieder.
Meine Frage ist nun, wie ich so einen Opamp am besten beschalte, damit 
er stabil arbeitet. D.h. welchen Kondensator an der Versorgung, vllt. 
Kondensator auch am Eingang des Opamp etc?

Vielen Dank für eire Hilfe!!

Autor: Michael (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Sind es immer ca. 1/3 Vcc oder ist das ein Beispiel und es können auch 
mal 1/5 Vcc sein? Und wie sieht die Schaltung genau aus?
Da es klappt sowie du ein Bauteil berühst könnte ich mir auch 
vorstellen, dass sich da was aufläd und durch die Berührung entladen 
wird => Layout könnte also auch interessant sein.

Autor: Jens G. (jensig)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Vielleicht ein "Wackliger" irgendwo. Also kalte Lötstelle, oder 
Kontaktprobleme innerhalb eines Bauteils?

Autor: Maddin Sche (schrank)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also ich habs noch mal komplett neu aufgebaut, jetzt funktionierts ohne 
Probleme.

Ich tipp jetzt mal auf "Wacklingen" oder sowas.

Vielen Dank für eure Antworten!

Autor: Εrnst B✶ (ernst)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich glaub eher, dein OpAmp hat das Schwingen angefangen, dein Multimeter 
ist nicht mitgekommen und hat halt den Mittelwert der Schwingung 
angezeigt.

Würd auch erklären, warum es durch kleine Änderungen (Finger-Kapazität 
am Poti...) wieder aufhört.

Sauberer Aufbau hilft da, notfalls (wie von dir oben Vorgeschlagen) 
kleine Kapazitäten an den Eingängen (pF … wenige nF sollten reichen)

Autor: Moi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wahrscheinlich hast Du den Komparator ohne Hysterese aufgebaut?!

Autor: Jadeclaw Dinosaur (jadeclaw)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Eventuell einen hochohmigen Widerstand (0.1-2MOhm, je nach 
Quellenimpedanz) vom Ausgang auf den + Eingang legen, damit erzielt man 
eine Hysterese, dadurch wird verhindert, daß der OpAmp um den 
Umschaltpunkt herum pendelt.

Gruß
Jadeclaw.

Autor: Carsten (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
was machst Du mit dem zweiten OPV im Chip?
(evtl offene Pins?)

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.