mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Schmitt-trigger mit PTC


Autor: manfred (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,
habe hier ein selbstbau-Thermostat, welches dazu dient Wasser auf einer 
gewissen Temperatur zu halten. Habe dieses Equipment einmal geschenkt 
bekommen und es funktioniert an sich auch gut. Das einzige, was mich 
stoert ist folgendes: Wenn die Temperatur zum Abschalten erreicht 
ist(ca. 35Grad, ueber Poti einstellbar) klappert das Relais erstmal 
einige Zeit bevor es komplett abschaltet. Nun wollte ich dem Problem mal 
auf den Grund gehen und habe die Schaltung aufgemalt. Es handelt sich 
meiner Meinung nach um einen Schmitt-Trigger, aber kommt mir doch etwas 
kompliziert vor. Habe mir gedacht die Hysterese zu erhoehen um das 
klappern zu vermeiden, mir ist aber nicht ganz klar wie ich das 
anstellen soll. Habe R3 mal verringert und es bessert sich auch. Wenn 
ich allerdings R3 soweit verringer bis das Relais nicht mehr 
klappert(auf 2,2MOhm), ist die Hysterese ewta 5Grad und doch etwas arg.
Vielleicht hat ja jemand eine Idee, wie ich das in den Griff bekommen 
kann?!
Danke fuer Eure Hilfe,
Gruss

Autor: Tmo (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

da scheint die Hysterese (R3) mit 5.6M doch etwas knapp bemessen zu 
sein. Einfach mal mit Verkleinerung von R3 experimentieren, bis Relais 
nicht mehr klappert.

Gruss

Autor: Benedikt K. (benedikt) (Moderator)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Liefert der LM358 überhaupt ausreichend Strom für das Relais?
Hast du schonmal versucht, das Relais über einen Transistor mit dem 
LM358 anzusteuern?

Autor: Stefan (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die Hysterese hängt nicht nur von der externen Widerstandsbeschaltung 
ab, sondern auch von der Ausgangsspannung der OPs, bzw. der 
Spannungsversorgung.
Ich weiß nicht, ob Du's im Schaltplan bloß vergessen hast, aber ich 
würde Vcc einfach mal "großzügig" mit Cs Puffern.
Könnte sein, dass das Abfallen des Relais die Versorgungsspannung soweit 
entlastet, dass sich Vcc deutlich ändert und sich daurch auch die 
Hysteresegrenzen verschieben?!

Autor: manfred (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,
also schalte das ganze jetzt mit einem Transistor. Das verbessert
die Situation schon deutlich, das Relais klappert nur ganz kurz...
Ansonsten habe ich Vcc auch gepuffert mit einem 100 uF Elko, keine 
Aenderung.
Naja, habe den R3 nun noch etwas verringer um die Hysterese zu erhoehen
und damit ists getan.
Danke fuer die Hilfe!
Gruss

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.