mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Probleme mit RS232 zwischen PC und µC


Autor: Arne (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo.

Ich habe mir nach www.mikrocontroller.net-Tutorial ein ATMEGA8-Board mit 
ISP und SUB-D UART-Schnittstelle selber gelayoutet und gefräst. Nun habe 
ich das Problem, dass beim Anschließen der Versorgungsspannung an K1(UB= 
10-15V) bei gleichzeitig angesteckten PC über UART, irgendwo auf der 
Platine eine Leiterbahn weg glüht. Wenn der PC nicht angeschlossen ist, 
geht alles gut.

Habe auch schon alle überflüssigen Kabel aus dem seriellen Kabel 
abgelötet und kurzschlusssicher verschrumpft.

Nachdem ich die durchgeschmorten Leiterbahnen durch eine Litze ersetzt 
habe, passiert das selbe irgendwo anders. Nun bin ich sehr enttäuscht 
und frustiert und frage mich, ob 0,2 mm Leiterbahn zu wenig Querschnitt 
für die Leiterbahnen ist. In meinem aktuellen Layout ersätze ich  einige 
GND-0,2mm-Leoterbahnen durch 1mm Bahnen.

Hoffe, dass mir danach nichts mehr abraucht. Aber normal müsste doch 
alles auch mit 0,2mm laufen, oder?

Habe gelesen, dass der Stromfluß über UART auf 10mA beschrängt ist.

Mein Layout habe ich als Dateianhang angehängt.

Ich möchte doch nur Daten über UART am PC empfangen und senden...

Hat jemand einen guten Rat??

Gruß

Arne

Autor: Lothar Miller (lkmiller) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Mein Layout habe ich als Dateianhang angehängt.
Das ist kein Layout, bestenfalls ein Schaltplan.

Da hätte ich dann noch ein paar Fragen:
Wie sieht das Layout aus?

Welche Leiterbahn schmort durch?

Wozu ist D3 da?

Woraus versorgst du die Schaltung?

Miss doch mal bei eingestecktem Netzteil und ausgesteckter serieller 
Schnittstelle die Spannung zwischen deinem GND (z.B. K3/Pin5) und dem 
passenden Gegenstück am PC. Was ist der Spannungsunterschied?

Autor: Peter Roth (gelb)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das Problem ist deine Stromversorgung. Die Leiterbahnen sind nämlich 
ausreichend (es genügt 1mm Bahnbreite pro Ampere)

Wenn die Leiterbahnen nur dann abrauchen, wenn der PC angsteckt ist, und 
du nicht sonstwo eine Kurzschluss eingebaut hast, hat die 
Stromversorgung auf der Masse eine Spannung gegen Erde. Und wozu ist D3?

Probiers mal mit 'ner Batterie (9 Volt) und dann nimm eine andere 
Stromversorgung.

Grüße, Peter

Autor: Arne (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Danke für die Antworten.

Ich werde die Erdung des PCs und der geregelten Labor-Spannungsquelle 
mal überprüfen. Am Laborgerät ist die Strombegrenzung auf 0,5 A 
eingestellt. Also kann der Strom nur aus dem PC kommen.

D3 ist übrigens überflüssig ... :)

Werde später mal mein neues Layout posten und den aktuellen Schaltplan. 
Habe jetzt 1k-Ohm Widerstände in den Tx und Rx Leitungen der 
RS232-Schnittstelle. Mal sehen, was passiert.

Besten Dank.

Arne

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.