mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik SPS mit ATMEGA644 und 6 Lastrelais


Autor: Gast_12 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Guten Tag,

Schaltung:
- ATMEGA644 Controller
- 6 FINDER Lastrelais an denen 230V Verbraucher hängen (Magnetventile, 
Wärmepumpe,
- Software: Heizungssteuerung
- 5 Analogeingänge
- 4 Digitaleingänge
- 1 PWM
- 1 Platine

Problem:
Die softwware funktioniert einwandfrei...und auch das aschalten der 
Relais je nach Programm.
Sobald aber eine Last auf das relais geschalten wird so "spinnt die 
Analge" und startet den Prozessor nach einem betätigen von neuem.... so 
wie nach einem Stromausfall

Kann mir hier jemand weiterhelfen?
Soll ich den Schaltplan mal reinhängen??
Das layout??

grüsse
andi

Autor: Mike (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Soll ich den Schaltplan mal reinhängen??

Würde uns das polieren der Kristallkugel ersparen...

Autor: Gast (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Die softwware funktioniert einwandfrei...

Der ist gut!

Wahrscheinlich sprühen bei Dir die Funken und bringen den Prozessor zum 
Absturz. Ist der Reset-Eingang niederohmig und mit einem Kondensator 
100nF beschaltet?

Autor: Falk Brunner (falk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das Übliche, siehe Relais mit Logik ansteuern.

Es fehlt ein Snubber.

MFG
Falk

Autor: Gast_12 (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo anbei schaltplan und layout

könnt Ihr da mir sagen was man modifizieren müsste?

Danke!

Autor: Falk Brunner (falk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@ Gast_12 (Gast)

>könnt Ihr da mir sagen was man modifizieren müsste?

Die Bildformate.

Autor: Otto (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Sieht jetzt gar nicht so schlecht aus - am Ausgang vom 7805 könnte ein 
10µF nicht schaden.

Weshalb Du am Brückengleichrichter gespart hast, weiß ich jetzt nicht.

In "unglücklichen Momenten" könnte das Einschalten aller Relais evtl. zu 
einem Spannungseinbruch führen.

Evt. liegt das Problem an der Leiterbahnführung und/oder fehlenden 
Masseflächen. Letztens hat hier z. B. jemand die 230V-Leitungen von den 
Relaiskontakten direkt am Quarz vorbei gelegt.

275V-Varistoren oder R/C-Glieder parallel zu den Relaiskontakten kommen 
auch gut.

Gruss Otto

Autor: Gast (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Letztens hat hier z. B. jemand die 230V-Leitungen von den
>Relaiskontakten direkt am Quarz vorbei gelegt.


Wie? Und nicht angeschlossen?

Autor: Gast_12 (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

also nochmals vielen Dank für Eure Antworten. Ihr habt ja jetzt mehrere 
Möglichkeiten genannt:

- Reset Eingang mit 100nF beschalten und niederohmig
- Der Beitrag "Relais mit Logik ansteuern"
- Snubber
- den 7805 mit 10µF beschalten
- RC Glied parallel

Allerdings kann ich nicht richtig einschätzen was nun das richtige 
ist...

Könnt Ihr mir nicht einen TIPP geben, was das vielversprechendeste ist?

danke und grüsse
andi

anbei nochmal wegen besserer Lesbarkeit

Autor: Gast_12 (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
...und board

Autor: Julian W. (julian-w) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Zum Thema Leslichkeit: Die Schaltpläne sind Spiegelverkehrt.

Autor: Magnus Müller (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Julian W. wrote:
> Zum Thema Leslichkeit: Die Schaltpläne sind Spiegelverkehrt.

Nö... nur um 180,000 Grad gedreht ;)

Autor: Otto (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die Nähe der rechten 230V führenden Leiterbahnen zur Einspeisung der 
Versorgungsspannung ist ein wenig gewagt.

Klemme mal den Verbraucher vom rechten Relais ab und prüfe dann.....

Otto

Autor: Otto (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Pin 16 (INT0) ist unbeschaltet - evtl. prüfen, ob er als Eingang 
konfiguriert ist und dann auf GND legen....

Natürlich sollte dieser Interrupt auch nicht freigegeben sein.

Otto

Autor: Falk Brunner (falk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@ Gast_12 (Gast)

>Dateianhang: schaltplan.pdf (111,5 KB, 15 Downloads)

Besser.

>- Reset Eingang mit 100nF beschalten und niederohmig

hast du schon, abgehakt.

>- Der Beitrag "Relais mit Logik ansteuern"
>- Snubber

Fehlt und ist der aussichtsreichste Problemlöser.

>- den 7805 mit 10µF beschalten

Bringt wenig.

>- RC Glied parallel

Ist der Snubber ;-)

MfG
Falk

P.S. AREF gehört NICHT an VCC, sondern dort nur 100nF gegen Masse dran!

Autor: Gast_12 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo die Herren,

also ich werde es jetzt mal mit einem RC Glied probieren. Mein Problem 
hierbei ist: Einmal hängt ein Schütz dran einmal hängt ein Magnetventil 
dran etc.
Alles Verbruacher mit unterschiedlichen Stromstärken und damit auch 
unterschiedlichen Werten für den Kondensator (im Fall der Faustregel: 1 
Ohm/V und 100nF/A  ...

Gut. Einen Range der Verbraucher gibt es schon: 100mA - 2A


Gibt es da ne Möglichkeit einen Mittelwert für die Kondensatorauslegung 
heranzuziehen?

Vielen Dank im Vorraus
grüsse
andi

Autor: Gast (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Gibt es da ne Möglichkeit einen Mittelwert für die Kondensatorauslegung
>heranzuziehen?

Habe ich mal eben berechnet: 43,89nF.

Autor: Falk Brunner (falk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@ Gast (Gast)

>Habe ich mal eben berechnet: 43,89nF.

WOW, mit zwei Nachkommastellen!

Nimm den Maiximalwert an, macht 200nF, 220nF ist ein Standardwert. Nimm 
den und sei glücklich.

MFG
Falk

Autor: Gast_12 (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

also bin jetzt Eurem Rat mal befolgtund alles ausprobiert. Bringt nur 
bedingt was mit dem RC glied. Eher Kondensator direkt dran!

Aber was ich gefunden habe: An der Grundplatine (schaltplan siehe 
Beitrag weiter oben) hängt mit einem 15cm langen Flachbandkabel eine LCD 
Display mit Tasten (siehe Anhang).

Dies ist die Quelle der Störung!!! Sobald die Last (schütz) schaltet 
werden über diese Leitungen der Impuls eingekoppelt und gehen direkt an 
den Prozessor, der dann hierauf zum spinnen anfängt. Selbst wenn das 
Display mit Tasten gar nicht dran hängt sondern nur das 15cm lange 
Flachbandkabel wird der Prozesor immens gestört und resetet sogar!.

Kann man diese Leitung nicht störunempfindlicher machen??
(habs auch schon abgeschirmt...aber ohne Erfolg!)

Vielen Dank im Vorraus
grüsse
andi

Autor: Matthias Lipinsky (lippy)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
>Kann man diese Leitung nicht störunempfindlicher machen??

gewöhnlich macht man bei solchen abgesetzten Teilen das so, dass bei dem 
Flachbandkabel jedes zweite Masse/Ub ist. Also eine Seite ist komplett 
mit Ub/Masse verbunden.

Etwa so wie im Anhang.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.