mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Mega2560 UART0 Problem


Autor: Fred L. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

also irgendwas stimmt nicht mit den Daten, die mein Mega2560 auf seinem 
UART(0) rausspuckt. Die Initialisierung und Beschickung des Transmitters 
ist OK- jedenfalls zeigt ein Max232-angeschlossener PC die gesendete 
Bytefolge korrekt. Nur mein Aurel Rs232 Funkmodul will einfach damit 
nichts anfangen- wird dieses aus anderer Quelle gespeist (Mega168 mit 
identischer Initialisierung /Baudrate wie obiger) gelingt die 
Übertragung jedoch... Leider hab ich kein Oszi um der Sache auf den 
Grund zu gehen- aber vielleicht hat jemand eine andere Idee ?

Gruß Fred

Autor: Fred L. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hab die Lösung jetzt gefunden- vielleicht interessiert sie den, der auch 
so ein Aurel Typ WIZ-SML-IA für serielle Übertragungen einsetzt! Bei 
unsauberer Spannungsversorgung neigt es offensichtlich dazu, 
eingespeiste Daten irgendwie gestört zu übertragen und beim 
Empfängermodul kommt nur undekodierbarer Mist an. Der Empfang klappt 
hingegen. Echt heimtückisch! Eine kleine Drossel+Elko- das wars.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.