mikrocontroller.net

Forum: Markt [suche] L4938 Spannungsregulator Automotive


Autor: Wegstaben Verbuchsler (wegstabenverbuchsler)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe hier eine defekte Wegfahrsperre aus einem alten Ford Probe 
Fahrzeug. Dort ist irgendwie der Blitz reingefahren.

Zur Stabilisierung / Glättung der Bordspannung (zwecks Versorgung der 
Chips der Wegfahrsperre) wird ein L4938 benutzt.

http://www.alldatasheet.com/view.jsp?Searchword=L4...

Der Leistungs-Ausgang OUT2 vom L4938 ist tot (da kommen nur 0 Volt 
raus).

HAt jemand so ein Teil oder kann mir jemand eine Bezugsquelle nennen?


Ergänzung: eine Quelle habe ich bereits gefunden:
http://www.sh-halbleiter.de/

vielleicht gibts ja noch andere Anbieter oder jemand hat sowas in der 
Schublade liegen ...

Autor: Jurij G. (jtr)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Falls es das Teil von Bosch ist was in Probes um 94-95 verbaut war, ein 
Tip: guck dir die Lötstellen genau an. Die sind bekannt dafür wegen 
kalter Lötstellen den Wagen plötzlich lahmzulegen, auch während der 
Fahrt.

Den Spannungsregler gibts bei Digikey.

Autor: Wegstaben Verbuchsler (wegstabenverbuchsler)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Jurij

du scheints dich auszukennen, vielleicht hast du ja ein paar Tips für 
mich?

> Falls es das Teil von Bosch ist was in Probes um 94-95 verbaut war

leider nein. Es ist ein 1997 er Modell, und dort sind die Temic WFS 
installiert.

schaltungstechnisch siehts es da drin wohl so aus, daß die erzeugten 5V 
des OUT2
- zum einen nach "draußen" geführt werden
- zum anderen über Widerstände und Transen irgendwo auf der Platine 
weiter geführt werden.

Ich hab da keine Pinbelegung, Schaltpläne oder sonstewas von der Temic 
WFS, "orakle" aber mal folgende mögliche Verschaltung:

Die auswärts gehenden +5V dienen der Versorgung des Transponder-Senders 
und Empfängers (wird irgendwo in der Nähe Zündschloß verbaut sein)

Die innen liegenden +5V dienen der Versorgung von 
Daten-Leitungs-Treibern (für den Transponder-Empfänger und für die 
Datenleitungen zwischen WFS und Motor-Steuergerät)


Was mir noch nicht ganz klar ist:
:: Wird über die Temic-WFS auch z.B. Benzinpumpe etc. gesteuert 
(Treiber)? Anscheinend wohl nicht, denn da ist nur Hühnerfutter auf der 
Platine, nix leistungstreibendes. [Die Bosch WFS hat wohl auch 
getrieben, es existieren im Netz diverse HAck-Mods, wie man die Bosch 
WFS entsprechend modifizeren kann]


Ich habe mal den Fehlercode gemäß der Anleitung auf probewiki.de 
ausgelesen. Laut Fehlercode-Tabelle ( 
http://www.probewiki.de/Fehlercodes )
bekomme ich einen Fehler
"P1602 PATS Communicationserror PATS und PCM kein Datentransfer"


> Den Spannungsregler gibts bei Digikey.

Danke für den Tip. Hm, wer bestellt denn demächst mal was dort?

Autor: Jurij G. (jtr)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wegstaben Verbuchsler wrote:
> leider nein. Es ist ein 1997 er Modell, und dort sind die Temic WFS
> installiert.

Mit der kenne ich mich leider nicht aus, hatte nur die alte.

>> Den Spannungsregler gibts bei Digikey.
>
> Danke für den Tip. Hm, wer bestellt denn demächst mal was dort?

Kannst bei der nächsten Sammelbestellung im Markt mitmachen. Wobei 
natürlich die Frage ist ob es nur den Spannungsregler zerlegt hat oder 
auch was dahinter. Schaltpläne für neuere WFS sind ja schwierig 
aufzutreiben.

Autor: Dieter Zobel (strupi52)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,ich brauche von Fachleuten Hilfe,unsere Familie ist total 
verzweifelt.Unser Problem:wir wohnen auf isla margarita(venezuela)keinen 
VW-haendler geschweige experte fuer wegfahrsperre,Das Auto leuft nur 1 
sekunde im tablo brennt die gelbe lampe (auto mit schluessel)Am 
Zuendschloss ist ein schwarzer Ring der mit einem kabel zur WFS geht,im 
schluessel befindet sich ein chip sieht aus wie ein Reiskorn,das zur 
WFS,ich habe den Commutators am Zuendschloss ausgewechelt und seitdem 
geht gar nichtsmehr.Ich moechte die WFP ganz ausbauen,denn ansonsten 
mueste ich das Auto nach Caracas abschleppen lassen,was sehr sehr teuer 
ist.Einen Monat suche ich hier Mechaniker,habe nur bezahlt und die kiste 
leuft immer noch nicht. Bitte wer kann mir helfen,und einen Tip geben 
wie ich das Auto zum laufen bringe?????Es muss doch eine Moeglichkeit 
geben??????Der mir hilft kann bei mir 3 Wochen umsonst wohnen,Flug ist 
bei Condor guenstig,Frankfurt-Polamar,in wartender Hoffnung gruss Dieter

Autor: eProfi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Dieter,
hast Du einen zweiten Schlüssel? Evtl. ist der Transponder im Schlüssel 
defekt.

Vielleicht hat das Steuergerät die Schlüsselkennung vergessen.
Dann muss man den Schlüssel neu "anlernen".

Da kenne ich mich nur wenig aus.

Versuche mal ein VW / Golf-Forum.

Ist es wirklich die WFS?
Bei einem Punto hatte ich ähliches Problem, Punto springt nicht an, trat 
nur etwa 1x im Monat auf. Es war der Induktionsgeber (Spule) für die 
Zündanlage.

Hast Du die Möglichkeit, einen passenden OBD-Adapter zu beschaffen / zu 
bauen. Dann kannst Du mal ins Steuergerät schauen und die Fehlercodes 
auslesen.

Würde gerne kommen, doch die Arbeitsstelle ruft...

Autor: hans (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert

Autor: Wegstabenverbuchsler (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Rueckmeldung:

Mittlerweile habe ich den BAustein beschaffen koennen, er war wirklich 
der "Uebeltaeter". (Bin grad in Urlaub, falls jemanden die Bezugsquelle 
interessiert schau ich noch mal nach)

Danke noch mal fuer takkraeftige Unterstuetzung.

Autor: Kevin F. (kef)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>isla margarita(venezuela)

>Der mir hilft kann bei mir 3 Wochen umsonst wohnen,Flug ist
>bei Condor guenstig,Frankfurt-Polamar,in wartender Hoffnung

also außerhalb eines 4* ALL-IN-Hotels würde ich dort auf keinen Fall 
wohnen wollen ---> viel zu gefährlich auf dieser Insel

Autor: Wegstaben Verbuchsler (wegstabenverbuchsler)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Dieter

Ich weiß nicht ob die speziellen Details vom Ford Probe und den VW 
identisch sind, aber vielleicht findest du einige der Dinge auch im VW 
wieder. Hier mein "Bericht" zum Thema WFS beim Probe:

Die Technologie der Wegfahrsperren scheint immer ziemlich ähnlich zu 
sein. Sie besteht aus folgenden Komponenten:

a) passive (=ohne Spannung betriebene) Transponder-"Kapsel" (Chip) im 
Zündschlüssel
--> Die Kennung die in dieser Komponente hinterlegt ist ist einmalig und 
eindeutig

b) Transponder-Spule in der Nähe des Zündschlüssels (keine individuelle 
Kennung)

c) das "Wegfahrsperre-Modul" ist eine zigarettenschachtel-große Kiste, 
welche die Transponderspule versorgt und den Transponder im 
Zündschlüssel ausliest.

d) Motorsteuergerät (Computer), welches grundsätzliche 
Betriebseigenschaften des Motors steuert und kontrolliert


zu C und D gilt folgendes:

--


Bei "alten" Ford Probe Modellen war die Wegfahrsperre (das unter C 
benannte) eine nachträglich eingebaute Komponente) Nachträglich 
deswegen, weil die ursprungliche Konstruktion von Ford keine WFS vorsah, 
und erst nach Seriensrtart irgendwann einmal die WFS hinzu kam. Der 
Transpondercode war in der WFS gespeichert, und die WFS hatte 
Steuerausgänge, um Benzinpumpe etc. per Relais abzuschalten. Man konnte 
sogar die WFS komplett "rauswerfen" (nach Überbrückung der durch die 
Relais sonst deaktivierten Leitungen), da die WFS nicht mit dem 
Motorsteuergerät "gesporchen" hat.

"neuere" Probe Modelle hatten eine WFS, welche mit dem Motorsteuergerät 
(MSG) gekoppelt ware. Die WFS selbst hat keine Komponenten mehr 
deaktiviert, und der TRanspondercode wurde in das Motorsteuergerät 
geschrieben. Das Motorsteuergerät selbst war dann für die Deaktivierung 
relevanter Komponenten (Zündspule, Benzinpumpe etc) zuständig.


00000000000000000

--> Dein"Schaden" hört sich so an, als ob die WFS "zu macht". Bei Probe 
hatte ich folgende Diagnostik:

1. Transponderchip im Schlüssel rausnehmen --> WFS signalisierte mittels 
der im Armaturenbrett eingenauten "Schlüssel-Lampe" einen "Morsecode" 
mit der Bedeutung "ich kann mit keinem Schlüssel=Transponderchip) 
"sprechen"

==> Vielleicht ist das bei VW auch so, du solltest daher zur Eingrenzung 
mal folgendes versuchen: TRansponderchip vorsichtig aus Schlüssel 
rausnehmen und in passender Entfernung (vielleicht 1 Meter) sicher 
verwahren. Schau nach, ob es ein geändertes Verhalten der "Signal" Lampe 
gibt.

2. Wenn WFS mit Chip sprechen kann, mußte sie noch mit dem MSG sprechen, 
um den Code abzugleichen. Der Probe ließ es zwar zu, daß die Zündung 
ansprang, aber sobald die Drehzahl über (800 rpm?) kam, wurde 
Benzinpumpe und Zündung dicht gemacht.

==> vielleicht ist es beim VW auch so. Motor versuchen zu starten, ohne 
viel GAs zu geben. Wenn dann der Motor tuckert, ist zumindestens das 
schon mal klar daß es kein Motorproblem ist.


3. Anschließend griff noch ein Sicherheits-Feature: Im Probe gab es 
Aufprallschutz-Sensoren und Airbag-Sensoren. Wenn da was nicht stimmte 
machte die WFS auch zu, Symptome ähnlich zum fehlenden Transponder


---

Wg. OBDII Diagnose:

Im Probe war ein Diagnose-Stecker verbaut welcher noch Ausgänge für eine 
Signallampe hatte. MAn konnte eine LED (zur Not ein einfahces 
Vielfachmeßgerät, (sehr) kleine 12V-Birne etc) anschließen und den 
"Blinkcode" auslesen. Entsprechende Stechkerbelegungen und Codtabellen 
gab es in geeigneten Foren (bei mir wars www.probewiki.de)

Autor: rainer (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ich habe auch eine temic in meinem probe24v bj.97 kann man die nicht in 
einer werkstatt brücken lassen wer mir helfen kann ich bezahl den 
aufwand gruss rainer tel. 01729995843

Autor: Wegstaben Verbuchsler (wegstabenverbuchsler)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
nein, bei der 97er temic kann man nix brücken. Entweder holst du dir vom 
Schrott eine neue, oder du reparierst sie oder lässt sie reparieren.

Melde dich im Forum an, dann können wir per mail miteinander in Kontakt 
kommen. evtl. hat deine WFS den gleichen Schaden wie "meine", dann 
könnte man das ggf. reparieren.

Bitte melde dich an um einen Beitrag zu schreiben. Anmeldung ist kostenlos und dauert nur eine Minute.
Bestehender Account
Schon ein Account bei Google/GoogleMail, Yahoo oder Facebook? Keine Anmeldung erforderlich!
Mit Google-Account einloggen | Mit Yahoo-Account einloggen | Mit Facebook-Account einloggen
Noch kein Account? Hier anmelden.