mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik Schaltverluste MOSFET


Autor: Philipp H. (swissrookie)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo allerseits

Ich bin gerade damit beschäftigt, eine Schaltung für eine schnelle 
Stromregelung zu entwerfen. Als ine einem ersten Schritt möchte ich 
einen einfachen 2-Punkt-Regler aufbauen.

Ein mit 3.3V Logikpegel gesteuerter MOSFET soll die Leistung schalten.

Eckdaten Last (induktiv)
========================
Strombereich: 100mA - 4A
Spannung: 12V - 36V


Nach einigem Suchen bin ich auf den IRF7470 gestossen.
http://www.irf.com/product-info/datasheets/data/irf7470.pdf
Jetzt hab ich Bedenken bezüglich Verlustleistung und dem SO-8 Gehäuse, 
denn die Schaltfrequenz wird im schlimmsten fall 1MHz betragen.

Was meinen die Experten? Brennt mir das Ding runter?

Grüsse Philipp

Autor: Gast (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
1MHz sind stolz und 3.3V mutig

Autor: Matthias Lipinsky (lippy)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
bzgl. der Berechnung der Verlustleistung:

Beitrag "Logic-Level Mos-Fet Ansteuerung"

Autor: Philipp H. (swissrookie)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@ lippy: Vielen Dank für den Link, ist das was ich gesucht hatte. Warum 
ich das vorher nicht gefunden habe...?!?

In einem ersten Schaltungsaufbau (mit grösseren FET's) hat sich jetzt 
gegzeigt, dass sich die Schaltfrequenz bei einer sinnvollen Hysterese 
sich zwischen 100 und 200 kHz bewegt. Also für den schnellen FET kein 
Problem.

Autor: Michael Lenz (hochbett)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Philipp,

müssen es unbedingt 3,3V sein? Ich würde in Deinem Fall nach einem 
MOSFET-Treiber suchen, der einen 3,3V-Eingang hat und eine integrierte 
Ladungspumpe.

Suchen würde ich zunächst bei Maxim und IRF, evtl. auch bei Analog 
Devices, Intersil u. a.


Gruß,
  Michael

Autor: Philipp H. (swissrookie)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Michael, danke für den Hinweis.

Ich habe in der Zwischenzeit eine Schaltung mit einem FET 
Treiber(TC4469) aufgebaut. Funktioniiert eigentlich gut soweit.
Schade ist halt, dass ich jetzt noch 10V für die Ansteuerung 
bereitstellen muss.

Grüsse Philipp

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.