mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Problem mit INA138.


Autor: Damian (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Verwende einen INA138.
Hat zufällig jemand erfahrung mit diesem Baustein????

Messe über einem Widerstand von 50mOhm (Rs), Verstärkungsfaktor 4 (RL = 
22kOhm).
Signal das gemessen liegt bei 24V. V+ = 5V. Am ausgang Messe ich 
dauerhaft 5V (mit einem KO kontrolliert), unabhängig wie hoch der Strom 
ist, welcher fliesst.
Der Spannungswert wird danach über einen AD-Wandler in einen ATMega 
eingelesen.

Beschaltung habe ich 3x Kontrolliert, die passt (Naja sehe auch keie 
möglichkeit etwas falsch zu machen...)!
Kann mir das nicht erklären, hat jemand eine Idee?

Autor: Matthias Lipinsky (lippy)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich hab den schon öfters verbaut.

Male mal bitte einen Schaltplan mit Angaben, was davor und dahinter ist.

Autor: Damian (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hier eine Skizze meiner Schaltung...

Autor: Matthias Lipinsky (lippy)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die Beschaltung selbst sieht richtig aus. Wird der Motor dahinter 
irgendwie geschaltet? Wie werden die 24V erzeugt?

Zeichne mal bitte das dazu..

Autor: Damian (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe leider kein vernünftiges Tool um Schlatpläne zu zeichnen. Die 
Skizze wird da wohl etwas zu gross, um dass Ganze noch vernünftig zu 
erkennen.

Aber davor ist die die Anachlussklemme, welche direkt auf mein Netzteil 
geht.
Danach eine mit MosFets aufgebaute H-Brücke, welche einwandfrei 
funktioniert.

Naja ich werde wohl nochmal einen INA138 bestellen müssen, tönt als wäre 
dieser defekt, da du mir ja bestätigt hast, dass die obere Beschaltung 
korrekt ist.

Autor: Olli R. (xenusion)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Damian wrote:
> Ich habe leider kein vernünftiges Tool um Schlatpläne zu zeichnen. Die
> Skizze wird da wohl etwas zu gross, um dass Ganze noch vernünftig zu
> erkennen.

www.cadsoft.de, Freeware-Version fuer Windows, Linux und Mac.

Olli

Autor: Matthias Lipinsky (lippy)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Danach eine mit MosFets aufgebaute H-Brücke, welche einwandfrei
>funktioniert.

Skizzier das mal bitte auf. Komplett mit allen Bauteilen.

(Ich hab ne Vermutung, warum deine Vermutung richtig sein könnte)

http://www.cadsoft.de/freeware.htm

Autor: Daniel P. (dpointeck)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Leute,

ich hab ebenfalls ein Problem mit dem INA138 und zwar kann ich am 
Ausgang nichts messen.
So ich wollte die Schaltung so aufbauen das ich am Ausgang bei 10A 5V 
abgreifen kann der shunt hat einen Widerstand von 0R051. Die Schaltung 
hab ich als jpg angehängt.

Autor: Matthias Lipinsky (lippy)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Und wie ist SPannungsquelle und Last verschaltet?
Und was für eine Last ist es?

Autor: Alexander D. (alexander_d)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Daniel P. wrote:
> Hallo Leute,
>
> ich hab ebenfalls ein Problem mit dem INA138 und zwar kann ich am
> Ausgang nichts messen.
> So ich wollte die Schaltung so aufbauen das ich am Ausgang bei 10A 5V
> abgreifen kann der shunt hat einen Widerstand von 0R051. Die Schaltung
> hab ich als jpg angehängt.

wenn du den INA138 mit +5V versorgst, kannst du nur max. 4V am Ausgang 
erhalten. Beachte auch, dass dein Messwiderstand auf mindestens 2.7V 
liegen muss, ansonsten wird der INA138 stark nichtlinear.
10A an 0R051 ergibt einen Spannungsabfall von 510mV. Im Datenblatt wird 
ein Wert von 50...100mV empfohlen.

Gruß,
Alexander

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.