mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Motorumpolungsrelais entstören Snubber


Autor: krabbe73 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo!
Ich habe ein 2x-Wechslerrelais mit dem ich die Versorgungspannung von 
einem Motor (DC) umpolen kann. Leider stürzt der Controler ab, wenn ich 
den Motor anschalte (hängt an dem gleichen Netzteil). Habe nun gelesen, 
daß man einen Snubber braucht. Nur wo schließ ich den sinnvoll an???? An 
den geschalteten Ausgängen vom Relais wechselt ja die polarität und gibt 
das dann nicht noch mehr Störung wenn der geladene Kondensator plötzlich 
umgekehrt zu seiner Ladung angeschlossen ist?! Brauch ich da vielleicht 
2 snubber, die durch eine Diode jeweils nur für eine Stromrichtung 
zuständig sind? Ich meine der der Strom geht durch den Relaiskontakt 
nicht nur an und aus sondern wechslet auch seine Polarität! Wie entstört 
man das?
Großes Danke an alle Experten! Krabbe

Autor: Lothar Miller (lkmiller) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Leider stürzt der Controler ab, wenn ich
> den Motor anschalte (hängt an dem gleichen Netzteil).
Willst du nicht erst in der Nähe suchen?
Welche Leistung hat der Motor?
Was macht deine Versorgungsspannung, wenn der Motor eingeschaltet wird?
Welche Kondensatoren hast du im Netzteil verbaut?

> Habe nun gelesen, daß man einen Snubber braucht.
Was dein Motor brauchen könnte ist evtl. ein Entstörglied. Aber vorher 
würde ich mir die Verdrahtung (Masse und GNE) nochmal genauer ansehen. 
Fließt der Motorstrom evtl. über die Controllermasse zurück zum 
Netzteil? Das wäre ein Grund für zwielichtiges Verhalten.

> Brauch ich da vielleicht 2 snubber, die durch eine Diode jeweils
> nur für eine Stromrichtung zuständig sind?
Oder einen Brückengleichrichter vor dem Snubber?
Halb- oder gar Viertelswissen kann dich schön in die Irre führen.

Autor: krabbe73 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Willst du nicht erst in der Nähe suchen?
Gerne! Ich bin nur leider Amateur und habe die Informationen alle immer 
nur zusammengesucht. Deshalb suche ich hier um Rat! Danke auf jeden Fall 
schon für die Hinweise!

> Welche Leistung hat der Motor?
Das ist ein 12V Getriebemotor, im Leerlauf ca 100mA Stromaufnahme, 
müssten also 1,2W sein.

> Was macht deine Versorgungsspannung, wenn der Motor eingeschaltet wird?
Das kann ich leider nicht genau sagen, weil ich keine empfindlichen 
Meßgeräte wie ein Oscilloskop habe.
Was ich probiert habe: Wenn ich als Spannungsversorgung für den Motor 
ein anderes Netzteil als das, woran der Controller angeschlossen ist, 
nehme, funktioniert die Schaltung ohne Wenn und Aber. Durch das Relais 
sind die Schaltkreise ja galvanisch getrennt. Nur wenn ich den 
Sekundärkreis mit dem Motor, also das, was vom Relais geschaltet wird, 
an das gleiche 12V Netzteil anschließe, stürzt der Controller ab.Das 
sehe ich an angeschloßenen LEDs.
Ich hab am Relais zur Entstörung bisher nur eine Freilaufdiode. Das 
Schalten des Relais allein ohne angeschloßene Last verursacht auch keine 
Probleme.

> Welche Kondensatoren hast du im Netzteil verbaut?
Das ist ein fertiges Netzgerät (12V 25W). das ist gar nicht selbst 
gebaut. Wenn das wichtig ist würd ich mal einen vorsichtigen Blick rein 
werfen.

> Oder einen Brückengleichrichter vor dem Snubber?
> Halb- oder gar Viertelswissen kann dich schön in die Irre führen.
Oh ja. Gerade weil ich so ratlos bin, frage ich ja hier, weil sich hier 
Leute tummeln, die wirklich was von der Sache verstehen. Ich mache diese 
Basteleien nur privat für mich zum Spaß.

Autor: krabbe73 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Habe einen Schaltplan gefunden:
www.roboternetz.de/wissen/index.php/Bild:Hbrueckerelais.gif
So ähnlich habe ich das auch! Andere Entstörungen wie auf dem Bild habe 
ich auch nicht.
Ist die Betriebsspannung oben rechts die gleiche wie die vom Controller 
und der Relaisspule, gibt es den Fehler. Wenn die Betriebsspannung oben 
rechts extern ist und mit dem ganzen Rest der Schaltung (Controler und 
Relaispule) nicht in Berührung kommt, funktioniert alles gut.
Ich möchte aber nur ungern 2 Netzteile nehmen müssen.
Wo kann ich in dieser Schaltung den Snubber reinbauen?

Autor: Lothar Miller (lkmiller) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Wo kann ich in dieser Schaltung den Snubber reinbauen?
Vergiss den Snubber!
So ein Motörchen darf deinen uC nicht zum absemmeln bringen.
Häng lieber mal einen dicken Elko (so um 4700uF) mit auf die 
Versorgungsschiene deiner (Logik-)Schaltung.

Evtl. solltest du die Lastversorgung (Motor) von der Logikversorgung mit 
einem RC-Glied entkoppeln.
                               ___          .-----.
     +12V  o-----o---------o--|___|---o-----|7805 '---.
                 |         |   10R    |     '-----'   |
                 |         |          |+       |      |
                 |         |         ---       |      |
               Motor     Relais      ---       |      uC
                 |         |          |4700uF  |      |
                 |         |          |        |      |
                 |         |          |        |      |
      GND  o-----o---------o----------o--------o------'

Autor: Lothar Miller (lkmiller) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
krabbe73 wrote:
> Habe einen Schaltplan gefunden:
> http://www.roboternetz.de/wissen/index.php/Bild:Hb...
> So ähnlich habe ich das auch!
Wenn du so eine Schaltung hast, dann kann beim Umschalten der 
Drehrichtung schon mal ein markanter Strom fließen, das ist immerhin von 
Vollgas vorwärts auf Vollgas rückwärts.

> Das ist ein fertiges Netzgerät (12V 25W)
Wie erzeugst du daraus die Spannung für den uC?
Ist das ein Lochraster-, Steckbrett- oder Platinenaufbau?
Wie ist die Masse geführt? (Nur zur Wiederholung ;-)

> Andere Entstörungen wie auf dem Bild habe ich auch nicht.
In dem Bild sind keine Entstörungen zu sehen. Nur eine Freilaufdiode, 
die hat aber mit Entstörung nichts zu tun (bestenfalls, falls sie fehlt, 
mit Zerstörung).

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.