mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik Linear-Stromversorgung mit FET zickt


Autor: ws (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Experten!

Ich bin nun langsam am Verzweifeln mit meiner linear geregelten 
Stromversorgung. Das Projekt besteht aus Analogteil und einem 
Digitalteil mit PIC welcher über AD7705 Strom und Spannung einliest und 
über DA's die Sollspannungen für den Analogteil bereitstellt. Ausserdem 
macht er eine Lüftersteuerung über PWM und eine RS-232 für 
Remote-Steuerung.

Der Digitalteil passt eigentlich (der PIC steuert nur, er regelt 
nicht!), was man vom Analogteil nicht sagen kann. Dieser ist nämlich von 
einer alten Eletkorschaltung für meine Zwecke etwas modifiziert, schaut 
aber immer noch recht einfach aus. Das genaue Problem möchte ich aber im 
Moment nicht verraten um niemanden zu beeinflussen und somit freie 
unbefangene Meinungen ermöglichen. So erhoffe ich mir ein neutrales 
Feedback von der Schaltung ohne fest eingefahrene Gedankengänge. In 
einem zweiten Moment erkläre ich Euch dann das Problem, das mir den 
Schlaf raubt. Jetzt jedoch wäre es nett, wenn der eine oder andere meine 
Schalutng kommentiert.

Dankeschön...

ws

Autor: Lothar Miller (lkmiller) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ja, wo isser denn, der FET?

Interessant wäre auch, was du geändert hast.
Oder sollen wir das auch raten :-/

Autor: Andrew Taylor (marsufant)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ein vollständiger Schaltplan Deines Gerätes MIT dem Leistungsteil wäre 
ggfs. hilfreich sagt mir meine Kristallkugel.


> Das genaue Problem möchte ich aber im
> Moment nicht verraten um niemanden zu beeinflussen und somit freie
> unbefangene Meinungen ermöglichen. So erhoffe ich mir ein neutrales
> Feedback von der Schaltung ohne fest eingefahrene Gedankengänge. In
> einem zweiten Moment erkläre ich Euch dann das Problem, das mir den
> Schlaf raubt. Jetzt jedoch wäre es nett, wenn der eine oder andere meine
> Schalutng kommentiert.


Und Du meinst das verschafft Dir hier irgendwie gesteigertes Interesse 
oder Pluspunkte, sodaß Dir hier mehr Leute helfen?

Autor: Benedikt K. (benedikt) (Moderator)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ws wrote:
> Jetzt jedoch wäre es nett, wenn der eine oder andere meine
> Schalutng kommentiert.

- Du hast die Schaltzeichen von Schottky und Zenerdiode verwechselt.
- Es wäre schön die Ein/Ausgänge zu beschriften, damit man deren Zweck 
besser erkennen kann. So fehlt z.B. der FET und die Angabe der Spannung 
des Trafos.
- D8 könnte Probleme machen: Bei 4A fallen am Stromshunt 2V ab. Bleiben 
noch 3,6V für das Gate übrig. Das wird vermutlich etwas wenig sein.

Autor: Lothar Miller (lkmiller) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> ... dieser ist nämlich von einer alten Eletkorschaltung für meine Zwecke
> etwas modifiziert ...
Weil du den FET so ausdrücklich erwähnst:
war da früher bei Elektor noch ein bipolarer Transistor drin?

Autor: ws (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Entschudigt bitte vielmals. Ich musste bei Lothar Millers Beitrag über 
den FET so lachen...nochmals entschuldigung. Also Folgendes:

1)Betrieben wird die ganze Sache über einen Ringkerntrafo 2x18V, 
2x4,44A, 160W, im Moment natürlich nur eine Sekundärwicklung, falls die 
Schaltung funktioniert, dann kommt an die zweite auch eine Analogplatine 
hin.

2)Der FET ist ein IRFP3710, im T0-247 Gehäuse, damit er mehr aushält.

3)Geändert wurde an der Original-Schaltung der 2xTLC271 in LT1632 und 
der 2xBUK455 in IRFP3710. Interessanterweise war in der 
Originalschaltung an beiden OPVs absolut keine Gegenkopplung vorhanden. 
Ausserdem wurden einige Widerstände neu dimensioniert, z.B. die 
Shuntwiderstände, die Led-Vorwiderstände, der "Grund-Last-Widerstand" 
von 330 Ohm, der Gatewiderstand auf von 220 auf 150 Ohm. In der 
Originalschaltung fehlen die SChutzdioden für die Spannungsmessung, die 
OPV-Rückkoppelung, die Widerstände R17 und R13, da die Sollspannung 
mittels einfacher Potis generiert wurde.

4)An AIN- und AIN+Eingängen hängt der AD-Wandler, genauergesagt der 
MX1416. DA_OUT_I_BUFF und DA_OUT_U_BUFF sind über Impedanzwandler 
(OPA2350) "gebufferte" DA-Wandler-Ausgänge. Spannungsreferenz, bzw. 
Maximal-Spannung: 4096mV. Der 7805er generiert die 5V fürs gesamte 
Digitalteil.

5)Ich erhoffe mir damit lediglich Kommentare die nicht nur das 
eigentliche Problem behandeln sondern auch "weiter" denken, wie z.B. 
Benedikts Post. Seine Vermutung nämlich könnte zu einer Symptomatik 
passen, die auftrat wenn das Ganze in Strombegrenzung ging. Das muss ich 
noch genauer untersuchen. Aber das eigentliche Problem ist im Moment die 
Spannungsregelung: die Strombegrenzung greift nicht, der IC5B regelt 
auch schön von etwa 0V-22V, aber am Ausgang habe ich Spannnungsbuckel 
von der gleichgerichteten Sägezahnspannung, etwa 5mV, 100Hz. Sie werden 
mit der Last etwas größer bis etwa 20mV. Ich dachte zuerst an ein 
Layoutproblem aber ich denke eher, dass hier ein Regelproblem vorliegt 
und zwar müsste das mit C13 zu tun haben.

Autor: Lothar Miller (lkmiller) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Dem R8 könnte ein kurzes Leben beschieden sein, wenn du den in die 
falsche Richtung drehst. Wolltest du da die Strommessung evtl. am 
Schleifer abgreifen?

Ich würde die Sense-Klemmen mit den Ausgangsklemmen wenigstens über 
einen 100 Ohm Widerstand im Netzteil verbinden (X2/1-2 und X2/3-4). Was 
wird passieren, wenn du die Sense-Leitung zum Verbraucher unterbrichst?

Mach doch statt der D5 und D4 die LEDs rein, dann sparst du dir die 
zusätzlichen Widerstände (mit roten LEDs kommst du sicher unter Ugsth).

Autor: Andrew Taylor (marsufant)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Led 1 und Led 3 mal probeweise entfernen (offen lassen) und C11 am 
Ausgang von 100nF auf 25uF erhöhen.
Und dann bitte mal berichten was passiert.

Autor: ws (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das mit den Sense-Leitungen ist eigentlich ein Non-Sense. Sense(+) und 
Sense(-) werden noch innerhalb des Netzteiles direkt und permanent! an 
OUT(+) und OUT(-) angeschlossen. Der Kondensator C11 wurde nicht 
bestückt sondern kommt direkt an die Ausgangsklemmen. Das Szenario mit 
den offenen Sense-Klemmen hab ich mir noch nicht überlegt, 
wahrscheinlich kommt da nichts Gutes raus.

Das mit den Led's hab ich mir auch durchgedacht, hielt es dann aber doch 
für etwas zu knapp. Im Moment halte ich es so für eine bessere Lösung. 
Ausserdem habe ich die Platine bereits bestückt. Man könnte es sich also 
für die zweite Platine überlegen.

@Benedikt

Die Schaltzeichen sind natürlich verkehrt. Ich habe für die 
Feritgstellung der Platine auf die richtigen Packages geachtet, und 
damit wurden wahrscheinlich die Packages vertauscht und habs dann total 
übersehen. Danke dir!

Autor: ws (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Andrew Taylor

Darf ich fragen was du Dir davon erwartest? Oder hast du viell. schon 
eine Theorie?

Autor: Lothar Miller (lkmiller) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wie sieht das Layout aus? Der LT1632 ist ein recht schneller seiner 
Gattung (immerhin rund 100mal schneller als der TLC271). Da schwingt 
schnell mal was.

> Interessanterweise war in der Originalschaltung an beiden OPVs absolut
> keine Gegenkopplung vorhanden.
Weil die TLC271 relativ beschaulich arbeiten, ist da nichts nötig. Die 
Gegenkopplung lief damals ganz einfach über den FET.

Autor: pillepalle (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
moin

reihenschaltung R + C als Gegenkopplung am OP ?

das muss parallel wenn ich mich nicht irre ;)

Autor: Benedikt K. (benedikt) (Moderator)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
pillepalle wrote:
> moin
>
> reihenschaltung R + C als Gegenkopplung am OP ?
>
> das muss parallel wenn ich mich nicht irre ;)

Es gibt beide Möglichkeiten. Diese hat eine mit zunehmender Zeit immer 
größer werdende Verstärkung, so dass der Regelfehler minimal ist. 
Hauptsächlich dient das RC Glied dazu, die Schaltung am Schwingen zu 
hindern.

Autor: Jens G. (jensig)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
also 5mV Spannungsbuckel (ist das wirklich schlecht ???) kommen bestimmt 
von der begrenzten Gleichtaktunterdrückung von IC5B. Denn seine beiden 
Eingänge brummen ja mit der Last mit. Die Last ist ja gegen + 
geschaltet, wenn ich es richtig begriffen habe. Das 
Gegenkopplungsnetzwerk bezieht sich aber auf Masse, womit es hier auf 
die Gleichtaktunterdrückung drauf ankommt. Vielleicht findest Du einen 
OPV, der in dieser Disziplin besser glänzt. Oder du versuchst, die 
1%-R's in der Gegenkopplung (R3-R6) leicht zu varieren im unteren 
%-Bereich. Ich könnte mir vorstellen, daß man da mit einer bewussten 
Ungenauigkeit der R-Werte die Gleichtaktunterdrückung etwas unterstützen 
kann, bzw, deren Fehler unterdrücken kann. Das musste aber mal 
probieren, in welcher Richtung Du einen der R's verändern mußt.

Autor: ws (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Je nachdem welche Sense-Leitung nicht angeschlossen ist, geht der 
Ausgang auf Umax oder Umin, natürlich nicht erwünscht und natürlich wird 
dieser Fall, dass die Sense-Leitungen nicht dran sind, ausgeschlossen. 
Am Ausgang wurden jetzt 22µF parallelgeschalten.

Ich habe jetzt einige Tests durchgeführt:

1) unbelasteter Ausgang bei etwa 10V, Spannungs-LED noch dran, 
Gegenkopplung des Spannungs-OPVs rein kapazitiv mit 27pF. Ohne 
Gegenkopplung schwingt der OPV! Interessanterweise schwingt er auch mit 
einem TLC277 (Doppel-OPV von TLC271), der deutlich langsamer ist! Zur 
Ausgangsspannung siehe Bild 1

2) belasteter Ausgang mit etwa 1A bei etwa 10V , Spannungs-LED noch 
dran, Gegenkopplung des Spannungs-OPVs rein kapazitiv mit 27pF. Die 
Sägezahnspannung ist etwas zu erkennen. Zur Ausgangsspannung siehe Bild 
2

3) unbelasteter Ausgang bei etwa 10V, Spannungs-LED noch dran, 
Gegenkopplung des Spannungs-OPVs rein kapazitiv mit 220pF wie im 
Schaltplan!. Man bemerkt Spannungsbuckel, bzw. Sinusspitzen. Zur 
Ausgangsspannung siehe Bild 3

4) belasteter Ausgang mit etwa 1A bei etwa 10V, Spannungs-LED noch dran, 
Gegenkopplung des Spannungs-OPVs rein kapazitiv mit 220pF wie im 
Schaltplan!. Die Spannungsbuckel, bzw. Sinusspitzen sind deutlich zu 
erkennen. Zur Ausgangsspannung siehe Bild 4

5)Tests 1-4 ohne Spannungs-LED durchgeführt, es sind jedoch keine 
Unterschiede zu erkennen. Ehrlich gesagt weiss ich nicht, was Andrew 
Taylor sich davon erwartet.

Alle Messungen sind AC gekoppelt mit 5ms/XDIV und 5mV/YDIV!

Jetzt bin ich mal gespannt ob sich jemand einen Reim drauf machen kann.

Meiner Ansicht nach liegt es an der Beschaltung des Spannungs-OPVs. 
Ehrlich gesagt weiss ich nicht mal wie er beschalten ist, also ob er als 
Subtrahierer fungiert oder nicht. Auch ob man in dieser Konfiguration 
einfach kapazitiv gegenkoppeln darf ist fraglich. Deshalb die 
Experimente mit C13. Ob diese Spannungsbuckel wohl dadurch entstehen 
dass R3,R4,R5 und R6 nicht komplett abgeglichen sind? Ich werde 
versuchen diese von Hand zu selektieren. Auch über die 
Gleichtaktunterdrückung habe ich mir Gedanken gemacht, aber kommen dann 
Buckel raus? Wer kennt den einen Rail to Rail IN OPV mit extrem hoher 
CMRR? Ich dachte schon daran den OPV mit einem INA122 auszutauschen, 
aber bei Strumentationsverstärkern solchen Typs ist die Bandbreite nicht 
unbedingt hoch. Ausserdem habe ich einen TLC277 eingesetzt der höhere 
Eingangsimpedanzen hat, weil ich dachte die Eingangsströme erzeugen 
Fehler, jedoch ohne Erfolg.

Autor: ws (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Upps..Bild 1 und 2 sind vertauscht...Bild 1 entspricht Test 2) und 
umgekehrt!

Autor: Jens G. (jensig)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
haste auch mal geprüft, ob die 12V sauber sind? Denn von dieser Spannung 
koppelst Du ja über R12 wieder was in den Regelkreis mit ein.
Wie hoch ist denn die Brummspannung auf +Ub? Die wird ja mit zunehmender 
Belastung auch größer, somit auch der Durchschlag auf die 
Ausgangsspannung.
Wie gesagt, ich würde mit den Gegenkopplungs-R's etwas experimentieren 
(einen der R's leicht variieren, evtl. mit Poti, das einen Teil-R 
darstellt).

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.