mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik USBProg am Mac unter VMWare Fusion


Autor: Thomas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo zusammen,

ich möchte den aktuellen USBProg an meinem MacBook Pro (Intel) in einer 
Windows-Instanz betreiben, die in VMWare-Fusion läuft.
Leider wird der USBProg nach dem Einstecken nicht erkannt.

Der USBProg ist der aus dem AVR-Starterkit. An meinem Windows-PC im 
Zusammenspiel mit AVR-Studio funktioniert er bestens.

Hat schon jemand geschafft, den USBProg am Mac zu betreiben, so wie ich 
das gerne hätte?

Für einen hilfreichen Tipp wäre ich sehr dankbar!

btw: Ich möchte nicht direkt am Mac programmieren, weil ich gerne mit 
AVR-Studio weiterarbeiten möchte.

Viele Grüße,
Thomas

Autor: Felix Nachname (time2ride)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,

Ich habe einen normalen USB<->RS232 Wandler mit Parallels laufen. Ich 
Verwende mein STK500 und AVR Studio ohne Probleme.
Ich kenn mich nich mit VMWare aus aber bei Parallels muss man die USB 
Geräte erst an die VM anschließen (Im Menü unter Devices/USB/). Wenn man 
das nicht macht, werden die an OSX angeschlossen.
Kann ja sein, dass das bei Fusion ähnlich ist.

Autor: Sven Bayer (mainframeosx)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Vieleicht hilft dir das weiter...

http://www.macsven.de/USBasp.html

Läuft unter MacOS X und Windows XP mit avrdude

Autor: Thomas Z. (solo0506)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
[...]
Ich kenn mich nich mit VMWare aus aber bei Parallels muss man die USB
Geräte erst an die VM anschließen (Im Menü unter Devices/USB/). Wenn man
das nicht macht, werden die an OSX angeschlossen.
Kann ja sein, dass das bei Fusion ähnlich ist.
[...]

Das ist auch bei Fusion so. Der USBProg wird als unbekanntes USB-Gerät 
angezeigt, aber wenn ich ihn verbinde, tut sich nichts. Der Menüeintrag 
verschwindet und ist nach eingen Sekunden wieder da...

Autor: Thomas Z. (solo0506)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Sven Schwiecker wrote:
> Vieleicht hilft dir das weiter...
>
> http://www.macsven.de/USBasp.html
>
> Läuft unter MacOS X und Windows XP mit avrdude

Danke für den Tipp, das sieht wirklich gut aus. Aber ich habe ja schon 
den USBProg, der wie gesagt unter Windows bestens funktioniert. Und den 
würde ich gerne weiterbenutzen.

Viele Grüße,
Thomas

Autor: Andreas Purde (edrup)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das Problem ist wohl, dass es es beim Mac ein Problem mit dem USB 
Descriptor gibt: 
http://wiki.embedded-projects.net/index.php?n=Main... Problem 
#3

Die Konsequenz wäre wohl, die Basis-Firmware anzupassen - habe ich aber 
noch nicht probiert.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.