mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik I2C am AVR, high oder low?


Autor: pacer (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Leute,

wollte mal nachfragen welche Pegel nach der Initalisierung der 
I2C-Schnittstelle an der Takt- und Datenleitung liegen. Soweit mir 
bekannt ist, müssten bei einem Start der Übertragung sowohl die Takt- 
als auch die Datenleitung auf low gezogen werden. Das würde aber 
bedeuten das zwischen Initalisierung und Startsignal beide Leitungen auf 
high liegen müssten.

Liege ich da richtig mit meiner Vermutung?
Hintergrund, ist der, dass meine Verbindung zwischen Temperatursensor 
und Mega8 nicht mehr funktioniert und ich mir mal die Signale anschauen 
müsste.

Gruß, pacer

Autor: tempo (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hallo pacer,

schau mal hier:
http://www.roboternetz.de/wissen/index.php/I2C

Autor: pacer (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
So, hab den Fehler gefunden, Kurzschluss der Clockleitung nach Masse.
Im nachinein klar, dass beide am Leitungen high sein sollten, da sie ja 
über die Pullupwiderstände auf high gezogen werden.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.