mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Atmega 644 mit 16MHz Quartzozillator Problem


Autor: Florian (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi Leute hab hier einen Atmega 644 in Minimalbeschaltung und möchte 
diesen mit einem  16MHz Quartzozillator laufen lassen. Die Fuses sind 
korrekt gesetzt bekomme aber keine gescheite ISP Kommunikation mit ihm 
hin (hab die Fuses auf einem anderen Board gesetzt).Meistens fnktioniert 
es auch überhaupt nicht. Als Programmer nutze ich ein LOWCOST LPT Kabel 
das bis jetzt immer einwand frei Funktioniert hat. Selbst wenn ich die 
Teilung durch acht (CKDIV8) aktiviere klappt es nicht. Hat einer von 
euch ne Idee?

gruss

Florian

Autor: TorstenS (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

bist du evtl. über den Unterschied zwischen Quarz und Quarzoszillator 
gestolpert?

Gruß
Torsten

Autor: Florian (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ja bin ich.
Fuses stehen auf external Clock und der Oszi ist nur mit Xtal1 
verbunden.

So wie ich es immer mache.

Gruss Flo

Autor: Michael U. (amiga)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

Standardfragen: Stromversorgung ok?
je 100n dicht an allen VCC/GND, AVCC/AGND-Pärchen?
100n dicht an VCC/GND des Quarzoszillators?

16MHz sind selbst auf einem Steckbrett kein Problem, Leitungsführung und 
die Stützkondensatoren sind dann aber durchaus schon von Bedeutung.

Gruß aus Berlin
Michael

Autor: Florian (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ja, da komische ist das es erst funktionierte dann aber nur Kauderwelsch 
kamm. Dachte erst daran das eventuell die ISP verbindung gestört ist und 
hab die verbindung umgelegt und nun geht nix mehr mehr.obwohl die 
Leitungen all ok sind und die Versorgung auh Funktioniert.

Gruss
flo

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.