mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik schrittmotorsteuerung


Autor: Daniel Münzi (erfolgstyp)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hallo

ich habe ein problem mit meiner schrittmotorsteuerung und zwar habe ich 
die l297/298 kombination 4 mal auf einer platine aufgebaut
(1 Spannungsversorgung) das problem ist wenn ich die strombegrenzung 
(Vref) auf 3V aufdrehe zieht motor 3,5A ist meiner meinung nach schon 
etwas zuviel (arbeite in vollschritt)drehe ich jetz die Vref einer 
weiteren endstufe hoch ziehen die motoren zusammen ca 9A. drehe ich jetz 
wieder einen runter bleibt der andere auf 5A bis ich die strombegrenzung 
wieder runterdrehe danach zieht er wieder 3,5A. außerdem ruckelt der 
motor den ich gerade aufdrehe ganz egal bei welchem ich das mach es ist 
immer das gleiche

kann mir bitte jemand helfen ich bin mittlerweile echt ratlos

danke im vorraus
mfg münzi

Autor: Klaus (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das ist so komplex, daß es ohne Schaltplan und evtl. Quelltext
nicht zu vernünftigen Antworten kommt.

Autor: Lothar Miller (lkmiller) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> (Vref) auf 3V aufdrehe zieht motor 3,5A
Was würdest du denn erwarten?

Schaltplan + Layout?

Welche Spannungsversorgung? Ist die stabil (auch bei 9A)?

Autor: Daniel Münzi (erfolgstyp)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@klaus
der schaltplan ist in den datenblättern eingezeichnet ich bin nicht von 
der standart beschaltung abgewichen

@Lothar
wenn ich Vref hochdreh erwart ich eignetlich ca 2A is ja die angegebene 
leistungsgrenze des l298 aber mit 3,5A könnt ich noch leben
als spannungsversorgung hab ich nen 300VA/14V trafo mit 
brückengleichrichter (25A mit kühlkörper) geglättet wird es über 30 
2200µF/25V kondensatoren
stabilisiert ist es nicht weil ich mich damit recht wenig auskenne und 
ich denke dass es bei diesen strömen zu aufwendig wäre

danke für eure antworten
mfg münzi

Autor: Daniel Münzi (erfolgstyp)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
was ich noch vergessen hab bei ca 12A bricht die spannung auf 12V 
zusammen

Autor: Klaus (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi Münzi,

>ich bin nicht von
>der standart beschaltung abgewichen

evtl. doch? Ansonsten hättest Du Ok-Werte!

Autor: Daniel Münzi (erfolgstyp)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
eigentlich lief alles schon wunderbar bis ich den 4ten motor 
angeschlossen hab seit dem spinnt die ganze schaltung ich hab schon 
ziemlich viele bauteile ausgetauscht aber es hilft alles nichts immer 
der gleiche fehler

kanns vllt sein dass der l297 auf halbschritt umschaltet also dass er 
beide spulen bestromt das fältt mir grad so ein während ich meinen 
beitrag les
ich hab ihn zwar auf vollschritt geschalten aber wo soll der ganze strom 
sonst hin und vorallem woran kann das nun wieder liegen??

mfg münzi

Autor: Klaus (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi Münzi,

wenn

>eigentlich lief alles schon wunderbar

das zutrifft, dann bau das ganze mal auf einen Motor zurück.
Danach kannt Du die "Macke" Stück für Stück durch schrittweise
Wiederinbetriebnahme finden! Klaus

Autor: Daniel Münzi (erfolgstyp)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hallo klaus

werd das morgen mal versuchen
außerdem werd ich messen ob beiden spulen bestomt werden wenn er 5A 
zieht dass würde dann heißen dass er aus irgendeinem grund in 
halbschritt fällt
das würde zumindest den strom und dass ruckeln erklären woher es dann 
kommt ist allesdings selbst mit dem lösungsansatz noch ein problem...

danke erstmal für die antworten
gute n8

Autor: Daniel Münzi (erfolgstyp)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hallo

habe heute mal nachgemessen und festgestellt dass der l297 den l298 so 
ansteuert dass der beide phasen des schrittmotors bestrom. darum der 
hohe strom. was ich jetz nicht versteh is warum der l297 im stillstand 
scheinbar auf halbschritt schaltet??

wär dankbar wenn mir jemand nen tipp geben könnte
mfg münzi

Autor: Lothar Miller (lkmiller) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> der schaltplan ist in den datenblättern eingezeichnet ich bin nicht von
> der standart beschaltung abgewichen
Auch nicht vom vorgeschlagenen Layout?

Autor: Daniel Münzi (erfolgstyp)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
vom vorgeschlagenen layout schon hab selbst eins designt
aber ich glaub nicht dass es daran liegt
was ich aber festgestellt hab is dass ich wahrscheinlich nur im normal 
drive mode (also called ”two-phase-on” drive)bin ich müsste demnach in 
den wave drive mode(also called ”one-phase-on” drive) soweit müsst ich 
nach reichlicher überlegung und ewigem datenblatt lesen jetz richtig 
liegen mein neues problem ist jetz dass ich nicht ganz versteh wie ich 
in den wave drive mode "kommen" soll. ich brauch 0V auf half/full (Pin 
19) und der translator muss auf 2, 4, 6 oder 8 stehen. aber wie kann ich 
sicher sein dass er auf einer der bitfolgen steht?

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.