mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik Problem mit Spannungsmessung am Kfz-Temperaturfühler


Autor: AlexW (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo miteinander!

Ich möchte die Spannung an einem im Auto verbauten 
NTC-Kühlmitteltemperatursensor mit einer Schaltung messen.

Üblicherweise ist im Motorsteuergerät ein 5 Volt Pullup-Widerstand 
verbaut (ca. 3k9 Ohm), an dem der NTC-Fühler angeschlossen ist. Der NTC 
geht auf Masse und bildet damit einen Spannungsteiler, der im 
Motorsteuergerät von einem AD-Wandler ausgewertet wird.

Mein Problem: messe ich diese Spannung mit einem Multimeter oder einem 
USB-Messsystem, klappt die Spannungsmessung solange der NTC einen großen 
Widerstand hat. Wird der NTC-Widerstand sehr klein (ca. 200 Ohm), 
pendelt die Spannung (die z.B. bei 0.9V liegen müsste) zwischen 0.5V und 
2.5V. Das Motorsteuergerät beeindruckt das übrigens nicht, die 
Temperatur wird über OBD nach wie vor korrekt angezeigt.

Hängt man ein Oszilloskop an die Leitung, bleibt die Spannung auch bei 
sehr kleinen NTC-Widerständen stabil. Operationsverstärker vorschalten 
klappt nicht. Entkoppeln mit einem 100nF-Kondensator habe ich auch schon 
versucht.

Kann mir jemand einen Tipp geben, wie die Eingangsschaltung vor dem 
AD-Wandler meiner Schaltung aussehen müsste? Vielen Dank!

Autor: Michael Lenz (hochbett)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Alex,

zeichne bitte ein Schaltbild dazu, dann läßt sich darüber reden.

Gruß,
  Michael

Autor: AlexW (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Michael,

anbei das Schaltbild.
Wie genau die Schaltung zum AD-Wandler des Motorsteuergerätes aussieht, 
weiß ich leider nicht. Ich vermute, dass da der Hund begraben liegt. 
Wenn ich die Schaltung so auf einem Board nachbaue, gibt´s kein Problem.

Gruß,

Alex.

Autor: Peter Hoppe (peterhoppe59)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

haben Deine Meßgeräte automatische Bereichsumschaltungen? Was passiert, 
wenn Du mit Scope und DVM gleichzeitig misst?

MFG Peter

Autor: oszi40 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
1.Wirf auch mal eine Auge auf die Masse und die LAGE Deiner Kabel. Je 
kleiner die Spannung wird, desto mehr Störungen könnten das Sigal 
verfälschen. Für den Oszi nimmst Du ein geschirmtes Kabel und für den 
Vielfachmesser 2 Laborstrippen??

2.Haben die Meßgeräte Zimmertemperatur??

Autor: Michael Lenz (hochbett)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

> Wie genau die Schaltung zum AD-Wandler des Motorsteuergerätes aussieht,
> weiß ich leider nicht. Ich vermute, dass da der Hund begraben liegt.
> Wenn ich die Schaltung so auf einem Board nachbaue, gibt´s kein Problem.
Wenn das Oszi alles richtig anzeigt und das DVM nicht, dann ist das DVM 
wahrscheinlich nicht in Ordnung oder treibt böse Scherze mit Dir 
(Bereichsumstellung u. ä.).

Gruß,
 Michael

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.