mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik SHT15 problem


Autor: Tom (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich habe seit 3 Tagen ein Problem mit seinen SHT15 Sensor an einen 
Mega162an einen 8MHz Quarz. Dieser ist vor ca. zwei Jahren schon mal 
gelaufen und habe auch schon mehrere in Betrieb genommen.

Kurz zur zu der Programmstruktur.

- Ich mache zuerst die Reset Sequenz (Datenleitung auf high, dann 12mal 
SCK)
- Dann die Befehlssequenz ( set sck,- reset daten,- reset sck,- set 
sck,- set daten,- set sck)
- Dann den Befehl (zb.00000011 für Temperatur)
-Datenleitung auf Eingang umschalten, gefolgt von einen Sck_Takt
-Warten bis Messung fertig (SHT legt Datenleitung auf Low)  , das macht 
er auch
-MSB einlesen

Das MSB hat konstant 255 und das LSB 0.

Hat diesen Effekt schon Jemand gehabt?

Pull-Up 4k7 ist drin und es ist mit dieser Beschaltung an diesen Pin 
auch schon ein 1Wire Sensor gelaufen.
Außerdem gehe ich davon aus, dass der Sensor funktioniert, da er nach 
der Befehlübermittlung die Datenleitung auf Low legt.

Autor: Knut Ballhause (Firma: TravelRec.) (travelrec) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Pinning?

Autor: Tom (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Verzeihung Pinning? Kannst du mit das näher erläutern?

Ich sollte vielleicht noch erwähnen, dass ich Bascom verwende und 
zwischenzeitlich schon einen zweiten mit dem gleichen Resultat probiert 
habe. Beide sind vor ca. zwei Jahren schon einmal problemlos gelaufen 
und wurden in einer ESD Verpackung gelagert.

Ich habe den Code mal angehängt – vielleicht findet ja einer einen 
Fehler. Der alte Code ist mir durch einen Festplattencrash verloren 
gegangen.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.