mikrocontroller.net

Forum: Compiler & IDEs Probleme mit GCC und Make


Autor: Nick Herzog (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,
vielleicht kann mir hier jemand helfen:
Ich habe unter WINNT4 SP6 AVRGCC installiert. 
(avrgcc_freaks20011214a.exe.
Dann habe ich die Umgebungsvariablen gesetzt:
set AVR=C:\AVRGCC
set CC=avr-gcc
set PATH=C:\AVRGCC\bin;%path%
Wenn ich nun bei den Beispielen z.B.: gcctest1.c im verzeichnis make 
aufrufe bekomme ich als Fehlermeldung:
Error makefile 36 : Command Syntax Error
*** 1 errors during make ***
Ich weis nicht an was das liegen könnte, kann mir jemand sagen was ich 
falsch mache ?

THX
Nick

Autor: Joerg Wunsch (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
An Zeile 36 des Makefiles. ;-)  Was dort steht, müßtest Du
denn schon posten, meine Spiegelkugel ist gerade kaputt...

Aber diese Version ist hornalt.  Nimm bitte WinAVR, die
aktuelle Version ist 200301<irgendwas>.

Autor: Nick Herzog (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich wußte nicht das damit die Zeile gemeint ist.
in Zeile 36 steht:
include $(AVR)/avrfreaks/avr_make
ich dachte es wäre ein Fehlerqode.
Ich werd mal die neuere Version testen.

THX
Nick

Autor: Andreas Schwarz (andreas) (Admin) Benutzerseite Flattr this
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Was schreibe ich auf 
http://www.mikrocontroller.net/avr-gcc-installation.htm? "Bitte 
unbedingt die Richtung der Schrägstriche beachten!". Ich bin mir sicher 
dass der Backslash in der Variable AVR schuld ist.

Autor: Nick Herzog (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

Der Backslash is Richtig, hab ich ja von deiner Anleitung mit Copy Paste 
eingefügt.
Ich hab irgendwo gelesen das GCC Probleme macht wenn Microsoft Visual 
C++ installiert ist, kanns daran liegen ? ich hab Studio 6 installiert ?
THX
Nick

Autor: marcel (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
nicht das ich wüsste habs auch am laufen...probiers erst mal mit der 
winavr version..wenns dann noch probleme gibt meld dich...

Autor: Andreas Schwarz (andreas) (Admin) Benutzerseite Flattr this
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Der Backslash ist falsch, in meiner Anleitung steht:
set AVR=C:/avrgcc

Autor: Nick Herzog (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich hab nochmal nachgeschaut, ich habs schon richtig gemacht, nur hier 
im forum falsch gepostet.
Klappt aber nicht.
Ich werd dann doch mal winavr testen müssen.

Nick

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.