mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik MAX232 töten?!


Autor: Sebastian (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo!

Kann man einen MAX232 kaputt kriegen, indem man die Ein- und Ausgänge
vertauscht? Ich suche verzweifelt einen Fehler in meiner Schaltung, und
habe gerade gemerkt, dass die +10V und die +10V gar nicht an den Pins 2
bzw. 6 anliegen. Das scheint ja ein Zeichen dafür zu sein, dass der MAX
hin ist. Nur wieso? Kann vertauschen von RxD und TxD Schuld sein?
(Vielleicht habe ich das Kabel eben mal falsch rum drangesteckt ...)

Grüße, Sebastian

Autor: Nik Bamert (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi!

Also das mit rxd und txd verstauschen kanns kaum sein, das ist mir
schon ein paar mal passiert und nix ist kaputt gegangen. Aber wenn du
beim TTL eingang die Rs232 Leitungen Anschliesst, also -12 und +12
kommen statt 0 volt und 5 volt kann ich mir schon vorstellen das er nun
ein bisschen gebraten ist...

Nik

Autor: Sebastian (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,

nee, die RS232- und TTL-Seiten habe ich zum Glück nicht vertauscht. Ich
habe die Elkos jetzt 10 mal durchgeguckt, alles korrekt. Entweder war
der MAX schon von Beginn an fritte, oder ich habe ihn durch vertauschen
von RxD und TxD getötet. Ich versteh das nicht ... :-(

Grüße, Sebastian

Autor: Sebastian (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ach, noch was: Ist es eigentlich normal, dass der MAX232 jedes Zeichen
echo-t? Ich habe nur RxD und TxD vom PC (Pin 2 und 3) an dem MAX dran,
mehr nicht (also vom MAX zum µC gibt es keine einzige Verbindung!).
Trotzdem bekomme ich ein Echo auf jedes in ZOC eingegebene Zeichen.
Ziehe ich das Kabel aus dem PC aus, ist Stille. Also irgendwie scheint
es im MAX ein internes Übersprechen zu geben ... Oder ein weiteres
Zeichen dafür, dass der MAX hin ist?

Grüße, Sebastian

Autor: Nik Bamert (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,

oder villeicht war n' Elko von Anfang an kapuut->kurzschluss->Max auch
weg...Eigentlich kanns nur noch an den Elkos liegen, wenn die verpolt
sind, raucht der Max ab. Oder die Versorgungsspannung nicht richtig
oder verpolt, aber sonst kommt mir eigentlich ni^chts mehr in den
Sinn..:)

Nik

Autor: muesing7 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die Masse von RS232 zur Platine wirst ja wohl net vergesse habe?!?!?
oder......?
Gruß muesing7

Autor: Beginner (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,
ich hatte ein ähnliches Problem.
Allerdings mit dem MAX202.
Der ist aber quasi ein MAX232.
Ich habe auch das empfangene Signal aur Rx2 und Tx2 gemessen.
Keine Ahnung woran es liegt.
Habe dann einfach Rx1 und Tx1 benutzt und dann ging es.
Komischer Fehler.
Vorallem weil über Rx2 und Tx2 vorher die Kommunikation geklappt hat.

Mfg
 Beginner

Autor: Sebastian (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe jetzt den MAX232 rausgeholt und gegen einen MAX233 (den ohne
externe Elkos) ersetzt. Jetzt klappt meine Schaltung zwar immer noch
nicht, aber der Baustein scheint OK zu sein. Zumindest liefert er jetzt
schon mal die +10V und -10V an den "Kontroll"-Pins. Scheinbar war der
MAX232 wirklich putt.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.