mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Xport - RS232 für PC


Autor: Robert (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo an alle,

Ich hab mir eine Schaltung mit dem Xport Ethernet-Rs232 Adapter gemacht. 
Am Xport hängt ein Max3232 mit einem 3.3V Spannungsregler.

Nun habe ich die Schaltung aktiviert und beim Xport eine gültige IP 
Adresse vergeben. Angeschlossen ist das Modul am Ethernet Port des 
Laptops und über einen RS232-USB Wandler wieder am USB-Port.

Mit einem Testprogramm der Fa. Lantronix und einem Terminalprogramm 
wollte ich nun die Kommunikation testen. Doch leider funktioniert nur 
die Kommunikation von der RS232 Seite zum Netzwerk. Vom Netzwerk aus zur 
RS232 Schnittstelle erfolgt leider kein Datendurchsatz.

Hat jemand eine Idee woran das liegen könnte?

Danke im Voraus
lg Robert

Autor: Msp 430_crew (msp430_crew)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Welches Testprogramm von Lantronix nutzt Du denn zum Testen?
Wenn der XPORT direkt am Rechner dran ist, hast Du dann ein gekreuztes 
Ethernetkabel genommen?

Autor: S. Pfiffig (pfiffikus)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Zwischenfrage: Wo bekommt man das XPORT Modul günstig wenn man gleich 
größere Stückzahlen braucht?

Autor: Msp 430_crew (msp430_crew)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich würde sagen bei Lantronix direkt mal nachfragen!

Autor: Robert (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Das Testprogramm war bei der App. Note zum Thema "Creating Custom 
websites" dabei. Im Anhang ist ein Screenshot.

Ich dachte mein Netzwerkadapter kreuzt das von selbst aus. Ich hab nun 
das Modul direkt am Router. Jedoch selbes verhalten.

Wenn ich jedoch über Ethernet was senden will, bekomme ich es im zurück. 
Siehe im Anhang.

lg Robert

Autor: Msp 430_crew (msp430_crew)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das Programm kenne ich leider nicht!
Aber wenn der XPORT direkt am Rechner hängt, musst Du ein gekreuztes 
Ethernetkabel nehmen...am Router sollte es dann aber laufen mit normalem 
Patchkabel.
Ist der XPORT denn richtig konfiguriert? Also IP, Subnetmask und Gateway 
richtig eingetragen?

Autor: Robert (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
IP und Subnetzmaske sollten passen. Ich komm vom Netzwerk aus über den 
Router auf die Konfigurationsseite des XPorts. Gateway ist die IP des 
Routers.

Komish ist jedoch, dass das gesendete zurück kommt. Mit einem eigenen 
Java-Programm konnte ich selbiges Verhalten feststellen. Bei einem 
readLine() wir das gelesen, was zuvor hinausgeschrieben wurde.

Vielleicht liegt darin der Fehler irgendwo begraben?

Sonst habe ich nichts eingestellt, da ich gelesen habe, dass 
standardmäßig die Brücke so konfiguriert ist.

Autor: Msp 430_crew (msp430_crew)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Okay, wenn die Verbindung zur Xport-Oberfläche klappt dann stimmen die 
Einstellungen ja anscheinend!
Tut mir leid, dann weiß ich auch nicht weiter!

Autor: hmm (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Komish ist jedoch, dass das gesendete zurück kommt. Mit einem eigenen
> Java-Programm konnte ich selbiges Verhalten feststellen. Bei einem
> readLine() wir das gelesen, was zuvor hinausgeschrieben wurde.

Klingt nach einem Schluss zwischen TxD und RxD beim XPort.

Der XPort lässt sich ja auch in einen Konfigurations/Debugmodus
über die serielle Schnittstelle versetzen.
(3 x 'x' nach Poweron glaube ich.)

Geht das denn?

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.