mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik AVRISPmkII unter Windows Vista 64


Autor: Tobi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Guten Morgen,

ich kämpfe momentan mit meinem AVRispmkII und mein neues Betriebsystem 
Vista 64! hat jemand vielleicht der Programmer unter Vista 64 und 
AVRDUDE am laufen zu bekommen?
Mein Problem ist die "Signatur" der Treiber (für AVRDUDE) ist nicht 
"Signiert" und wird nicht initialisiert

Ich habe ja von Anfang an alles mit PN (WinAVR) gemacht und wenig mit 
AVR-Studio von daher meine Frage, unter AVR-Studio läuft

Gruß

Autor: Marius Wensing (mw1987)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Vom jetzigen Standpunkt empfehle ich dir, dich ganz schnell von dem 
Gedanken zu entfernen. Vista 64 akzeptiert den libusb-Treiber nicht. 
Wenn du Pech hast, zerschießt du dir damit sogar den ganzen USB-Stack.

Entweder lernt AVRDUDE den Jungo-Treiber zu nutzen, oder du musst 
warten, bis es von libusb ne 64-bit-Version gibt. Und das kann 
vermutlich lange dauern.

Nimm am besten AVRStudio zum Programmieren des µC.

MfG
Marius

Autor: Bensch (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Richtig, AVR Studio mit Jungo-Treiber läuft unter Vista64 problemlos.

Im übrigen bist du dann auch gleich die kryptische Fuseliste los unter 
Dude, die ist mir immer auf den S.. gegangen.

Autor: Tobi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,

danke für die Antworten!
naja ok, muß ich dann damit leben :-(
mit PN (WinAVR) programmieren und mit AVR-Studio flasen!

@ Marius Wensing
> Entweder lernt AVRDUDE den Jungo-Treiber zu nutzen

was meinst du damit?
kann ich in AVRDUDE irgenwo den Jungo-Treiber einfügen? glaube aber 
nicht oder?

Autor: Marius Wensing (mw1987)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Nein, soweit ich weiß kann AVRDUDE im Moment nichts mit dem Treiber 
anfangen. Wäre natürlich schön, wenn es irgendwann funktioniert. Dann 
wäre man von der ganzen LibUSB-Sache unter Windows weg.

MfG
Marius

Autor: Martin e. C. (eduardo)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Timo,
"prinzipiell" geht!

ich habe das gleiche Problem neuer Laptop, Vista 64Bit AVRISPmkII und 
programmiere auch gerne mit WinAVR.

Das Problem liegt NUR daran dass der beim WinAVR beilegenden Treiber 
nicht "Signiert" ist.

Beim booten mit F8 gibt's eine Funktion wo man "Signatur Prüfung der 
Treiber" desaktivieren kann (hab momentan nicht mein Laptop dabei und 
kann nicht genau sagen).
So lässt sich der Treiber von AVRISPmkII unter Vista 64Bit problemlos 
installieren und funktioniert unter WinAVR bzw. AVRDUDE Fehlerlos!

Du muss aber jedes Mal die "Signatur Prüfung" (mit F8 beim Booten) 
abschalten sonst funktioniert der AVRISPmkII nicht :-(

Gruß
Martin

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.