mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Frage zu Schrittmotorsteuerung


Autor: Yannic (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hi,

ich habe mal eine Frage zur oben angehängten Schrittmotorsteuerung.

Ich bekomme wenn ich das Poti voll aufdrehe pro ausgang maximal 1,2A. 
Eigentlich müsste ich aber auf 2A kommen.

Ich hab dann mal am Poti (25k) von GND -> Potiausgang gemessen und 
bekomme dort wenn ich das poti voll aufdrehe nur 11,6 K raus.

Jemand eine Idee woran das liegen kann ?

mfg Yannic

Autor: Michael U. (amiga)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

was soll man dazu bei einem Schaltplan ohne vollständige Wertangaben der 
Bauteile wohl antworten...

Gruß aus Berlin
Michael

Autor: Lothar Miller (lkmiller) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Ich hab dann mal am Poti (25k) von GND -> Potiausgang gemessen und
> bekomme dort wenn ich das poti voll aufdrehe nur 11,6 K raus.
Im eingebauten Zustand?
Wenn ja, dann hast du den R7, die Dioden und die gute Hälfte vom IC mit 
vermessen.
Welchen Wert hat R2, was ist IC2?

BTW:
offenbar hast du IC2 selber gezeichnet, denn dieses Schaltplansymbol ist 
absolut nichtssagend. So sieht eigentlich ein Makro für das Layout aus.

Autor: thomas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hallo

tja....da muß ich meinem stadtgenossen recht geben.

ich hole mal meine glaskugel und versuche es 
trotzdem................................................................ 
...................................................kann  es sein, das 
dein strommesser einen mittelwert anzeigt????
in den spitzen könnte es ja die 2A haben.

gruß

Autor: Yannic (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ui,

Sorry ganz vergessen zu sagen, was das IC2 ist.

Das IC2 ist ein LM358 (OAmp)
R2 hat 0,68 Ω / 4 W

Jop gemessen habe ich in eingebautem Zustand.

@ thomas

sollten die 2A bedingt durch die Schaltung nicht permanent anliegen ? 
(Messen tue ich mit angeschlossendem Schrittmotor von KL4 1 über die 
Phase des Schrittmotor zum KL4 2).

mfg Yannic

Autor: Yannic (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Keiner eine Idee wo ich was nachmessen könnte um der Sache auf den Grund 
zu gehen, wieso ich pro Ausgang keine 2 A eingestellt bekomme ?

mfg Yannic

Autor: Ratzi_ratlos (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
das ist doch die typische Pollinschaltung...

mach R2 kleiner und der Strom wird sich erhoehen !

Autor: Yannic (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,

ja das ist die typische Pollin Schaltung. Was mich wundert ist nur, dass 
sie im Datenblatt mit 2A angegeben ist. Deswegen wundert mich etwas das 
pro Phase nur 1,2A zur verfügung stehen. Oder bezieht sich die angabe im 
Datenblatt auf beide Phasen zusammen ?

mfg Yannic

Autor: Ratzi_ratlos (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
...schoen,dass du dich wundern kannst.
zu einem Resultat kommst du indem du einen zB 1R0 parallel zum R2
schaltest......Kann deine Stromversorgung laessig 2 A ??
2A ist schon ein schoenes Stroemchen

Autor: Yannic (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,

danke schonmal für die Hilfe.

Mich würde aber dennoch interessieren ob das Problem bei der Pollin 
Schaltung so grundsätzlich besteht, oder ob ich einen Layoutfehler habe 
der das Problem verursacht.

Der Leistungswiderstand wurde bisher auch immer recht heiß.

Das Netzteil kann bei 24V 20A liefern, massig Power ist also da.

mfg Yannic

Autor: Ratzi_ratlos (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Fehler kannst nur du finden.
Wie gross ist R2 ? Messung entspricht Farbcode oder Aufdruck ? Leistung 
?
Auch dein 7805 duerfte bei 24V in auch gemuetlich warm werden ;-)

Autor: Yannic (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi zu R2 hatte ich oben schon was geschrieben:

R2 hat 0,68 Ω / 4 W

Messungen ergeben den selben Wert.

mfg Yannic

Autor: Yannic (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,

ich habe gerade nochmal 2 Fragen.

Ich würde wegen der starken Belastung des 7805 gerne die Logik mit einem 
5 - 12V Netzteil betreiben.

Kann ich Gnd von den beiden Netzteilen dann zusammenschalten und an die 
Logik dann die + 5-12V und an VS des L298 und die Dioden dann die + 24V 
des anderen Netzteil ?

Und die 2. Frage du hattest oben etwas von einem 1 Ohm Widerstand 
parallel zu R2 geschrieben, dass würde dann ja (I = U/R) I = 0,8V / 0,4 
Ohm = 2A ergeben, aber wie sieht es mit der Belastbarkeit des 1 Ohm 
Widerstand aus ? Denn der R2 hat ja 4Watt und meine 1Ohm nur 1/4 würde 
das zu problemen führen, oder wie teilt sich das auf ?

mfg Yannic

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.