mikrocontroller.net

Forum: PC Hard- und Software Microcontroller in Maus defekt?


Autor: kitze (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,
ich habe jetzt endlich mal meine MX510 auseinandergebaut, da sie seit 
einem Sturz nicht mehr geht, oder besser gesagt die linke Maustaste. 
Habe schon die Verbindungen mit einem Multimeter gechekt, alles okay. 
Die Schalter habe ich auch ausgetauscht. Das komische war nur, dass ich 
die Maus mal angeschlossen hatte und mein Bruder dann V und A gemessen 
hat. Als ich dann mit der linken Maustaste geklickt hab, gings auf 
einmal? Aber nur für den Zeitraum, als er das Multimeter dran hatte.

Habe auch alle anderen Verbindungen von dem Taster gecheckt, auch die 
zum Mikrocontroller in der Maus ist okay. Könnte es denn sein, dass der 
Mikrocontroller durch einen Sturz kaputt gegangen sein kann? Aber 
eigentlich spricht ja dagegen, dass die linke Maustaste kurz 
funktioniert hat. Ich bin komplett verwirrt irgendwie..

Wenn jemand weitere Ideen hat, bitte immer her damit!

Danke schonmal!

Autor: Visitor (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Was hat er gemessen, als es ging? Strom oder Spannung? Beides 
gleichzeitig ja wohl kaum mit nem normalen Multimeter.

Und wo hat er das gemessen? Also zwischen welchen Punkten?

Autor: HildeK (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Sieht für mich trotzdem nach einer defekten Verbindung aus: Lötstelle, 
Leiterbahn oder ev. sogar ein haarfeiner Kurzschluss zweier Pins. Das 
ist gelegentlich sehr schwierig zu erkennen. Durch den Druck mit der 
Messspitze kann sich das temporär reparieren.
Überprüfe mit einer Lupe bei gutem Licht die betreffenden Stellen. 
Versuche mit einer sehr feinen Pinzette o.ä. an den Pins des Controllers 
zu wackeln - das sollte nicht gehen, wenn sie alle festgelötet sind. 
Oder löte einfach die Pins nach.
Ich hatte mal einen USB-Stick, klein und so flach, dass ich ihn im 
Geldbeutel unterbringen konnte - wo er über Gebühr mechanisch 
beansprucht wurde. Irgendwann ging er nicht mehr. Nur unter dem 
Mikroskop und der Pinzette konnte ich ausmachen, dass sich einige Pins 
vom Pad gelöst hatten.
Es war zu reparieren.

Autor: PC Fuzzi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ja oder kauf ne neue Maus.
Ich hab an der Arbeit noch ca. 400 FS Mäuse rumgobbeln, wenn du sie 
haben willst melde dich.

Autor: kitze (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also, er hat zuerst die Stromstärke und danach die Spannung gemessen und 
bei beiden hat die linke Maustaste dann wieder kurz funktioniert. Könnte 
es denn sein, dass das Multimeter die Verbindung irgendwie überbrückt 
hat?

Hier sind nochmal Fotos wo gemessen wurde:

http://img91.imageshack.us/img91/4246/dscn2290.jpg
http://img252.imageshack.us/img252/1182/dscn2291.jpg
http://img252.imageshack.us/img252/1241/dscn2292.jpg

Werde mich nachher mal auf die Suche nach kleinen Rissen machen, aber 
eigentlich kann es ja nicht wirklich was mit den Pins des 
Microcontrollers zu tun haben, der liegt ja auf ner ganz anderen Platine 
(auf der braunen).

Gruß

Autor: HildeK (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Werde mich nachher mal auf die Suche nach kleinen Rissen machen, aber
>eigentlich kann es ja nicht wirklich was mit den Pins des
>Microcontrollers zu tun haben, der liegt ja auf ner ganz anderen Platine

Mit den Fotos sieht einiges anders aus, als ich es mir vorgestellt 
hatte:
- µC: kein SMD, andere Platine - Fehler ist dort nicht als erstes zu 
vermuten
- einiges an bedrahteten BE

Ich würde jetzt als erstes den Lötkolben nehmen, und die paar Lötstellen 
einfach mal nachlöten. Speziell die Steckverbinder und Tasten. Bei der 
bedrahteten Technik sind mir auch schon gelöste Lötstellen begegnet, 
meist durch thermische Zyklen (bei alten Fernsehgeräte) oder eben 
mechanische Belastung. Auch die dünnen Leiterbahnen, die an die großen 
Lötaugen der Steckverbinder gehen, sind mechanisch gefährdet.

Autor: kitze (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Welche Lötstellen meinst du genau? Ich hab nochmal die Verbindung von 
der Maustaste bis zum Microcontroller gecheckt, und das Multimeter hat 
mir angezeigt, dass da eine Verbindung besteht. Hab ja auch schon den 
Schalter von der linken Maustaste und den vom Mausrad ausgetauscht. Der 
vom Mausrad geht einwandfrei, der von der linken Maustaste ja nicht. 
Deshalb denke ich, dass es eigentlich nicht am Schalter, sondern ja fast 
nur an den Verbindungen liegen kann. Aber da ist ja eigentlich eine 
Verbindung hergestellt. Zumindest bei dem einen Pin.

Ich habe auch nochmal eine allgemeine Frage:

http://img171.imageshack.us/img171/3060/dscn2290kopie.jpg

Die rot eingezeichnete Verbindung versteh ich ja. Aber zu welchen Pins 
(1-8) vom Steckverbinder gehen denn die Pins a und b vom Schalter?

Gruß

Autor: Rufus Τ. Firefly (rufus) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wenn Du die Focusebene Deiner Kamera parallel zur Platine ausrichten 
würdest, also das ganze Bild scharf ist, dann könnte man dazu was 
sagen. Gerade aber die Lötstellen des Tasters sind sowas von unscharf 
...
Daher nur Vermutungen:

b ist gar nicht angeschlossen, a ist mit der Massefläche verbunden, die 
vermutlich zu Pin 7 des Steckverbinders führt.

Autor: *.* (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Logische Erklärung wäre Pullup-Widerstand gebrochen (sofern einer 
vorhanden ist).

Autor: kitze (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hm..wie genau sieht denn so ein Pullup-Widerstand aus bzw. wie kann ich 
den identifizieren?

Ein scharfes Bild werde ich nachher nochmal nachreichen.

Gruß

Autor: Rufus Τ. Firefly (rufus) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ein Pullup-Widerstand ist ein ganz normaler Widerstand.

Auf Deinem Bild

http://img171.imageshack.us/img171/3060/dscn2290kopie.jpg

sind gleich zwei davon etwas oberhalb von Punkt "A" zu sehen, im 
Bestückungsdruck mit R19 und R14 beschriftet.

Autor: HildeK (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Welche Lötstellen meinst du genau?
Auf jeden Fall alle die von Durchsteck-Bauelementen. Da es aber nicht so 
viele sind, löte einfach alles mal nach.

>Aber zu welchen Pins
>(1-8) vom Steckverbinder gehen denn die Pins a und b vom Schalter?

Das ist auf dem Foto nicht zu erkennen. Gibt es auch Leiterbahnen auf 
der Oberseite? Sieht auf Grund der Durchkontaktierungen zumindest so 
aus. Also können diese Pins auch oben weitergehen.

Autor: Rufus Τ. Firefly (rufus) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Zwar ist das eine zweilagige Platine, aber aufgrund des 
kostenreduzierten Herstellungsprozesses sind hier Durchkontaktierungen 
keine Lötaugen.
Das Platinenmaterial ist kein FR4, sondern so eine Art Pertinax, da kann 
man mit gewissem Aufwand zwar Vias einbauen, die aber sind nicht lötbar.

Daher kann man davon ausgehen, daß Lötstellen, zu denen auf der Lötseite 
keine Leiterbahn führt, tatsächlich offen sind.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.