mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik kein Strom?


Autor: Martin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi!

Ich habe den Schaltplan im Tutorial mit einem
ATMega8 aufgebaut und eine Spannung von 5 Volt angelegt.
Leider fließt jedoch kein Strom, wie ich auf meinem
Labornetzgerät ablesen kann (nur 0.11 Ampere).
Habe ich einen Fehler im Schaltplan gemacht, oder
kann das wirklich stimmen, dass der ATMega8
fast keinen Strom verbraucht, wenn er nichts rechnet?
Das ist übrigens mein erster Versuch mit Mikrocontrollern
und der Mikrocontroller ist unprogrammiert.
Pony-Prog erkennt ihn nicht.

Martin

Autor: Stefan Kleinwort (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
0.11 Ampere?
das ist 110mA. Der mega8 braucht so um die 15mA, auch wenn er richtig
rechnet.

Stefan

Autor: Martin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Komisch...

Wenn ich mit Ponyprog den Mikrocontroller auslesen will,
bekomme ich immer die Meldung "Device missing or unknown Device".

Wodran kann das liegen?

Autor: Martin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi!

Ist schon OK.
Ich habe es selbst gelöst.
Wenn ich die Pins von der anderen Seite sehe,
muss ich natürlich seitenverkehrt denken. Das
hatte ich jedoch vergessen.

Nun funktioniert es.
Und jetzt erhalte ich auch ungefähr 15 mA.

Martin

Autor: wolli (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wenn da vorher längere Zeit 110mA geflossen sind, hast Du glück wenn
noch alle Pins funktionieren.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.