mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik micrel lm2576


Autor: Julian Asd (julian123)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo

Ich hab ein Problemm mit dem LM2576 5.0wt von Micrel.
Ich hab ihn so angeschlossen wie im Datenblatt und es kommen auch 5V
raus aber wenn ich ihn belaste bricht die Spannung bei ca 250ma auf 2V 
zusammen. Ein LM2575 von National Semiconductors liefert in der gleichen 
Schaltung stabil 1A bei 5V. Diode ist eine SB 504 und Spulen hab ich 
schon mehrere getestet. Was mach ich falsch?

Autor: Marcus Müller (marcus67)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Was für eine Spule nimmst Du denn ? Eine Entstördrossel ?

Mehrere falsche bringen am Ende auch nichts.

Passen die Kondensatoren ?

Gruß, Marcus

Autor: Julian Asd (julian123)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Spule ist eine 220uh.
http://de.farnell.com/productimages/farnell/standa...
Der Kondensator hat 3300uf 10V  und noch ein 1 pf.
Die Schaltung funtioniert ja mit dem 1A Regler, nur mit dem 3A Micrel 
nicht und von der Pinbelegung sind die gleich.

Autor: Benedikt K. (benedikt) (Moderator)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die Spule könnte etwas klein sein, die sieht nicht wirklich nach 3A aus. 
Da diese aber einen offenen Kern hat, dürfte sie nicht in die Sättigung 
gehen.

Hast du ein Oszilloskop? Falls ja, mess mal die Kurvenformen am Ausgang 
des 2576 mit wenig und mit viel Last. Dann sollte man sehen, weshalb die 
Spannung zusammenbricht.

Autor: Michael X. (Firma: vyuxc) (der-michl)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Bei 220µH taugen die kleinen Garnrollen nicht für Ströme >1A. Hast du 
ein Oszi? Damit siehst du schnell dein Problem.

Autor: Julian Asd (julian123)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Soll ich an Pin 2 messen oder an Pin 4 und wie muss die Kurve aussehen?

Autor: Benedikt K. (benedikt) (Moderator)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
An Pin 4 sollte eine saubere Gleichspannung anliegen. Pin 2 ist 
interessanter. Falls möglich mal ein Foto davon und stells hier rein.
Die Spannung sollte mit etwa 52kHz zwischen -0,5V und Vin-1,5V pendeln 
(sauberes Rechteck).
Wie hoch ist eigentlich die Eingangsspannung?

Autor: Marcus Müller (marcus67)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Bist Du sicher, daß das eine Speicherdrossel ist ? - Sieht mir mehr wie 
eine Entstördrossel aus. Diese sind für einen Schaltregler leider 
ungeeignet. Bei kleinen Strömen spielt das keine so große Rolle - bei 
größeren schon.

Nächste Frage: Ist es ein Low ESR Kondensator ?

Gruß, Marcus

Autor: Benedikt K. (benedikt) (Moderator)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Marcus Müller wrote:
> Nächste Frage: Ist es ein Low ESR Kondensator ?

Selbst ohne Kondensator funktioniert der Stepdown Regler mehr oder 
weniger, da die in Reihe liegende Spule die Spannung (eigentlich eher 
den Strom) glättet. Es bleibt noch ein Ripple von etwa 0,3A (bei 
geratenen 15V Eingangsspannung) den der Kondensator abfangen muss. Das 
sollte jeder Elko schaffen.
Der LM2576 benötigt daher kein Low ESR Elko am Ausgang, das sagt auch 
das Datenblatt:
"Standard aluminum electrolytics are usually adequate, but low ESR types 
are recommended for low output ripple voltage and good stability."

Am Eingang sieht es dagegen anders aus, denn hier bekommt der Elko die 
volle PWM ab. Allerdings ist hier aber auch sehr viel mehr Ripple 
zulässig, wenn die restliche Schaltung damit klarkommt.

Autor: Julian Asd (julian123)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die Eingangspannung ist 12V.
Unbelastet ist das ein unsauberen Sinus.
Bei 20 ma ist das eine Mischung aus Sinus und Rechteck und bei 200 ma
(2,5 V)ist es ein unsauberes Rechteck.
Bilder mach ich noch.

Autor: Benedikt K. (benedikt) (Moderator)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Der Sinus ist das Ausschwingen da der Regler im diskontinuierlichen 
Modus arbeitet. Das ist normal.
Auf das unsaubere Rechteck bin ich gespannt.

Autor: Julian Asd (julian123)
Datum:

Bewertung
0 lesenswert
nicht lesenswert

Autor: Benedikt K. (benedikt) (Moderator)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die Schaltung ist etwas suboptimal: Die Diode sollte näher an den 2576.

Es sieht so aus, als wenn die Strombegrenzung zuschlägt, zumindest sackt 
gegen Ende des Zyklus die Spannung ziemlich ab. Allerdings begrenzt ein 
2576 meist irgendwo bei 4-7A. So sehr dürfte die Spule nicht in die 
Sättigung kommen. Desweiteren fließt der Strom ja auch in den Ausgang, 
er geht also nicht verloren.

Schalte mal 2 von den Spulen parallel (oder verwende eine andere Spule 
die mehr Strom verträgt). Ich halte es zwar für sehr unwarscheinlich 
dass die Spule in die Sättigung kommt, aber dann kann man es 
ausschließen.

Ansonsten überprüf mal die Schaltung ob da wirklich alles richtig 
verdrahtet ist.

Autor: Der Gast (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das Layout ist leider alles andere als Schaltregler tauglich.
Besonders Pin2 - Diode - Spule sollte möglichst kurz gehalten werden, 
genauso
wie die Feedback Leitung so kurz wie möglich sein sollte.

Autor: Julian Asd (julian123)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das ist nur das Testlayout. Ich hab die Diode mal weiter an den Regler 
gelötet, hat sich aber nichts geändert. Die Spulen auf dem Bild hab ich 
schon in allen erdenklichen Kombinationen zusammengelötet.
Je nach dem welche Spule ich verwende komm ich mit einigen auf 1A bei 
4,2V und bei anderen bricht die Spannung sofort auf 2,3V ein, bleibt 
dann aber bis 2A konstant. Bei über 2A bleiben noch 0V und der Regler 
Pfeift(macht er auch so)

Autor: Marcus Müller (marcus67)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Alles soweit auseinander ist sicherlich nicht gut.

Gerade der lm2576 funktioniert eigentlich hervorragend mit minimalem 
Ripple. Ich habe davon schon rund 2.500 Stück verbaut. Das ist bei uns 
allerdings ein SMD Aufbau mit rd. 15x15mm incl. Kondensatoren und Spule.

220µH erscheint mir recht groß, wir liegen bei 3.3V / 1A bei 47µH, ich 
müßte den Wert aber mal im Datenblatt nachsehen.

Ich tippe nachwievor auf ein Problem mit den Spulen. Bei 3A muß die 
ganze Dimensonierung schon genau stimmen.

Gruß, Marcus

Autor: Benedikt K. (benedikt) (Moderator)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Was mir noch auffällt: Am Eingang der Elko. Wo ist der?

Autor: Julian Asd (julian123)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Der LM2575 1A funktioniert auch auf der gleichen Platine ohne Probleme 
nur der 3A Regler will einfach nicht laufen. Zum Test wird die Schaltung 
aus einem Netzteil versorgt da sind 10000uf drin das sollte reichen.

Autor: Benedikt K. (benedikt) (Moderator)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Setz mal einen Elko direkt an den Eingang vom 2576 auf die Platine.

Autor: Julian Asd (julian123)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Danke hat funktioniert. Ich hab keine Ahnung warum, aber anscheinend 
brauch man einen Elko direkt davor.

Autor: Benedikt K. (benedikt) (Moderator)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Julian Asd wrote:
> Ich hab keine Ahnung warum,

Habe ich weiter oben geschrieben:
Der Elko am Eingang ist wichtiger als der am Ausgang, denn der Eingang 
wird nur während der Einschaltphase belastet und zwar mit dem vollen 
Strom.
Wenn da kein Elko ist, bricht die Spannung aufgrund der Induktivität der 
Zuleitung weg und das IC macht Mist.

PS: Eine ordentliche Spule solltest du dir trotzdem zulegen.

Autor: Julian Asd (julian123)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Mach ich. Das Ding wird bei 2A schon sau heiß kann man den nicht passiv 
betreiben?

Autor: Benedikt K. (benedikt) (Moderator)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Einen kleinen Kühlkörper braucht der 2576 schon für den vollen Strom. 
Bis etwa 1-2A Dauerstrom gehts auch ohne (je nach Eingangsspannung etwas 
unterschiedlich).

Autor: Marcus Müller (marcus67)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Bessere Spulen und Kondensatoren (Low ESR am Eingang) steigern den 
Wirkungsgrd erheblich und verringern die Temperatur entsprechend.

Gruß, Marcus

Autor: G_dal (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also meiner Einschätzung nach sind die von dir verwendeten Drosseln alle 
ungeigent, schauen alle aus wie Enstördrosseln mit niedriger 
Sättigungsfestigkeit.
Such dir ein passende Speicherdrossel, vorerst am Besten eine die den 
doppelten Strom aushält den du am Ausgang ziehen willst. Induktivität 
kannst du ja berechnen, oder aus dem Datenblatt entnehmen.
Durhc auswählen der richtigen Drossel kannst du wahrscheinlich momentan 
recht exzessive Rippleströme eindämmen die zu starker ERwärmung im 
SChaltregler führen.

Autor: Julian Asd (julian123)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Der Regler soll später ein Atom 330 1,6Ghz versorgen.
Brauch ich unbedingt low ESR Kondensatoren und welche Spule ist gut für 
den Regler. Bis jetzt hab ich nur so ein SMD Teil gefunden und SMD 
wollte ich eigentlich nicht verbauen.

Autor: Michael X. (Firma: vyuxc) (der-michl)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Julian Asd wrote:
> Der Regler soll später ein Atom 330 1,6Ghz versorgen.
Nee, oder? Für den Core brauchst du IMVP-6, für die 1,05Vtt reichen 1A.
Mach ein ordentliches Design, ohne gute Versorgung baust du eine 
Standheizung.

Autor: Benedikt K. (benedikt) (Moderator)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Julian Asd wrote:
> Brauch ich unbedingt low ESR Kondensatoren und welche Spule ist gut für
> den Regler.

Bedrahtete Spulen (außer bei Ringkern) sind zunehmend am Aussterben.
Geeignet wäre z.B. die L-PISR 100µ von Reichelt. Diese kann 3A, was 
etwas grenzwertig ist, da der 2576 durchaus auch mal 5A liefern kann.

Eine Spule mit mehr Induktivität verkleinert den Stromripple, was 
kleinere Elkos am Ausgang erlaubt. Allerdings wird die Spule dann 
größer. Eine kleine Spule vergrößert den Stromripple, weshalb am Ausgang 
Low ESR Elkos sinnvoll sind.
Wenn der Spannungsripple am Ausgang nicht extrem kritisch ist, reichen 
aber meist normale Elkos (vor allem wenn man 2-3 parallel schaltet).

Autor: Pieter (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
moin moin,

oder man nimmt besser den LM2675, der arbeitet mit 260KHz und hat 
DMOS-Schalter und kleinere Spule und...und...und
Layout muss aber auch stimmen, ist im Datenblatt angegeben.

Autor: Julian Asd (julian123)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Natürlich nicht für die CPU sondern für das ganze Board. :)

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.