mikrocontroller.net

Forum: PC Hard- und Software Raid bauen mit LSI Controller


Autor: Verwirrter (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Leute!
Ich will mir ein Raidsystem aufbauen allerdings verwirrt mich das 
LSI-Menü.
Es soll ein Raid 10 werden also aus 4 identischen platten, leider 
verwirrt mich jetzt das Menü und das Handbuch da hier immer von IM oder 
IME-Drive gesprochen wird, im Handbuch steht dann auch immer was von 
Hot-Spare was ich aber nicht will, ich will einfach nur ein simples Raid 
10, mehr nicht.
Kann mir da einer sagen wie ich das dem Controller beibringen kann?
Habe leider noch keine gescheite deutsche Dokumentation gefunden die ich 
auch raffe.

Vielen Dank schonmal.

Autor: Verwirrter (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Oder muss ich erst zwei Raid1 erstellen und mit denen dann ein Raid0 
bauen?
Bräuchte da allerdings erstmal ne Meinung dazu da ich jetzt nicht 50 mal 
die kiste hoch und runterfahren will da ich im moment keinen Zugang zu 
nem 2ten PC hab.

Autor: Verwirrter (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hat sich erledigt, try and error hat geholfen...

Autor: Verwirrter (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Update:
Ist das normal das ein Raid1 bzw. 10 so lahm beim schreiben ist?
Ist der Controller Kac*e oder was? ich mein 200Gb in 20h sind schon ein 
bissl lahm oder?

Autor: Peter (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
welchen Controller hast du denn?

Autor: Verwirrter (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das ist so ziemlich das billigste was ich mir leisten konnte :-)
Ein gebrauchter LSISAS3041e von egay inkl. 4x 500Gb SATA Platten.
Habe schon den Verdacht das mich der Verkäufer beschi**en hat.

Autor: Bernd (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wow,

nach "nur" 4 Beiträgen von dir wissen wir jetzt "schon" um welchen 
Kontroller es sich handelt. Vieleicht wäre der Herr so freundlich und 
mal zu schreiben um welche Platten es sich handelt, wie er das ganze 
Konfiguriert hat und wie er die Performance gemessen hat ?

Bernd

Autor: Verwirrter (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ja ok ich hätte nen bisschen mehr schreiben können.
Controller ist ja jetzt klar.
4x Samsung HD501LJ als Raid10 konfiguriert
MB ist ein Asus A8N-SLI
Laut SisoftSandra hat das Array ein Leserate von durchschnittlich 
103Mb/s
Schreiben tut es nur mit knapp 25Mb/s was ich sehr langsam für ein 
Raid10 finde.
Wenn ich unter Windows Daten kopiere kommt es mir subjektiv noch 
langsamer vor. Schreibcache ist aktiviert.

Die Festplatte von der ich lese ist auch eine HD501LJ (Kein Raid, hängt 
am normalen Satacontroller vom Mainboard, schafft knapp 64Mb/s lesen)

Falls noch Irgendwelche infos fehlen sollten bitte bescheid geben.

Autor: Bernd (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Moin,

versuch doch mal jeweils ein RAID-0 und ein RAID-1 anzulegen und zu 
schauen wie es da mit der Schreib- und Lese-Performance aussieht.

Bernd

Autor: PC "Fuzzi" (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Bend:
Ok aber hast du nach dem "konstruktiven" Beitrag auch solche Antworten?

Autor: Verwirrter (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Habe ich auch schon versucht. Macht aber keinen Unterschied.

Autor: Bienenwachs (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Unter manch einem Betriebssystem, beispielsweise unter dem guten alten 
Windows 98, lässt sich im Gerätemanager einstellen, ob DMA verwendet 
wird oder nicht. Standardmässig ist es deaktiviert. Schaltet man es ein 
wird es ... schneller.

Autor: Bernd (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ok, wenn die Performance unter RAID-0 und RAID-1 schon genauso schlecht 
ist dann wäre es sehr verwunderlich wenn sie unter RAID-10 besser wäre. 
Hast du mal versucht den Kontroller unter Linux zu verwenden ? Laut 
Handbuch basiert den Kontroller auf LSI Fusion MPT und dafür gibt es 
einen Treiber im Linux Kernel.

Bernd

Autor: Verwirrter (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das müsst ich mal versuchen, muss aber erst ubuntu oder so installieren, 
kann also was dauern da ich grad wenig zeit habe. Allerdings möchte ich 
das teil ja unter Windoof verwenden da bringt es mir dann leider auch 
nicht viel wenn es unter linux läuft... komisch das.

Autor: ... (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wenn ich das richtig sehe ist das eine PCIe x4 Karte. Nur hat das 
Motherboard gar keinen passenden Slot dazu. Wo hast Du das Teil denn 
reingesteckt?

Autor: Verwirrter (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Steckt im zweiten PCIe 16x Slot welcher aber nur mit 8x betrieben wird 
weil die Grafikkarte auch noch 8 Lanes braucht und der Chipsatz nur 16 
insgesamt für die beiden 16x Slots hergeben kann
(ist eines der ersten SLI-boards wo man noch so ne kleine Platine auf 
dem board umstecken muss um den zweiten 16x Slot nutzen zu können)

Autor: ... (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Dann läuft der Controller mit ziemlicher Sicherheit nur mit einer Lane. 
War letztens erst ein Artikel drüber in der c't. Von den Daten her 
sollte das eigentlich trotzdem noch reichen, aber was der 
Treiber/Controller/Chipsatz dabei macht ist eine ganz andere Frage.
Wir hatten ein ähnliches Problem mit einem 64bittigen Adaptec SCSI Raid 
Controller, der in einem 32bit Slot steckte. Funktioniert hats, aber 
trotz  schneller SCSI Platten eine Performance jenseits von Gut und 
Böse. Selbst die auch noch vorhandene alte 40GByte IDE Platte war 
schneller. Ein ebenfalls 64bittigen LSI Controller im selben Slot lief 
dagegen mit voller Geschwindigkeit.

CU

Autor: Verwirrter (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das eigenartige ist aber das das Teil mit nem Mordstempo lesen kann, nur 
beim schreiben krückt das teil eben rum, das raff ich einfach nicht.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.