mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Phasenanschnittssteuerung - Tiny2313


Autor: TriacZünder (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

zum Ausprobieren und Spielen will ich eine Phasenanschnittssteuerung 
basteln.

Ich bin mir der Gefahr, die von 230 V ausgeht, voll bewusst. Mein 
Arbeitsplatz ist durch Trenntrafos und Isolation geschützt.

Weil meine Steuerung später einfach nur in einem gewissen Rhytmus 
blinken soll (ohne dass ein Mensch auch nur in die Nähe kommt), brauche 
ich auch keine galvanische Trennung.

Ich habe die Schaltung wie im Anhang zu sehen aufgebaut.

Hat alles gut funktioniert (Die Zündsignale für den Triac habe ich 
testweise auf die halbe Amplitude gesetzt), bis ich die Glühbirne an den 
Ausgang angeschlossen und "Leitung A" verbunden habe. (Die hatte vorher 
für die ersten Tests ausgelassen.)

Kleines Bruzeln, größere Rauchwolke. Jetzt habe ich zwei halbe Tiny2313.

Ich frage mich aber, warum. Das Beinchen an INT0 am Sockel ist leicht 
angeschwärzt, scheinbar hat es da gebruzelt. Dort ist auch der Prozessor 
auseinander gebrochen.

Woran mag das liegen?

Ich weiß, in der Application Note zum Zero Cross Detector war auch noch 
ein 1M-Widerstand zwischen N und GND des Prozessors, auf den habe ich 
verzichtet, damit ich den Triac auch zünden kann.

(Wer mir nicht helfen mag, brauch es nicht zu tun. Den bitte ich aber, 
einfach nichts zu schreiben.)

Autor: Matthias Lipinsky (lippy)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Woran mag das liegen?

Ein Triac wird zwischen GATE und A1 angesteuert. Das ist, in deinem 
Schaltplan der untere Anschluss.

Also passiert folgendes, sobald die Glühlampe an den unteren beiden 
Anschlüssen ist:

Über dem Triac liegen 230V. Da aber der A1 nicht an GND von µC liegt, 
bekommt der volle 230V...

Autor: Christian Erker (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ev. geht etwas über den Triac schief, das muss ich mir aber genauer 
ansehen noch ..

Schnellschuss: Was hast du für R2 genommen? Übliche 1/4W-Widerstände 
oder SMD Widerstände sind oft nur 100-200 V spannungsfest und schlagen 
ev. über in dieser Schaltung (Spitzenspannung 325V).

DAs es erst nach Anschluss der Lampe schiefging, kann je nach 
vorhandenen Induktivitäten etc. auch durch Schaltspitzen verursacht 
worden sein.

Für eine Blinkschaltung würde ICH die Nullspannung auf der Sekundärseite 
des  Trafos messen (soooo verschoben ist das nicht, unkritisch bei fast 
rein ohmschen Glühbirnen) und das Triac mittels Optokoppler zünden.

Gruß,
Christian

Autor: Christian Erker (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Ein Triac wird zwischen GATE und A1 angesteuert. Das ist, in deinem
>Schaltplan der untere Anschluss.

>Also passiert folgendes, sobald die Glühlampe an den unteren beiden
>Anschlüssen ist:

>Über dem Triac liegen 230V. Da aber der A1 nicht an GND von µC liegt,
>bekommt der volle 230V...

Das kam mir auch seltsam vor, darum schrieb ich auch, ich muss mir das 
nochmal ansehen. Der Triac gehört aber in die andere Leitung, ja.

Gruß,
Christian

Autor: Klaus2 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
...und um das ganze etwas gescheiter zu machen, würd ich mal nen 
optoisolator welcher form auch immer empfehlen! natürlich ohne ZCD :)

Klaus.

Autor: TriacZünder (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Mh, ja, den Triac hat es wohl auch zerschossen, habe den gerade mal 
durchgemessen, hat in alle Richtungen so ca 60 Ohm.

Aber wie hätte ich den sonst verbauen sollen?

A1 an den unteren Eingang (der auch an Trafo 2 und 4 angeschlossen ist) 
und A2 Richtung Glühbirne?

Autor: Matthias Lipinsky (lippy)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
>Aber wie hätte ich den sonst verbauen sollen?


Ich hab mal ein ZweiKanal Dimmer so aufgebaut.

Vielleicht kannt du dir paar Anregungen holen.

Autor: TriacZünder (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Ja, Danke.

Den "Trick" mit den Optotriacs habe ich auch in diversen Application 
Notes gesehen.

Aber wie schon geschrieben, ich dachte eigentlich, ich käme auch ohne 
aus...;-)

Ich sehe schon, warums dann wohl gekracht hat. Scheinbar habe ich beim 
Aufbau stumpf den Triac in die falsche Leitung gesetzt.


Dann müsste es doch aber wie angehängt funktionieren, oder?

Autor: Matthias Lipinsky (lippy)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Vor das GATE des Triacs gehört auf alle Fälle ein Widerstand. Der 1M ist 
ja nur zur Strombegrenzung bei der Nulldurchgangserkennung.

Und kleiner Tip: An jedes Pinpaar der µC für die Betriebsspannung gehört 
ein 100nF Kondensator. So nahe wie möglich dran.

Autor: TriacZünder (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Stimmt, ich werde da 470 Ohm einsetzen (gibt bei 5 V etwas mehr als 10 
mA, reicht nach DB zum Durchschalten).

Den 100nf werde ich auch hinzufügen, aber das Fehlen hat ja mit dem 
Durchbrennen nichts zu tun...

Autor: TriacZünder (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ups, naja, Bild hat sich nicht verändert, wollte es gar nicht ein 2. Mal 
hochladen, sorry.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.