mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik LED-Booster (Zetex ZXSC310) komplett abschalten


Autor: Tobias John (tobiasjohn) Benutzerseite
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo zusammen,

ich habe einen ZXSC310 in einer Batterie-betriebenen Schaltung verbaut.
Betrieben werden soll eine Hintergrundbeleuchtung von einem LCD-Display.

Nun ist mir aufgefallen, dass die Schaltung immer noch 30mA zieht obwohl 
ich STN (Shutdown) vom Zetex auf Low liegen habe. Die 
Hintergrundbeleuchtung ist dann nur noch schwach beleuchtet, da der 
ZXSC310 natürlich nicht mehr arbeitet.

Jetzt habe ich mir Gedanken gemacht wie ich die Hintergrundbeleuchtung 
komplett abschalten kann.

Im Anhang befindet sich eine Schaltung mit der Idee.

Könnte das so gehen oder gibt es eine bessere Möglichkeit den Zetex 
ZXSC310 komplett mit der Hintergrundbeleuchtung abzuschalten?

Gruß,
 Tobias

Autor: Tobias John (tobiasjohn) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Push...

Autor: was-willst-du (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
pop


Welchen Strom nimmt denn die ganze Schaltung auf, wenn Du die Led 
einfach nicht anschließt? Mach doch das zuerst, bevor Du die 
Komfortabschaltung einbaust.

Autor: Falk Brunner (falk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Tobias John (tobiasjohn)

>Nun ist mir aufgefallen, dass die Schaltung immer noch 30mA zieht obwohl
>ich STN (Shutdown) vom Zetex auf Low liegen habe.

Dann hast du irgendwo einen Fehler, Hardware oder Software.

>Im Anhang befindet sich eine Schaltung mit der Idee.

Mach es richtig über das Shutdown Pin. Alles andere ist Murks.

MFG
Falk

Autor: Tobias John (tobiasjohn) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Falk Brunner wrote:
> @Tobias John (tobiasjohn)
>
>>Nun ist mir aufgefallen, dass die Schaltung immer noch 30mA zieht obwohl
>>ich STN (Shutdown) vom Zetex auf Low liegen habe.
>
> Dann hast du irgendwo einen Fehler, Hardware oder Software.
>
>>Im Anhang befindet sich eine Schaltung mit der Idee.
>
> Mach es richtig über das Shutdown Pin. Alles andere ist Murks.
>
> MFG
> Falk

Aber wenn ich mir die Schaltung ansehe, dann ist es doch klar, dass 
immer 30mA fließen...

Wenn der ZXSC310 nicht aktiv ist (STDN Low) dann liegen doch immer noch 
3V an der Spule, somit auch 3V an der Diode, da fallen dann ca 0,2V ab 
und dann liegen immer noch 2,8V an den LEDs, was der Grund für die 30mA 
sind...

Wie soll ich das nur mit dem ZXSC310 verhindern?
Die Schaltung ist korrekt, schau mal ins Datenblatt vom ZXSC310...

Gruß,
 Tobias

Autor: Winfried (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Schalte doch die 3 LEDs in Reihe anstatt parallel. Dann sollte das 
Problem gelöst sein.

Autor: Tobias John (tobiasjohn) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Na auf die Idee hätte ich auch kommen können :D

Danke für den Hinweis, das dürfte das Problem tatsächlich lösen!

Ich werde es gleich mal ausprobieren...

Gruß,
 Tobias

Autor: Tobias John (tobiasjohn) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Ich werde es gleich mal ausprobieren...

Wunderbar!
Es klappt... eine einfache Lösung ist manchmal einfach zu naheliegend :D

Gruß,
 Tobias

Autor: Falk Brunner (falk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@  Tobias John (tobiasjohn)

>Na auf die Idee hätte ich auch kommen können :D

Und wer LEDs so einfach parallel schaltet MUSS bestraft werden . . .

Autor: Tobias John (tobiasjohn) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Falk Brunner wrote
> Und wer LEDs so einfach parallel schaltet MUSS bestraft werden . . .

Dann musst du die Entwickler von Electronic Assembly bestrafen und nicht 
mich... :D
Schau mal ins Datenblatt eines EA DIP128-6 - Displays vom besagten 
Hersteller.
Da sieht man klar und deutlich, dass die LEDs parallel geschaltet sind - 
daran kann ich nichts ändern!

Gruß,
 Tobias

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.