mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Temperaturübertragung


Autor: LinkinPark (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich habe ein Problem mit einem NTC. Und zwar will ich mit einem NTC die
Temperatur eines Passivkühlkörpers messen. Eigentlich habe ich mir das
ganz einfach vorgestellt, ich wollte in einen Alublock ein Loch Bohren
und da dann den NTC mit Wareleitpaste versehen reinstecken, und den
Alublock dann auf den Kühlkörper schrauben. Dadurch habe ich mir eine
relativ genaue Messung gewünscht da ich dachte dass durch die große
Auflagefläche des Aluminiums die Temperatur gut auf den NTC übertragen
wird. Nun habe ich aber leider festgestelt das an dem Kühlkörper ca.
100V gegen Masse anleigen welche dem Microcontroller, speziell dem
AD-Wandler, nicht sehr zusagen. Wie kann ich eine möglichst gute
Temperaturübertragung bei keiner Stromleitfähigkeit erreichen ?

Vielen Dank schon mal

Autor: Gerhard Gunzelmann (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo LinkinPark

glaubst Du nicht, daß es erst mal besser wäre, die 100 Volt von Deinem
Kühlkörper wegzukriegen ? Haste die Halbleiter da ohne Glimmerscheiben
draufgeschraubt ? Für Deine eigene Sicherheit und auch Deiner Schaltung
wäre ne Isolierung nicht schlecht. Und was die genaue Messung
anbelangt, da ist eigentlich ein NTC nicht so gut geeignet, schon mal
weil er alles andere als linear ist.

Gerhard

Autor: LinkinPark (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ja mir würde es auch besser gefallen wenn der Kühlkörper keine 100V
hätte. Leider kann ich dagegen nichts machen da es sich um ein
PC-Netzteil handelt.

Autor: Gerhard Gunzelmann (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi

ah so, dann sind das keine 100 Volt DC, sondern wohl 115 Volt AC und
kommt durch Entstörbauelemente zustande. Na ja, wenn Du aber einen
Temperaturfühler nimmst und ihn gut isolierst und dann die Eingänge an
Deinem uC mit Zenerdioden schützt müßte das eigentlich gehen, denn ich
meine daß diese 100 Volt (wie auch immer) hochohmig sind, unb bei
Belastung leicht zusammenbrechen. Man könnte natürlich auch mit einem
Isolationsverstärker arbeiten oder mit einem berührungslosen Sensor,
der macht die Sache aber teuer.

Gerhard

Autor: LinkinPark (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ja 100V AC sind da ungefähr drauf. Ich dachte auch schon mal dass die
wohl leicht zusammenbrechen und ich den Kühlkörper mal einfach auf
Masse leg ? Ist das zu empfeheln ?

Autor: Gerhard Gunzelmann (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo

also ich bin in so einem Fall feig. Empfehlen würd ich das sowieso
nicht. Vielleicht kannst aber mal nen Widerstand nehmen. so 10Kohm am
Kühlkörper - gegen Masse/Schutzleiter (Gehäuse) und dabei die Spannung
messen. Wenn die Spannung unter 2 Volt fällt kannste ja so weitermachen
mit Deinem NTC, aber wie gesagt, rein aus dem Bauch raus hätte ich
jetzt bedenken den Kühlkörper direkt mit dem Schutzleiter zu verbinden.
Vielleicht liest dies hier ein Spezialist und gibt noch seine Meinung
dazu.


Gerhard

Autor: LinkinPark (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
OK Danke werd ich wie beschrieben versuchen

Autor: Peter Dannegger (peda)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
"Ich dachte auch schon mal dass die
wohl leicht zusammenbrechen und ich den Kühlkörper mal einfach auf
Masse leg ?"

Je nach Netzsicherung (16A ?) brechen sie zusammen. Gleichzeitig geht
die Raumbeleuchtung aus und Du kannst schon mal ein neues PC-Netzteil
bestellen.

Sicherheitshalber aber vorher den Feuerlöscher griffbereit halten.


Netzspannung ist kein Spielzeug !!!


Peter

Autor: LinkinPark (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das Licht blieb an. Das ist extra abgesichert.

Autor: LinkinPark (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Nein im erst. Habe das natürlich nicht ausprobiert sondern habe den NTC
jetzt mal mit einem Schrumpfschlauch isloiert an den Kühlkörper
geschraubt. Jetzt habe ich 100% keine Verbingung mehr zu den 100V nur
der Atmel mist noch nicht richtig da die Temperatur im sekundentakt
zwischen 18 ung 38 Grad pendelt was doch sehr unwahrscheinlich ist.
Woher kommt das ?

Autor: BKD (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hallo,

Welchen AD-Wandler hast du eingesetzt (bzw die bit Auflösung)?
Mit welcher Ref Spannung betreibst du die Messung?
Hast du den Fühlerwert per Software oder Hardware Linear gemacht?

Ich habe mal das gleiche gebaut.. Verwendet habe ich nen Atmel2051,
ADS7823,LM35CY und einer ref. Spannung von 2.5V (UB/2) Das ganze konnte
ich dann über die RS232 Abfragen (War auf ca.1,2mV genau--LM35 macht
bei 1C --> 10mV).

Heute würde ich nen IIC Temp-Fühler einbauen!

Autor: ulrich strobel (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
pt 100 oder pt 1000 das beste was es gibt. durch die isolierung hast du
aber einen erhöhten wärmewiderstand, und vor allem eine höhere
wärmekapazität was den Messaufbau ohnehin schon sehr ungenau macht; den
wäremefühler nur mittels Glimmerscheibe zu Isolieren und dann auf oder
gegen den Kühlkörper zu kleben oder pressen scheint mir da sinnvoller,

oder richtig lumpig geizig genau, auf das Kunststoffgehäuse des
Transistors kleben, das hat ja exakt die zu messende Temperatur
(natürlich nur ist das jetzt nur zu prüfzwecken geeignet!!; keinesfalls
rückartige Bewegugen) könnte sich dann sogar mit der Wärmekapazität zu
deinem Meßpunkt mehr als gutstellen.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.