mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik Pspice Probleme mit der Schaltung


Autor: Alex (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo PSpice Experten.

Ich habe ein Problem mit der Simulation meiner Schaltung. Eigentlich 
baue ich einen Schmitt Triger mit einer Hysterese. Dabei verwende ich 
einen LT6221 OP. Die Schaltung habe ich richtig aufgebaut und Modell für 
6221 eingebunden, siehe Anhang. Nun wenn ich an –IN einen Dreieck( 
T=10us) gebe, schaltet mein Komparator gar nicht. Am ausgang habe ich 
stets 5V. Ich weiss, dass es falsch ist, da ich die Schaltung schon 
aufgebaut habe. Und diese funktioniert selbsverständlich auch bei 
100KHz. Voran könnte es liegen, dass die Simulation nicht funktioniert? 
Auch die anderen OPs von LT(Bibliotheken hatte ich mit PSpice) schalten 
nur bei kleinen Frequenzen.

Pinbelegung des Modells:
Node List: IN+(3) IN-(2) VCC(7) VEE(4) OUT(6)

Die Simulation brauche ich dringend, da mein ganzes Projekt davon 
abhängt. Danke in Voraus.

Alex

Autor: Alex (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hier is meine Schaltung

Autor: flätz (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Pulsweite PW=1ns? Kein Wunder dass da nichts von zu sehen ist.

Autor: HildeK (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
>Pulsweite PW=1ns? Kein Wunder dass da nichts von zu sehen ist.
Das ist kein Problem - das gibt fast ein ideales Dreieck - eben mit 1ns 
Dach und unten fehlt sie dann. Die Rise- und Falltime von 5µs machens 
aus ....

Ich habe das auf die Schnelle mit LTspice simuliert - da funktioniert es 
prächtig. Ich vermute mal, die Einbindung in dein Spiceprogramm ist 
nicht korrekt.

Autor: flätz (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ach ja, auf TR und TF habe ich gar nicht geachtet:)
Könnte sein, dass das Pinout vom LT6221 durcheinander geraten ist? Das 
Einbinden von Modellen in ORCAD/PSPICE ist leider immer wieder eine 
Tortur besonderer Art:(

Autor: HildeK (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Ach ja, auf TR und TF habe ich gar nicht geachtet:)
Nein - die sind schon richtig. Ein durchaus gutes Signal, um einen 
Komparator zu testen. Ich hatte genau deine Daten eingegeben und das 
gibt das rote Dreiecksignal in meiner Simulation.

Autor: HildeK (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Oh, sorry flätz. Ich bin zu schnell gewesen und hatte deinen Kommentar 
als einen von Alex angeschaut. Ich kann ja nicht editieren ....

Autor: Felix Nachname (time2ride)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Probier mal überall Junctions zu setzen, bei PSpice sind Pins manchmal 
nicht verbunden, auch wenn es so aussieht.

Autor: Alex (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Danke erstmal für die zahlreichen Antworten

Hmm,
also ich vermute auch, dass ich PSpice model falsch eingebunden habe. 
Eigentlich habe ich auf der LT webseite Modelltext in eine lt6221.lib 
Datei gespeichert und diese dann mit PSpice Modell Editor in eine OLB 
umgewandelt. Auch habe ich in der Simulations Settings Libreris  die 
lt6221.lib eingebunden. Mehr brauche ich doch nicht zu machen, um den 
OPV zu verwenden?

Ich habe versucht eine fertige OLB für 6221 im Internet zu finden, 
leider ohne Erfolg.

Autor: flätz (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe das jetzt selbst mal getestet, und kann das Problem von Alex 
leider bestätigen. Der OP wird in PSPICE sehr langsam. Flanken mit 500us 
funktionieren, solche mit 50us anscheinend auch gerade noch.
Wenn man die Simulationsoption "Skip the initial...bias point 
calculation" aktiviert, erhält man immerhin 2 mehr oder weniger falsche 
Perioden.
Anscheinend sind die Simulatoren doch unterschiedlich gestrickt. 
Auffällig ist z.B., dass im Modell der Punkt 0 verwendet wird. Dieser 
ist leitend mit dem Punkt 0 der Schaltung verbunden, ohne dass ein Pin 
vorhanden ist. Als weiteres taucht ein Kondensator mit C=1mF auf.
Wie dem auch sei, um das Problem zu lösen müsste man wohl mal das ganze 
Modell aufdröseln:(

Autor: Michael (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Klingt fast so als seien im Modell die Knotennummer gleich bezeichnet 
wie die "externen" Knotennummern. However, wird wohl nix anderes übrig 
bleiben als das Modell aufzudröseln.

Autor: Alex (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Verstehe ich richtig. LT stellt ein nichtlauffähiges Modell ins 
Internet? Weil ohne Vorkenntnisse ich kein Modell auflösen kann.

Autor: flätz (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Nein, das Modell funktioniert in LTSPICE. Die Simulation ist sogar in 
Bruchteilen von Sekunden fertig, während PSPICE minutenlang rumrödelt. 
Leider sind die Simulationsergebnisse völlig unterschiedlich, und im 
Moment fehlt eine passende Erklärung dafür.
Könntest Du nicht einfach in LTSPICE weitermachen? Die Einarbeitung geht 
wirklich fix.

Autor: Alex (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ich habe heute die Schaltung in LTSPICE simuliert. Leider stimmen die 
Simulieten Ergebnisse mit der Realität nicht. Wenn ich die Widerstände 
verändere, wird die Hysterese nicht kleiner/größer. Das ist natürlich 
falsch. Auch die Schaltung, die ich heute aufgebaut habe, vehält sich 
ein wenig anders!!!

Autor: flätz (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Naja, für den ST-Betrieb ist der OP auch sicherlich nicht gedacht. Das 
kann schon sein, dass das Modell da nicht mehr realistisch ist. 
Vielleicht könntest Du für Deine Simulation ja einen anderen OP, oder 
besser einen echten Komparator verwenden?
Leider kann ich Dir mit dem Modell jetzt auch nicht weiterhelfen. Der 
Grund für das Versagen in PSPICE interessiert mich aber auch.

Autor: HaJo42 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Interessanterweise ist das LT6221 (alias LT6220) Model, das mit 
LTSpiceIV mitkommt (in der Datei LTC4.lib) ein anderes als das, was man 
direkt von der Linear-Webseite herunterladen kann. Das von der 
Linear-Webseite enthält dem Kommentar [Spice2], und könnte vielleicht 
veraltet sein.

Autor: HaJo42 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ach, vergessen: Den Glauben, dass Simulationsergebnisse mit der 
Wirklichkeit übereinstimmen, sollte man ablegen. Wenn's halbwegs in die 
richtige Richtung geht ist es ein guter Tag.

Autor: flätz (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Interessanterweise ist das LT6221 (alias LT6220) Model, das mit
> LTSpiceIV mitkommt (in der Datei LTC4.lib) ein anderes als das, was man
> direkt von der Linear-Webseite herunterladen kann. Das von der
> Linear-Webseite enthält dem Kommentar [Spice2], und könnte vielleicht
> veraltet sein.

Auwaia, genau das wars! Das Modell aus LTC4.lib funktioniert auch in 
PSPICE. Besten Dank an HaJo42 für die Lösung des Rätsels!

Autor: Michael (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Wenn's halbwegs in die
>richtige Richtung geht ist es ein guter Tag.

Wenn es nicht halbwegs in die richtige Richtung geht ist entweder der 
Simulator murks und/oder das Modell für die Tonne. Jedes 
Simulationsergebnis sollte hinterfragt werden ob es denn auch sein kann 
;)

Autor: HaJo42 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Auwaia, genau das wars!

Schon eine anständige Anschiss-Mail an Linear gesendet?

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.