mikrocontroller.net

Forum: Platinen EAGLE-Problem mit SMD-Schaltkreis


Autor: Paul Baumann (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe mich eben zum ersten Mal daran versucht, einen SMD-Schaltkreis
mit bedrahteten Bauelementen zu verbinden. Dazu habe ich den Schaltkreis
gespiegelt, so daß er auf der Leiterseite zu liegen kommt. (Bottom)
Die angehängte Schaltung hat keinen Nährwert, -sie dient nur zur 
Verdeut-
lichung des Problems.

Leider ist es mir weder "von Hand" noch mit dem Autorouter möglich,
die Verbindungen zwischen dem Widerstand und dem Schaltkreis zu
zeichnen. Es bleiben die Luftlinien.

Offenbar ist der Schaltkreis nicht im Raster, aber auch ein Verändern 
des Rasters auf 0,1 Mil ergab keine Besserung.

Mit SMD-Kondensatoren (0805) in Verbindung mit bedrahteten Bauelementen
hingegen hatte ich noch nie Schwierigkeiten.

(Eagle-Version 4.15)

Frage: Was kann ich tun, um den Kollegen Schaltkreis zur Mitwirkung zu
überreden? ;-)

Ratlos
Paul

Autor: was-willst-du (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hast Du jemals schon mit Eagle gearbeitet ?

Es geht einwandfrei. So wie in Eagle halt Leiterbahnen gezogen werden.

Lese das Manual und alles wird gut.

Autor: Paul Baumann (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ja, Meister, ich habe nicht nur "jemals" sondern seit Jahren mit Eagle
gearbeitet. Nur dieses o.g. Problem hatte ich noch nie, weil das der
erste Versuch mit einem SMD-Schaltkreis war.

Solche Tips kannst Du Dir in eine Körperöffnung Deiner Wahl schieben!

...und noch Eines: Es heißt: "Lies das Manual".

:-(
Paul

Autor: Christian L. (lorio)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo, Paul!

Also bei mir geht es. Du musst dementsprechend die Leiterbahnen auch auf 
dem Bottom-Layer routen.

Gruß
Christian

Autor: Torben (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das Problem ist dein Rastermass. SMD Bauteile haben ein anderes 
Rastermass als die THD Bauteile in Eagle. Änder das Rastermass oder 
beginne vom IC aus zu routen. Mit der ALT Taste (gedrückt halten) kannst 
Du das zweite Rastermass aktivieren.

Autor: was-willst-du (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Naja ich weiß gar nicht welchen Tip ich Dir geben sollte.

Ich pack einfach die Luftlinie und verleg sie. Das Problem liegt somit 
wohl nicht in Deinen Files, sondern vermutlich woanders.

Das Raster spielt beim Verlegen keine große Rolle, vom nähesten 
Rasterpunkt zum Anschlußpunkt auf dem Bauteil legt Eagle selbständig.

Welche Vorbildung Du besitzt, geht aus Deinem ersten Beitrag nicht 
hervor.

Vielleicht bist Du auf dem falschen Layer?

Autor: Paul Baumann (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Christian und Torben
Ich danke Euch erst mal für die Ratschläge. Leider ist das Ergebnis das
Gleiche wie vorher. Ich habe es mit Rastern von 0,1mil, 1mil, 10mil
versucht. Auch das Drücken der ALT-Taste während des Zeichnens läßt, 
wenn
ich auf danach "Luftlinien berechnen" gehe, diese nicht verschwinden.
Wenn ich den Schaltkreis "anfasse" und verschiebe, sehe ich, daß keine
Verbindungen bestehen.

Wenn es diesen ver..xxx.ten Schaltkreis als DIL gäbe, wäre das
Problem gelöst. ;-)

MfG Paul

Autor: Paul Baumann (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe noch einen 2.Versuch angehangen. Wie man sieht, klappt das 
Routen
von SMD-Kondensatoren und bedrahtetem Widerstand. Das Raster beträgt 
25mil
und die Schaltkreise liegen darauf richtig. Um sicher zu gehen, daß es 
nicht
an dem Schaltkreis selbst liegt, habe ich noch einen weiteren eingefügt.
Auch dieser zeigt keine Neigung, sich von seinen Luftlinien zu verab-
schieden. Die Brücke unter dem 16-poligen Chip habe ich von Hand mit 
"Wire"
gezeichnet, aber auch die hat keine Verbindung zum Chip.

So Etwas ist mir noch nie passiert...
Kopf kratz
Paul

Autor: Paul Baumann (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe das Problem gefunden:
Im Autorouter war als "Routing Grid" 50mil eingestellt. Es müssen aber
25mil sein, dann geht es.

Trotz Monolog: Danke an alle Helfer, jetzt auch an "Was-wilst-Du", 
dessen
2.Antwort vernünftig war.

MfG Paul

Autor: Christian L. (lorio)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Könnte sein, dass du statt ROUTE den WIRE-Befehl nimmst?

Autor: was-willst-du (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Sieht so aus. Das erklärt auch, warum das Raster wichtig sein soll.

Beim Route-Befehl ist das Raster nämlich nicht wichtig.

Autor: Sven P. (haku) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Christian L. wrote:
> Könnte sein, dass du statt ROUTE den WIRE-Befehl nimmst?

Glaub ich auch, Drahtbrücken setzt man nämlich normalerweise auch nicht 
von Hand.

Autor: was-willst-du (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das liebe ich hier so.

groß tönen
>Ja, Meister, ich habe nicht nur "jemals" sondern seit Jahren mit Eagle
>gearbeitet

leicht ausfallend werden
>Solche Tips kannst Du Dir in eine Körperöffnung Deiner Wahl schieben!

sich mit irgendeiner Lösung zufrieden geben
>Im Autorouter war als "Routing Grid" 50mil eingestellt. Es müssen aber
>25mil sein, dann geht es.

ob er den wahren Grund für die Fehlbedienung je erfahren wird?
> Könnte sein, dass du statt ROUTE den WIRE-Befehl nimmst?

Frohe Ostern!

Autor: Paul Baumann (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich benutze den Route-Befehl (links in Werkzeugleiste). Aus lauter
Verzweiflung habe ich es dann nur einmal probeweise mit "Wire" versucht.
Wire verwende ich normalerweise nur, um Umrisse zu zeichnen.

Es ging mir hauptsächlich darum, herauszufinden, warum es mit dem
Autorouter nicht funktionierte. Ich habe schon oft SMD-Kondensatoren
benutzt, nie gab es Probleme. Heute wollte ich das erste Mal in meiner
Eagle-Laufbahn einen SMD-Schaltkreis benutzen. Als das nach mehreren
Stunden nicht gelang, und sowohl das Handbuch als auch die Suche
im Forum von Cadsoft erfolglos waren, habe ich mich erdreistet, hier
zu fragen.

Also dann: Danke Euch noch einmal und eiert nicht so herum wie ich. ;-)

Zitat aus "Rambo, der beste Koch der Welt"
Mache Eier!

MfG Paul

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.