mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik Triac oder MOC brummt


Autor: Mathias O. (m-obi)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Guten Morgen,

ich habe eine Phasenanschnittssteuerung für einen Dimmer gebastelt. 
Nulldurchgangserkennung, µC und Phasenanschnitt funktioniert alles 
super. Nur jetzt brummt was, entweder der Triac oder der MOC, eine 
Drossel hab ich erstmal weggelassen. Aber es kommt noch eine rein. Ich 
hab verher schonmal probiert mit Drossel, aber es brummt auch 
(Vielleicht Drossel nicht richtig ausgelegt). Weiß jemand einen Grund?


m-obi

: Verschoben durch Admin
Autor: Matthias Lipinsky (lippy)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Entweder ist der R42 falsch dimensionert, oder aber in Programmzeile 42 
ist ein Tippfehler...

Autor: Mathias O. (m-obi)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Joker ;)

Der Code funktioniert, das Brummen kommt entweder vom Triac oder MOC, 
das hört man. Am Code kann das nicht liegen.

Autor: Chris W. (squid1356)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hm, also ich habe ja keine Ahnung wie STARK es bei dir brummt, aber ich 
habe auch noch nie einen Dimmer (jeglicher Art) "gehört", der NICHT 
brummt.

Brummt es denn sehr stark? Wird der Triac ungewöhnlich heiß?

Die Drossel dient übrigens nur zum entstören, hier werden die 
hochfrequenten Anteile, die durch die steilen Flanken des 
Phasenanschnitts entstehen, herausgefiltert.

In "billigen" Dimmern brummt trotzdem oft gerade diese Drossel 
(zusätzlich), weil die Wicklungen nicht stramm genug auf dem Kern 
sitzen. Ich habe durch vergießen solcher Drosseln schon öfter die 
gröbsten Störenfriede besänftigen können.

PS.: Ich glaube kaum daß der MOC brummt, das ist lediglich die 
Ansteuerung deines TRIAC.

Schaltung, Bild etc. würde helfen...

Autor: Mathias O. (m-obi)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also eins kann ich sagen, das Brummen ist abhängig vom Zündwinkel. Am 
lautesten ist es bei 90°.

Bilder mach ich noch.

Schaltplan hab ich den genommen:
http://pcdimmer.pc.ohost.de/schaltplan/pc_dimmer_d...

Autor: juppi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo

Zündest du jede Halbwelle?

MfG

Autor: Lothar Miller (lkmiller) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Also eins kann ich sagen, das Brummen ist abhängig vom Zündwinkel.
Ist das eher ein "Brummen" (tieffrequent)
oder ein "Knistern" (hochfrequent)?

Mach mal den Snubber raus (C502).
Evtl. neigt der C502 zur Mikrofonie, was ist das für einer? Ein Kerko?

Autor: Mathias O. (m-obi)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ja ich zünde jede Halbwelle.
Es ist ein Brummen, ich denk mal so 100 Hz.
Heute Abend mach ich mal den Snubber raus, bin grad nicht zu Hause.

Autor: Mathias O. (m-obi)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hab denn C502 (im Bild links der Blaue) mal rausgenommen, aber das 
Brummen ist immernoch da, genauso stark. Hab ihn dann wieder 
reingemacht.


Hab auch ein paar Bilder gemacht:

Minimaler  Zündwinkel:
http://img6.imageshack.us/my.php?image=sdc11802.jpg

ca. mittlerer Zündwinkel (am lautesten):
http://img6.imageshack.us/my.php?image=sdc11804.jpg

Maximaler Zündwinkel:
http://img6.imageshack.us/my.php?image=sdc11801.jpg

Testplatine:
http://img6.imageshack.us/my.php?image=sdc11808.jpg


Erklärung zur Testplatine:

dicke rote Leitung: angeschlossen an Netzspannung
dicke blaue Leitung: angeschlossen am Verbraucher
dünne gelbe Leitung: angeschlossen am µC
dünne rote Leitung: angeschlossen an GND


Übrigens: Ich weiß, dass die Platine scheiße gelötet aussieht und die 
Farben von den Leitungen nicht ganz stimmen.

Autor: Ich (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das die Triacs Geräusche machen habe ich schon oft erlebt und das läßt 
sich nicht verhindern.

Falls das bei Dir auch so sein sollte hilft dann nur ein schallgedämmtes 
Gehäuse für den Steller.

Noch ein paar auffällige Sachen:

 - Kühlkörper für Triac fehlt
   (wenigstens ein kleiner, kenne Deine Last nicht)
 - die Kondensatoren sehen nicht aus wie für Netzspannung geeignet
   (die Widerstände eigentlich auch nicht)

Autor: Lothar Miller (lkmiller) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Dieser rote Keramik-Scheiben-Kondensator ist der schönste Lautsprecher, 
den ich je gesehen habe ;-)
Ersetz den mal durch einen Folien-C. Und dann schliess den roten 
Piezo-Lautsprecher-Kondensator mal an die Stereoanlage an, du wirst dich 
wundern.

> - die Kondensatoren sehen nicht aus wie für Netzspannung geeignet
besonders der klitzekleine blaue Snubber  :-o

Autor: Mathias O. (m-obi)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also den roten habe ich gegen ein Folienk. ausgetauscht und siehe da 
kein Brummen mehr, gar nix. Nur wenn man mit dem Ohr ganz ganz nah ran 
geht, dann hört man noch ein kleines brummen, aber ganz wenig.
Die anderen Bauteile halten aber, auch der blaue Kondensator und die 
Widerstände. Den Triac spendier ich später noch nen Kühlkörper, der 
bekommt ne Last von 300 Watt. Soll ich den blauen Kondensator trotzdem 
austauschen?

Autor: Chris W. (squid1356)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
du solltest die kondensatoren auf Netzspannung ausrichten, und mal die 
Widerstände kontrollieren, ob 1/4W bei allen reicht.

...und das Ohr nicht zu nah ran, sonst knallts ;-)

Autor: Mathias O. (m-obi)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe diesen Folienk. statt des Scheibenk. eingesetzt.

Autor: Lothar Miller (lkmiller) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Also den roten habe ich gegen ein Folienk. ausgetauscht und siehe da
> kein Brummen mehr, gar nix.
Also gut, aber das ist dann kein "Brummen".
Brummen ist, wenn z.B. eine dicke Baumaschine an dir vorbeiruckelt.
Brummen ist mechanische Bewegung.
Brummen ist niederfrequent.

Das was du gehört hast, ist ein 50Hz (oder eher 100Hz) "Knistern".
Denn so richtig in den Bassbereich reicht dieser rote Lautsprecher nicht 
;-)

Autor: Lothar Miller (lkmiller) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Mathias O. wrote:
> Ich habe diesen Folienk. statt des Scheibenk. eingesetzt.
Jo, der reicht: 630VDC


Aber den armen kleinen blauen keramischen, den solltest du dir auch noch 
anschauen...

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.