mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik AVR Olimex AVR-P40-USB m. ATmega32: Target not powered?


Autor: Semiconductor (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo

ich probiere verzweifelt mit AVR Studio über ein AVRISPmkII über ISP auf 
einen ATmega32 zuzugreifen, der sich auf einem Olimex AVR-P40-USB 
befindet. (Infos und Schaltplan des boards: 
http://www.olimex.com/dev/pdf/avr-p40-usb.pdf)

Den USB-Anschluß des Olimex-Boards verwende ich nur für die 
5V-Stromversorgung. Ein Spannungs-Meßgerät zeigt an, daß auf dem VCC gut 
5V anliegen, also dürfte es über genügend Saft verfügen. Über ISP 
schließe ich den AVRISPmkII an. AVR Studio meldet auch eine Verbindung, 
aber es ist ja nur die Verbindung zum AVRISPmkII. Es ist jedoch nicht 
möglich, z.B. die Signatur des uC zu lesen, und ich kriege nur die 
Fehlermeldung "... target not powered?" und einen Hinweis, daß 
wahrscheinlich die fuse-bits keinen ISP-Zugang erlauben.

Ich habe jedoch 3-4 neue ATmega uC, und keiner von diesen funktioniert. 
Glaube nicht, daß die uC alle so ausgeliefert werden, daß per default 
kein ISP Zugang möglich ist, oder doch?

Vermute, daß es am Olimex Board liegt. Aber die Pins usw. sind richtig 
verbunden, und Spannung liegt ja nun auch an. Fehlt noch ein 
entscheidendes Detail? Hat jemand ähnliche Erfahrungen gemacht?

Viele Grüße
Semiconductor

Autor: ... ... (docean) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
isp frequenz runtergestellt?

UND:
http://www.mikrocontroller.net/articles/AVR_Checkliste

Autor: Semiconductor (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi

danke für die schnelle Reaktion.

Ja, die Frequenz habe ich runtergesetzt. Auf dem Olimex board ist ein 
Quarz mit 10MHz, ich habe alle möglichen Frequenzen ausprobiert, alle <= 
1/4 * 10 MHz.

Aber das hat nicht geholfen.

Mittlerweile glaube ich, daß es doch was mit dem Board zu tun haben muß. 
Aber wenn der uC unter Spannung ist und die Verdrahtung paßt, muß es 
doch funktionieren...?

Gruß
Semiconductor

Autor: Norgan (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
VTG auf dem ISP-Konnektor des Boards nicht angeschlossen?

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.